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OVERVIEW: COMMON ACTIONS 

This document provides new developers with a quick reference to some of 

the most basic tasks associated with a new implementation of the CMS. The 

“common actions” included here consist of those activities that virtually all 

developers will need to perform when building a CMS. 

Each of the common action topics include (when applicable): 

 A description of the activity 

 Common errors 

 Best practices 

 Reference to other related modules in the manual 

 

ORGANIZATION 

The manual itself is organized according to the CrownPeak CMS construction 

methodology, which consists of three distinct phases:  

 

Each phase has a specific purpose and builds upon the previous phase as 

the developer readies the CMS to hand off to the client. 

For a more detailed view of this approach, refer to the Construction Phase 

Overview Chart that appears below.  The illustration is designed to give the 

new developer an “at-a-glance” view of the process of building a CrownPeak 

CMS, from the delivery of HTML by the design agency, to publishing pages as 

the live site is deployed: 

 

 

Implementation Phase 1. Analyze the HTML 

2. Build Templates 

3. Create Models 

4. Configure the CMS 

QA Phase 5. Assemble Assets 

6. Complete the Workflow 

Deployment Phase 7. Publish to Stage and Live Sites 
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ANALYZE EXISTING SITE: DEGRADING 

THE HTML LAYOUT 

There may be page layout elements that need to be added or removed 

based on changing page content supplied by CMS end users. This commonly 

occurs, for example, when a certain image can be optionally included with 

content. To prevent broken images on the published site, the <img> tag 

should be removed from the output. 

BEST PRACTICES 

Use If statements to check the value of optional fields in the output. The 

syntax should be: 

 if content.item("fieldname") <> "" then 

{statement} end if 

 

COMMON ERRORS 

Be careful not to make the following syntax errors in your If statements: 

 If content.item("fieldname") = null then {statement} end if 

 If isEmpty(content.item("fieldname")) then {statement} end if 

 

RELATED MODULES 

 Build Templates: Creating a Navigation Wrapper 
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BUILD TEMPLATES: CREATING AND 

USING LISTS 

Lists are used to enumerate and loop through content. They are best used in 

situations where the CMS end user needs to include a multiple of a specific 

field or content. For example, you would include a list in a template for a 

slideshow, where the user will upload any number of images or use it for a 

list of related links. 

 

BEST PRACTICES 

 Use the Code Wizard to create your list. 

To access the Code Wizard, click the          button in the Developer’s 

Environment. Locate the List Panel widget: 

 

 

 

 

 

 

 

 

 

 

 

 

 To include additional fields in your list, move the cursor to the desired 

point in your code, and use the Code Wizard to add them. The Code 

Wizard adjusts the input code to fit into your list. 

 You can also nest lists (lists of lists). Below is an example of a simple 

embedded list in the input.asp. It is important to remember that, with 

embedded lists, while your first list is created via set list = 

content.createList(), the embedded list refers to its parent 

(list.createList()): 
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<% set list = content.createList("list") %> 

 <% do while list.nextPanel() %> 

 <table width="100%" class="tabletext"> 

  <tr> 

   <td>List</td> 

   <td> 

    <input name="list" size="50" value="<%= 

list.escapeItem("list") %>"/> 

   </td> 

  </tr> 

   

 <% set embedded_list = 

list.createList("embedded_fields") %> 

 <% do while embedded_list.nextPanel() %> 

 <table width="100%" class="tabletext"> 

  <tr> 

   <td>Embedded Fields</td> 

   <td> 

    <input name="embedded_fields" size="50" 

value="<%= 

embedded_list.escapeItem("embedded_fields") %>"/> 

   </td> 

  </tr> 

 </table> 

 <% loop %> 

 

 </table> 

 <% loop %> 

 To display the code in the output, iterate through your list as follows: 

<% set list = content.createList("list") %> 

   <% do while list.nextEntry() %> 

     <%= list.item("list") %> 

   <% loop %> 

 You can also use conditionals to add code at certain points of your list 

(for example, create a new table row every nth element of the list). 
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COMMON ERRORS 

When working with lists, try to avoid: 

 Referencing a list using the content object instead of the list object (for 

example, content.item instead of list.item. This will only display the first 

element of a list. 

 Forgetting the loop statement at the end of your “Do While 

list.nextEntry()” loop (especially with embedded lists) 
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BUILD TEMPLATES: CREATING A SEED 

ASSET 

Creating new assets is a central function within the CMS. The most basic 

method is creating a seed asset. 

STEPS 

To create a seed asset: 

1. Create an empty text file on your desktop. 

2. In the CMS, choose File > New > Upload. (Note if the new upload does 

not show in your folder check your access permissions it may be turned 

off.) 

The following screen appears: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click Browse to select the empty file you created and click Save.  

4. Select (highlight) the asset. 

5. Choose View > Properties > Template. 

The Template Properties screen appears: 
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6. Assign the desired template to the asset and click Save. 

7. Select (highlight) the asset. 

8. Choose View >Properties> Workflow. 

The Workflow Properties screen appears: 

 

 

 

 

 

 

 

 

 

9. Assign a workflow to the asset and click Save.  

10. Select (highlight) the asset. 

11. Choose Edit > Rename. 

12. Type in the new name and click Save. 

 

BEST PRACTICES 

 Use models to streamline the process for creating assets that are 

frequently created in the CMS. 
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 Use the method described above for creating one-off or special files (for 

example, a home page) 

 After creating a new asset, remove the reference to the seed asset to 

prevent the empty file from publishing out with your asset: 

1. Select (highlight) the new asset. 

2. Choose View>Properties>Content. 

3.  The Content Properties screen appears. There will be a field listing 

out the seed asset. 

4. Select (highlight) the asset field. 

5. Choose Edit > Delete Field: 

 

 

 

 

 

 

Should we make a point of saying its best to create one seed file and then 

store it in the system folder and copy it from there when we need a new file. 

 

RELATED MODULES  

 Create Models: Adding and Configuring a Model 
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BUILD TEMPLATES: APPLYING 

DEBUGGING TECHNIQUES 

When building templates, it is inevitable that you will need to perform some 

troubleshooting in order to fix bugs. There are several ways to do debugging 

in the CMS. Developers should use whatever methods work best for their 

specific situations. 

 

BEST PRACTICES 

Here is a list of the most common troubleshooting approaches (in no 

particular order): 

 Debug Console 

The Debug Console is launched by choosing System > Tools > Debug 

Console. A separate window opens where output from “debug.log” 

<%debug.log “Hello World”%> or <%debug.log 

content,item(“_cmsFolder”)%>statements in the templates is displayed: 

 

 

 

 

 

 

 

 

 

The console shows the time at which the statement executed, as well as the 

time between writes to the debug window, giving some indication as to 

performance.  

The debug console is useful for debugging scenarios in which any output to 

the CMS Preview or published page would be undesirable. It is also useful 

for debugging template files such as post_input.asp which has no direct-to-

screen output.  
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Note: There are occasions where debug.log output is not written to the 

window due to the polling frequency of the window, which may make it less 

ideal for debugging certain types of errors. 

 The ### Method 

In many instances, there is no substitute for seeing code or debugging info 

directly within the page. Sometimes the best way to start the debugging 

process is to enter a few “#” (or other characters) into the page to see where 

and how they appear when the page is rendered. This method is particularly 

valuable when troubleshooting conditionals or do-while loops. 

Note: These characters could also be hidden in HTML comment tags to help 

mask their output from other users of the CMS. This could be useful if the 

content on which you are working is for a live site and you don’t want to 

interfere with the normal content management. 

 Loop Debugging 

Be sure to make use of the following system variables in order to determine 

if your list has any elements, and which items are being printed: 

 Print out the size of a list using size() 

Format: list.size() 

 Print out the index of the current item using itemIndex 

Format: list.itemIndex 

 “Bit-by-Bit” Method 

For bugs in complex CMS or HTML code, the best debugging strategy can 

often be to start reducing down the code in the template (either by deleting 

or commenting), and gradually adding lines of code back in to see where the 

error occurs. This can occur a number of ways by reverting back to the 

original code to breaking down the HTML by cutting in half preview the 

document and then preview the document until the error is resolved now. 

When that happened you can further narrow the code down to the specific 

element causing the issue. 

 External Debugging 

Sometimes, the best approach to debugging HTML, JavaScript, CSS errors or 

other issues (i.e., with include files) might be to begin outside the CMS. 

External debugging can be faster at times, especially if the errors are in 
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pages that take a long time to publish. Once the errors are solved externally, 

you can migrate the updated code back into the CMS. 

 Content.Dump 

This can be used to show all the fields that are in the content object, a 

similar trick to this is also use the debug.log content and the user will see a 

dump of all the content fields in the debug window. 

 Multiple Windows 

For virtually all types of debugging, it is advisable to use multiple CMS 

windows (or tabs in Internet Explorer 7). This allows you to switch back and 

forth quickly between your template editor and CMS Preview. 

 The CMS ID  

You should include the CMS ID when confronted with errors that might be 

intermittent in nature. In fact, it is advisable to add the CMS ID 

(content.item(“_cmsId”)) to an HTML comment in the output code. Then you 

are able to look for the ID on published pages and quickly correlate the issue 

back to a specific asset and template once it is found. 

 

COMMON ERRORS 

The most common error during debugging is failing to remove your 

debugging statements from code. Always be sure to clean up after yourself. 

One common error is that you are debugging the wrong template; always 

view the general properties on the file to verify if you are editing the correct 

template 

Keep in mind that while debug.log statements will not publish out, if they are 

not commented or removed, they will be rendered by the CMS and will 

adversely affect performance. 

Also, be sure to make backups of templates before debugging. Even though 

versioning can be used to revert as well, having a cloned version of a 

template can be a faster method of restoring code in some instances. 
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BUILD TEMPLATES: CUSTOMIZING 

WYSIWYG FUNCTIONS 

In the template, a developer can customize the WYSIWYG functions being 

displayed by removing them altogether, restricting access to functions based 

on group configuration (“old” WYSIWYG only), or by dynamically including or 

removing functions based on user information. 

 

BEST PRACTICES 

 Use the Code Wizard to generate the WYSIWYG field. Include all possible 

functions in the generated code. Then manually remove unnecessary 

functions by commenting them out. This approach makes it easier to 

reactivate disabled functionality at a later date. 

 Build includes for commonly used WYSIWYG configurations. Requests 

for WYSIWYG changes usually mean changes to all your templates that 

use WYSIWYG’s. By using an include, you can make these changes 

quickly without editing each template individually.  

Only use the parameter configurations in your include. In this way you 

can reuse them across templates. Separate templates might have 

several WYSIWYG’s and, thus, different variable names for each 

WYSIWYG. 

 If your site uses CSS for formatting, you might not need many of the 

WYSIWYG functions. For example, in many cases you can probably omit 

the table and bulleted-list functions. By keeping the number of 

WYSIWYG functions small, you can help ensure that users focus on 

managing the content and not the design—since design should be 

enforced by your CSS. 

 You can use the input.setStyleSheetMenuItem parameter to add custom 

options to the Styles menu of the WYSIWYG. This parameter takes two 

arguments: the name of the class to be inserted and the name of the 

tag to use.  

A sample line might look like this: 

input.setStyleSheetMenuItem “address”, “div” 

Note: This must correlate to classes in your stylesheet referenced by the 

nput.setParam stylesheet parameter.  The input.setStyleSheetMenuItem 

code can be placed after the input.setParam parameters but before the 

input.addTextAreaButton parameters. 
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 Although the WYSIWYG allows for several paste options, the Text Only or 

Text With Breaks options are usually the best choices. Either of these 

will help to ensure that the text is pasted properly, with as little 

extraneous code as possible, resulting in fewer (if any) conflicts with 

your CSS. 

 

COMMON ERRORS  

 When using custom CSS classes, remember that many CSS files are 

built to require additional page context in order to determine their style.  

One CSS class might be constructed in a way that requires nesting 

within another tag or CSS class in order to understand its position in the 

document and how it should be rendered. Because the WYSIWYG view 

in the input template is only a subset of the document, not all CSS 

classes will render properly in this view. This is a natural result of not 

having the full document context in place. However, the content should 

render properly once viewed within the CMS Preview (when the full 

context should be in place). 

 Not using includes (see the Best Practices section above to review the 

value of includes). 

 Do not give users too many WYSIWYG controls. This frequently results in 

pages that break the Web site’s design conventions. 
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BUILD TEMPLATES: PAGINATION 

The CMS has built-in constructs for paginating content. This can be useful for 

breaking up content into multiple pages, or for handling content like photo 

galleries.  

Note: Consult the API Reference Guide for detailed code examples on 

pagination. 

 

BEST PRACTICES 

Pagination is best used for content stored in list constructs within the same 

asset. It is not ideal for aggregating content from separate assets. In those 

cases, building a separate template to act as an index is best. 

Also, be sure to account for the effects of pagination when naming your files. 

It is best to let the CMS handle that aspect of file naming for you. You will 

likely need to use a portion of the preset cmsPublishPath value to ensure 

you get the automatic page numbering generated by the CMS. 

 

COMMON ERRORS 

Do not use pagination for content in multiple assets. Again, pagination works 

best with content contained in lists in a single asset. 

Also, keep in mind that pagination code does some of its work in the CMS 

Preview by passing arguments between pages. This does NOT happen in the 

published code. Be careful that you don’t do a lot of work getting your 

pagination to work in CMS Preview (using pagination parameters) and forget 

that those parameters will not work when the files are published.  
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BUILD TEMPLATES: CREATING A 

NAVIGATION WRAPPER 

In any CMS implementation, one of the first steps in template development 

should be to create a navigation wrapper. The navigation wrapper includes 

layout elements that appear on every page of the site, and is included in 

each template that uses the system.wrap API function.  

The navigation wrapper generally includes the header, footer, and 

navigation. 

 

BEST PRACTICES 

You should review wireframes and HTML in order to determine elements of 

the page that should be included in the navigation wrapper.  

Note: Review existing templates within the CMS for examples of navigation 

wrapper implementations. 

 

COMMON ERRORS 

 Too Much or Too Little in the Navigation Wrapper 

It is usually a good idea to separate page headers and footers into 

separate templates instead of integrating them into the navigation 

wrapper. Separate files allow you to create includes on the live site so 

that changes to the header and footer can be deployed universally by 

republishing a single file instead of the entire site. 

 Trying to Build a Navigation Wrapper Without Access to All Page Types 

Occasionally, developers try to create a CMS without having all of the 

client’s page type HTML. This is usually done to accommodate the 

client’s schedule. The pitfall in implementing a CMS without reviewing all 

page types, however, is that you end up working with only a portion the 

necessary information.  

Additional common elements are typically revealed through an analysis 

of all possible page types. 
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BUILD TEMPLATES: UPLOADING AND 

RESIZING IMAGES 

CMS end-users can upload images into the system using Image Upload 

interface. The interface can be added to a template using the Code Wizard 

and selecting Image Upload: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Code Wizard inserts the appropriate code into the input and output files 

in the template. The most basic implementation of the interface will allow a 

CMS end user to upload a graphic into the asset or to link to an image in the 

assets folder.  

You can also automatically adjust the size of an image using the Thumbnail 

or the Resize Image options. When you select these options, new images are 

created and added to the system in addition to the original image. The Code 

Wizard automatically inserts the appropriate code into the upload file—as 

well as into the input and output files of the template. 
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Note: Make sure you leave upload.asp selected. If you crop or create a 

thumbnail, keep post_input.asp selected as well.  

 

BEST PRACTICES 

 It may be better to have separate input fields for the full-size and 

thumbnail images (have the user do the resizing) since auto-generated 

thumbnails tend to look grainier. 

 Resized images maintain the original aspect ratio, so the final 

dimensions may not match (for example, a 200x125 image will not 

resize directly to 100x100). 

 Clients often ask for the dimensions of the image be placed in the input 

template so get in the habit of placing the recommended image height 

and width (for example, H:234 W:453). 

 If an image has to be resized and constrained to a certain height (or 

width) while preserving proportions, set the height (or width) to the 

desired height (or width) and the width (or height) to 1000px. The image 

while be resized to the desired height and the width will remain 

proportional. 

 

COMMON ERRORS 

 When you create a thumbnail or resize image, the CMS will 

automatically create a new field for the alternate version of the image. 

Make sure you refer to the correct field name when displaying the image 

in the output. 

 When creating thumbnails or resized images with the Code Wizard, 

make sure that “upload.asp” and “post_input.asp” are checked in the 

“Affects”  area of the Insert Image Upload Code dialog.  This will ensure 

that the Code Wizard generates all the code you will need for properly 

generating the thumbnail and/or resized image. 

 The image upload wizard by default allows users to upload and browse 

to existing image assets in the CMS. Linking to images via the browser 

does not trigger the resizing. To avoid this, turn off linking and force the 

user to upload images into the asset. 

 If you have more than one upload in a template, you should modify the 

upload file to include if statements so the correct field is modified. For 

example: 
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if content.item("_cmsUploadVariable") = 

"upload#piece_thumbnail" then {statement} end if   
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BUILD TEMPLATES: ADJUSTING 

TEMPLATE CODE 

Once a CMS is implemented, you may need to adjust templates to address 

new client input or layout requirements. 

 

STEPS 

To identify what template is controlling the look and behavior of an asset: 

1. Open the asset. 

2. Chose View > Properties > Template. 

The Template Properties page appears: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the Template Properties section you can see the name, location, and ID of 

the template. 

To open a template for editing, use one of the following methods: 

1. Navigate to the /System/Templates folder.  

2. Select (highlight) the template file you want to edit.  

3. Choose Edit > Edit. 
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Or,  

1. Navigate to the folder containing the asset that uses the template you 

want to modify. 

2. Select (highlight) the asset. 

3. Choose Edit > Edit Template. 

 

Either of these methods opens the CMS Template Editor, where you can 

make your code modifications. 

 

BEST PRACTICES 

It is a good idea to keep two browser windows open, side by side: one with 

the asset or page that uses the template and the other with the template 

code. It makes it much easier to refresh the asset and test the template 

changes.  

When working on significant changes to a template that control assets that 

your clients are either actively working on or that are LIVE, you should make 

clones of the template folder and assets. 

To make the clones: 

1. Right-click on the template folder and select Clone. 
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2. Right-click on the asset and select Clone. 

3. Select (highlight) the cloned asset. 

4. Choose View > Properties>Template: 

 

 

 

 

 

 

 

 

 

The Template Properties screen appears: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Apply the new template clone and click Save. 

You can now use the two clones in concert for testing your code changes 

without disrupting work your clients may be doing or affect assets going out 

for publication that use the template you are working on.  
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Once the clients approve your changes, you can either replace the template 

files in the original template folder with your new ones, or apply the cloned 

template file to all of the original assets.  

Note: It is usually easier to replace the old files with the new clones, but be 

sure to back up the original template files in the template folder just in case 

you need them (for example: rename the old output.asp to output-bak.asp). 

 

COMMON ERRORS 

As mentioned above, the most common problems occur when working on a 

template that controls live assets currently in the act of publishing or that 

are being edited by the client. Be sure to work in a window of time when 

clients and publishing are not active—or use the recommended cloning steps 

to avoid conflicts. 

 

RELATED MODULES 

 Build Templates: Creating a New Asset 
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BUILD TEMPLATES: RELATED LINKS 

A common requirement of templates is the ability to allow users to manually 

enter and arrange a list of related links. These links can be to external URLs, 

internal CMS pages, or they can link to an uploaded asset such as a PDF. A 

link may also be the type that generates a JavaScript popup window with 

various parameters turned on or off.  

Link functionality on a template can be implemented using a combination of 

code auto-generated by the Code Wizard. 

 

STEPS 

The first thing you need to do is get the core code in place on your input, 

output and post-input templates. To do this:  

1. Find or create the template with which you want to work. 

2. In your input.asp template, choose where you want to place the code on 

the input form by placing your cursor in that area. 

3. Click the Code Wizard button: 

  

The Code Wizard Menu pops up, displaying a library of code widgets.  

4. Scroll to the very bottom of the list to reveal a widget called Related 

Links: 

 

 

 

 

 

 

 

 

 

5. Click on Related Links.  

The Insert Related Links window appears: 

 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 29 

 

 

 

 

 

 

 

This window allows you to specify (if desired) a different name for the list and 

a default for the link type drop down menu (you should leave it set to None 

in most cases).  

6. Make sure that the input.asp, output.asp and post-input.asp are all 

checked in order to get updated with the code.   

7. Click Insert to update all three template files.  

The input will display the list panel to slot in/sort a list of links (each panel 

has a field to type in a link title and a link-type drop-down menu which 

triggers either a field to type in an external URL), to browse for another 

internal page or to upload a file.  

The post-input does not contain a good deal of code that helps to distill down 

the link types and title into just a couple of fields: related_link and 

related_link_title.  At the end of the code, the post-input adds each content 

field in the list by using: 

content.add "related_link:" & 

related_link.itemIndex, url 

content.add "related_link_title:" & 

related_link.itemIndex, title 

From here, some additional manual workarounds can be performed (if 

necessary): 

 The Code Wizard is not smart enough to know exactly where to place the 

code on the output, so be prepared to hunt down that piece of code and 

move it into the correct place. 

 There will probably be some unique style tags from your client’s HTML, 

for example, <li>, that also has to be manually inserted around the 

related links code in the output. 

 Some clients ask that for internal links the original title of the page 

being linked should be inherited, eliminating the need to manually enter 

that title.  
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The code has to check first for a manually entered title. If none exists, it 

should inherit the title from the internally linked page. This can be done 

using the following code: 

<%do while list.nextEntry()  

  link = asset.getLink(llist.item("related_link")) 

  if list.item("related_link_title") <> "" then 

    title = list.item("related_link_title") 

  else 

    title = 

asset.getContentField(list.item("related_link"),"ti

tle") 

  end if%> 

<li><p><a href="<%=link%>"><%=title%></a></p></li> 

<%loop%> 

 

COMMON ERRORS 

 Be sure that you use related_link_type as the field to set the list - not 

related_link.  The related_link_type will always be set to a value and 

because you are creating the list to iterate through, you do want to use 

related_link since the iterator cannot be empty. 

 Remember that the CMS displays links to all related pages in all 

workflow states, even if those pages are not Live. When the page 

publishes out, it only prints the links to pages that are Live. 

 

Related Modules 

 Build Templates: Creating and Using Lists 
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BUILD TEMPLATES: E-MAIL IMPORT 

A client may request the ability to have end users submit comments on 

articles contained on their Web site. A common approach is to have each 

comment e-mailed to the CMS and imported as an individual asset. The 

client would then approve the comments for publication and then republish 

the article with the new comments added. 

 

STEPS 

The first task is to set up an SMTP import in the CMS: 

1. Go to System > Configure > Import > SMTP. 

2. Choose File > New Email Import. 

The edit Email Import page appears and a token has been auto-generated: 

 

 

 

 

 

 

 

 

 

 

 

Note: You need to specify this token in the send mail portion of script in 

order to grant the import access into the CMS. 

3. Complete the following fields and click Save: 

a. Label (whatever you want to call this import) 

Folder (specify or browse to the folder where you want the 

imported assets to be stored)  

b. Model (specify the model/template that you will be using to 

interpret the fields of data that are in the imported assets) 

c. Note the email address of the server can be found in the 
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blue bar of the main section of the email imports. It is 

typically the client name @ advantage,crownpeak.com  

 

BEST PRACTICES 

 The comments form processing can be set up using various types of 

code—depending, of course, on the type of server on which it resides 

(Unix/Apache, Windows/IIS, etc).  

 When you create the link to the add comment form on the article 

template, be sure to append the CMS ID, article title and description, so 

the following: 

<a 

href="<%=asset.getLink("/Site/Issues/Articles/Comme

nts/Add 

Comment")%>?art=<%=content.item("_cmsId")%>&artTitl

e=<%=content.item("title")%>&artDesc=<%=content.ite

m("subtitle")%>"> 

Would translate to: 

http://www.clientsite.com/add-comment.php?art=1234& 

artTitle=This+Is+The+Title& 

artDesc=This+is+the+description 

The code for add comment form and processing is as follows (based on a 

Unix server running php): 

<?php  

 

// Configuration 

$fd_subject = "New Comment TKY7a4UB8cJRreST"; 

$fd_from_email = "pendingcomments@cp_sample.com"; 

//$fd_from_name = "Experience Life"; 

$fd_to_email = "ExperienceLife@cp_sample.com"; 

//$fd_to_email = "mckenna.developer@cp_sample.com"; 

$fd_body = $_POST['c_name']."*x*\n"; 

$fd_body .= $_POST['c_email']."*x*\n"; 

$fd_body .= date("F j, Y")."*x*\n"; 

$fd_body .= $_POST['c_message']."*x*\n"; 

$fd_body .= $_POST['art']."*x*\n"; 

$MP = "/usr/sbin/sendmail -t";  

  

if ($_POST['submit']){ 
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  $fd = popen($MP,"w"); 

  fputs($fd, "To: $fd_to_email \n"); 

  fputs($fd, "From: $fd_from_email\n"); 

  fputs($fd, "Subject: $fd_subject \n\n"); 

  fputs($fd, "$fd_body\n"); 

  pclose($fd); 

  }?> 

 

<div id="content" class="page05"><!-- pagetype 5 --

> 

   <div id="contentcolumnwide"><img 

src="/images/consistent/add_comment.gif" alt="Add 

Comment" /> 

    

   <?php if ($_POST['submit']){ 

    

     print '<p>Thank you. We have received your 

comment. It will be reviewed and published by the 

moderator.</p>'; 

     print '<p>Return to <a 

href="javascript:history.go(-2)">page</a></p>'; 

      

} else { ?> 

  

<div id="AddCommentFormContainer">  

<form id="AddCommentForm" name="AddCommentForm" 

method="post" action="<?php echo 

$_SERVER['PHP_SELF']; ?>" onsubmit="return 

validateForm(this, false, false, false, true, 

16);"> 

<div class="error"><ul id="errors"></ul></div> 

<h3 style="width:377px;text-align:left;">You are 

commenting on:</h3> 

<p style="width:377px;text-

align:left;"><strong><?php echo $_GET['artTitle']; 

?></strong><br /><?php echo $_GET['artDesc']; 

?></p> 

<input type="hidden" name="submit" value="true" /> 

<input type="hidden" name="art" id="art" 

value="<?php echo $_REQUEST['art'];?>" /> 

<table border="0" cellspacing="0" cellpadding="0" > 

<tr><td align=right></td><td 

style="width:6px;"></td><td><p class="required" 
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style="text-align:center;">Blue fields 

required</p></td></tr> 

<tr><td align=right><p class="required">Your 

Name</p></td><td 

style="width:6px;"></td><td><p><input type="text" 

style="width:300px;" name="c_name" id="c_name" 

emsg="Your Name cannot be blank" alt="blank" /><br 

/><i>(Your name will be displayed with your 

comment;<br />please include it as you would like 

to appear on-screen.)</i></p></td></tr> 

<tr><td align=right><p class="required">Your Email 

Address</p></td><td 

style="width:6px;"></td><td><p><input type="text" 

style="width:300px;" name="c_email" id="c_email" 

emsg="Your email cannot be blank" alt="blank" /><br 

/><i>(Your email address will not be shared. We 

only ask for it<br />so we can get in touch with 

you if you have questions.)</i></p></td></tr> 

<tr><td colspan="3" align=right><p 

style="width:377px;text-align:left;"><span 

class="bold" style="color: #00416E">Comment</span> 

(limit 1500 characters)</p></td></tr> 

<tr><td colspan="3" align=right><p><textarea 

name="c_message" id="c_message" cols="30" rows="7" 

emsg="Comment cannot be blank" 

alt="blank"></textarea></p></td></tr> 

</table> 

<table border="0" cellspacing="0" width=352 

cellpadding="0"> 

<tr><td align=right><input type="image" 

src="/images/consistent/submit.gif" /></td></tr> 

</table> 

</form> 

</div> 

 

<?php } ?> 

Your “comment” template has to include an smtp-import.asp file. This file 

should contain the following code: 

<% 

 

txt = Split(content.item("_cmsEmailBody"), "*x*", -

1, 1) 

 

content.add "commenter", txt(0) 

content.add "email", txt(1) 

content.add "date", txt(2) 
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content.add "comment", txt(3) 

content.add "articleID", txt(4) 

 

content.add "_cmsLabel", txt(3) 

 

%> 

When a user submits a comment and the email successfully hits the 

established import, the corresponding Hits column on the Email Imports 

page is incremented. 

 

 

 

Note: You can right-click to “trigger” the import if you do not see the 

imported asset there already. 

 

FTP IMPORTS 

FTP imports are similar to SMTP imports, but the data enters the CMS via 

FTP instead of by e-mail. The recommended format for this remote file is 

*.csv or comma delimited or XML.  

When you create a new FTP import in System > Configure > Import > FTP, 

additional fields are used to specify authentication to an external server on 

which a data file is residing. Triggering the import will make the CMS connect 

to the remote file and import it in to the CMS. The remote file needs to have 

the correct import TOKEN in it somewhere in order to be granted access into 

the CMS. The template referenced in the model that the FTP import uses has 

to have a supporting template file similar to smtp_import.asp, but in this 

case the file is called ftp_import.asp.  

Here is an example of ftp_import code from a project that takes the data 

from the import and translates it, creating in a folder a number of different 

“Issue” and “Article” assets. This creates the proper relationships between 

the assets (for example, the article “Hello World” may be a featured article, 

Issue #5). 

<% 

'======================================= 

' Title: /System/Templates/Upload Main 

Topic/ftp_import.asp  
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' Description: used to import remote FTP files into 

the CMS by polling remote FTP sites.% 

' **Logic: Create MainTopic and Volume/Issue assets 

and relate them 

' MRHEE:07/10/2007: Per Client: Create an asset for 

each (1)issue and each (2)topic, and 

'          relate (3)each issue with each topic and 

(4)each topic with the issue. 

' v.1.1 

'======================================= 

%> 

<% 

 

 

Dim csvContent 

Dim list 

Dim sCount 

 

Dim new_fields  

 

Dim assetTopicId 

Dim assetTopicLabel 

Dim assetTopicFolder 

Dim assetTopicModel 

Dim tFields 

Dim tList 

 

Dim assetIssueId 

Dim assetIssueLabel 

Dim assetIssueFolder 

Dim assetIssueModel 

Dim iFields 

Dim iList 

 

csvContent = content.item("_cmsFtpBody") 

 

assetTopicFolder = "/Site/Publications/The Dental 

Advisor/" 

assetTopicModel = "/System/Models/Main Topic 

Article/Main Topic Article" 
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assetIssueFolder = "/Site/Publications/The Dental 

Advisor/" 

assetIssueModel = "/System/Models/Issue/Issue" 

 

sCount = 0 

 

Set list = util.createListFromCSV(csvContent, ",") 

 

Do While list.nextEntry() 

  sCount = sCount + 1 

   

  ' init asset labels 

  assetTopicLabel = list.item("Topic") 

   

  sVolume = Trim(list.item("Volume")) 

  sIssue = Trim(list.item("Issue")) 

  'If Len(sVolume) < 2 Then sVolume = "0" & sVolume 

  'If Len(sIssue) < 2 Then sIssue = "0" & sIssue 

   

  assetIssueLabel = sVolume & "-" & sIssue 

   

  Set new_fields = list.currentEntry() 

   

  ' Topic Asset   

  If Trim(asset.getIdInFolder(assetTopicFolder, 

assetTopicLabel)) <> "" Then   ' Test for Null or 

Empty result 

    assetTopicId = 

asset.getIdInFolder(assetTopicFolder, 

assetTopicLabel) 

 

  Else 

    ' Create MainTopic Asset: 

    assetTopicId = asset.Create(assetTopicLabel, 

assetTopicFolder, assetTopicModel, new_fields) 

    asset.setContentField assetTopicId, "title", 

assetTopicLabel 

  End If 

   

  ' Issue Asset 
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  If 

Trim(asset.getIdInFolder(assetIssueFolder,assetIssu

eLabel)) <> "" Then    ' Test for Null or Empty 

result 

    assetIssueId = 

asset.getIdInFolder(assetIssueFolder,assetIssueLabe

l) 

  Else 

    ' Create Issue Asset: 

    assetIssueId = asset.Create(assetIssueLabel, 

assetIssueFolder, assetIssueModel, new_fields) 

    asset.setContentField assetIssueId, "Volume", 

sVolume 

    asset.setContentField assetIssueId, "Issue", 

sIssue 

  End If 

   

  ' Topics Relationships 

  set tFields = asset.getContent(assetTopicId)            

'The content object doesn't exist 

  set tList = 

tFields.createList("upload#featured_in_issue")     

'Content now does 

  asset.setContentField assetTopicId, 

"upload#featured_in_issue:" & tList.size()+1, 

"/cpt_internal/" & assetIssueId 

   

  ' Issues Relationships 

  set iFields = asset.getContent(assetIssueId)        

'The content object doesn't exist 

  set iList = 

iFields.createList("upload#select_doc")     

'Content now does 

    asset.setContentField assetIssueId, 

"upload#select_doc:" & iList.size()+1, 

"/cpt_internal/" & assetTopicId 

   

Loop 

 

%> 
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COMMON ERRORS 

The most common issues include: 

 Token does not match. 

 SMTP import code has the wrong content fields referenced. 

 SMTP has the wrong syntax. 

Note: Be sure to send a copy to your own e-mail when import errors occur. 

The CMS includes an error message with some details in that e-mail. Or you 

can click on the red error text in the CMS next to an import that failed. 

  



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 40 

BUILD TEMPLATES: FIXING ERRORS 

Various types of errors can occur in the CMS. Many are generated by user-

input content that “breaks” a form. Other types of problems come from 

template errors.  

The next section contains some strategies for determining from where a 

particular error might be originating, and how to go about solving it.  

Note: Whenever possible, be sure your clients have read the 

“Troubleshooting” document provided in the Help menu of the CMS. 

Strategies for Dealing with Errors 

When an error occurs:  

 Verify that the error does not occur in the original HTML. 

 Try to recopy the text from the original HTML. 

 Verify if the problem is in the CMS, on the site, or both. 

1 If it is in the CMS, try to verify if it is a template issue: It should 

probably appear in the input or output.asp, for example. 

2 Try to get a path and/or CMS ID from the client for the asset(s). 

3 If you get a CMS ID, you can use the File > Goto option (click 

Goto and enter the ID on the popup) to get to the file quickly. 

4 Try to get a screenshot if you can. 

5 Make sure you get the URL for their CMS instance. 

6 If possible, it is usually best to make clones of assets to do any 

testing on; chances are the client has a live site and if you can 

avoid disrupting the site, you should. 

 It is a good idea to wrap template changes you make in conditionals so 

they only show in a narrow area if possible. Also, wrap any debugging 

code in HTML comments if you can—or use the CMS Debugging tools. 

 Another useful approach is to delete half of the content and see if the 

error is resolved. Then, add content back until the error reappears. 

Continue this practice until the error is narrowed down to a specific line. 

 Send an e-mail to local CMS developers to ask colleagues for help. You 

can also post to the community forum. 
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BEST PRACTICES 

When dealing with errors, keep in mind the following useful tips: 

 Fix errors before importing them into the CMS. 

 Make sure the developer of the HTML has a site that you can access 

externally. 

 Make sure you have a staging site to where you can publish so that you 

can adequately test the code. For HTML errors, save your files as a 

HTML pages and/or publish them. Then create a base href for the CSS 

and JS back to the stage site 

 Isolate the error if it’s a stylesheet or JavaScript error; then add the full 

path to the design site and see if the error occurs. 

 Make sure with JavaScript file references (JavaScript “src” calls) that 

you are using a asset.setParam “link_type” include. 

 Use Firefox with extensions—specifically Web Developer 

(https://addons.mozilla.org/en-US/firefox/addon/60) and Firebug 

(https://addons.mozilla.org/en-US/firefox/addon/1843) with the files 

that are outside the system. 

 Use HTML validation. 

 Use the debug.log command to print out any errors 

This is useful when following a route through the page. Use debug.log 

“1” in your code to see if the page is running through successfully. 

 Use versions to go back to when the file was working correctly. 

 Make sure you have two windows open—one that is displaying the code 

and the other previewing the file whose template you are editing. Get in 

the habit of saving and reloading your preview page often to limit the 

amount of errors that crop up. 

 

COMMON ERRORS 

When trying to debug errors, check the following: 

 The last place you edited code is often where the error lies. 

 End tags—usually this type of error says “Expected statement” where the 

code is not properly closed. 

 If and end if tags must be closed. 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 42 

Note: Use the content.dump to see a list of variables and copy the value to 

your code. Sometimes a spelling mistake can be all that is causing the error. 

 

RELATED MODULES  

 Build Templates: Applying Debugging Techniques 
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BUILD TEMPLATES: CREATING TABBED 

INTERFACES 

The tab interface allows you to organize your input template into logical 

sections. Using tabs, the end user can navigate from one section to the next 

without a lot of scrolling.  

A tab interface is most easily created using the Code Wizard inside the 

developer template. 

 

STEPS 

1. Navigate to the folder that contains the template with which you want to 

work. 

2. Select (highlight) the template and choose Edit > Edit:  

 

 

 

 

 

 

 

 

3. Click the Code Wizard button: 

 

The Code Wizard menu pops up, displaying a library of code widgets.  

4. Scroll to the bottom of the list to reveal a widget called Tabbed Panel: 
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5. Click Tabbed Panel. 

The Insert Tabbed Panel window appears: 

 

 

 

6. Add as many sections as you need in the Tab Titles box.  

Note: You should keep the Tab names to a reasonable length—using 

specific keywords related to the section rather than full sentences. 

7. Click Insert. 

The following code is inserted: 

<% input.startTabbedPanel "General, Form, Right 

Side Nav" %> 

<!—General content inserted here -→ 

<% input.nextTabbedPanel %> 

<!—Form content inserted here -→ 

<% input.endTabbedPanel %> 

 

BEST PRACTICES 
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 A class=”hidden” has to be placed inside the HTML contained by each 

section tab – except for the first section tab. For example: 

<tr class=”hidden” align="justify" valign="top" 

bgcolor="F0F0F0"> 

 

For panels, use the panel style sheet: 

<% list.setParam "panel_stylesheet", 

"visibility:hidden; display:none;" %> 

 

 When inside the tabs, it is also a good idea to add content into a system 

include. For example, if you have a right nav tab you will probably need 

to add it to other templates. So, centralize the content into an include 

and link to the content. 

 

COMMON ERRORS 

If an item shows up on the wrong panel, make sure class="hidden" is 

embedded in the HTML TR Tag. 
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CREATE MODELS: ADDING AND 

CONFIGURING A MODEL 

Models are the basis for creating new content in the CMS. They can be a 

single file, single folder, or a complex structure of files and folders 

 

STEPS 

To create a new model: 

1. Go to the /System/Models/ folder. 

2. Choose File > New > Folder to create a new folder to contain your 

model. 

3. Enter the new folder name at the prompt and click OK. 

4. Choose File > New > Upload to add a seed asset (assuming you are 

creating a single-asset model). 

Or,  

Copy an asset from elsewhere in the CMS into your model folder. 

Note: Rename the asset if necessary to reflect its use (for example, 

“Press Release” for a new press release model).  Check the content 

properties (View >  Properties > Content) of the copied asset to make 

sure you are not inadvertently replicating existing data.  Any data in your 

model will be replicated in each new asset created using that model. 

5. Select (highlight) the asset. 

6. Choose View > Properties > Template interface. 

The Template Properties screen appears: 
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7. Assign the desired template to the asset and click Save. 

8. Navigate to the area in the CMS where you want to use the model.  

9. Select the appropriate folder (or if you are in the folder where you want 

to place the model), and go to View > Properties > Models.  

10. Select the folder of the model you created. 

 

 

 

 

 

 

 

 

 

11. Click Save. 

You should be able to see your model displayed under File > New. If you 

can’t, you might need to adjust access controls on the current folder, on the 

model itself, or both. 

 

BEST PRACTICES 

When naming items in the CMS, select names that will make sense to end 

users. Remember that those folder names and file names will appear on the 

File > New menu. 

As discussed in the Steps section, after you upload a seed asset and assign 

a template to it, remove the reference to the empty file used to seed the 

asset. Since the file is attached to any asset created from this model, 

removing it keeps a lot of unnecessary empty files from getting published 

out to the server. 

To remove the seed asset reference: 

1. Select (highlight) the new asset. 

2. Choose View > Properties > Content. 

The Content Properties screen appears. There will be a field listing out 

the seed asset. 
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3. Select (highlight) the asset field. 

4. Choose Edit > Delete Field: 

 

 

 

 

 

 

 

RELATED MODULES 

 Build Templates: Creating a New Asset 
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CREATE MODELS: CONFIGURING TO 

DISABLE “NEW DEPENDENCY” 

A model is a miniature representation of an asset or list of assets. It provides 

boilerplate content and settings.  

The power of models comes in when you use several prototypes (which the 

developer can choose) or when you have a collection of assets and folders 

that can have recursive model definitions.  

In this approach, CrownPeak CMS can create and entire folder structure 

when you choose the File > New menu option. The model allows a new file to 

be created with the access rights, content, and structure already predefined.  

Note: The model directory is located in /System/Models.  

 

BEST PRACTICES 

When working with models, consider these tips: 

 After applying a model, click the Refresh Folder button       so that the 

New > Model Item appears. 

 Make sure that the model is configured in View > Properties > Model. 

 In the Models directory, also create a section folder to store the models 

so that other Web sites can be added within the model folder. 

 Create a model for new folders and files instead of using the Access 

Properties > New folder so you can control the access permissions.  
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 View the properties content and remove any unwanted content. 

 Edit the content that can be continually typed in—it is easier to delete 

the file than to edit it. 

 Check the access permissions for your users as well as yourself; make 

use of the Assume Identity to log in as a specific user so that you can 

test the model access rights. 

 

COMMON ERRORS 

When working with models, the most common errors include the following: 

 Model does not show: 

Try clicking Refresh Folder. 

 More options than the specified model shows up: 

Check your access permissions and see if the access permission New 

Dependency is turned on. 

Note: Check your user access permissions—but keep in mind that, if you 

have administrative privileges, what works for you might not work for a 

particular group. 

 

RELATED MODULES 

 Build Templates: Creating a New Asset 
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CONFIGURE CMS: CREATING INDEX 

PAGES AND AUTOMATED LISTS 

Typically, a few templates in every CMS implementation contain automated 

document lists. For example, many clients include news stories or press 

releases on their sites. By using index pages, the newest items can be 

automatically added to the CMS. 

CMS template developers can generate automated lists using a number of 

API functions, including asset.getfilelist, asset.getlist, asset.createfilter. 

 

BEST PRACTICES 

 When using a filter to generate a list of assets, use asset.setParam 

"fieldnames", "_cmsid" before calling asset.getFilterList. This improves 

the speed of the filter by reducing the size of the list by just including the 

cmsid instead of the entire content object for each asset. Then, when 

looping through the list, use asset.getcontent or asset.getheader to get 

fields in the content object. 

 Check for valid list items by checking for a asset.getlink value for each 

item before printing into the output. 

 Copy the code from your inut.asp to reduce common misspelling error 

and code errors. Its best to make sure that the input.asp code is working 

correctly in the input that way you reduce the number of errors when you 

copy the code over to the output.asp 

 

COMMON ERRORS 

When using more than one list on a page, a typical error is to use the wrong 

list when looping through content. This usually occurs with object names like 

list1 and list2. To avoid this error, create list names that are descriptive. For 

example, if you have a list of press releases and a list of articles on the same 

page, call your press release list “Releases” and the article list “Articles.” 
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CONFIGURE CMS: ADJUST ACCESS 

PERMISSION FOR AN ASSET 

A CMS project may have specific requirements relating to who can view or 

modify certain types of content. The following steps outline the process for 

restricting access permission to assets in the CMS. 

 

STEPS 

To modify an asset’s access permissions (also referred to as the Access 

Control List or ACL): 

1. Select the asset or folder in question. 

2. Select View > Properties > Access. 

 

 

 

 

 

 

 

The Access Properties page appears: 
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The Access Properties page shows a matrix of the asset’s access properties. 

The rows represent each Group in the CMS, and the columns are groupings 

of individual permissions. Click on one of the column headers (View, Edit, 

Publish, Properties, Other) to expand the column to show all the individual 

permissions for that grouping. (Need an image here that shows that) 

You can click on the various check boxes to toggle a permission on or off for 

a specific Group in the CMS. Be sure to note that the access controls set at 

the Group level will affect which access properties you can control for 

members of that Group.  
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Also note that if the asset has workflow applied, you may or may not be able 

to modify certain access controls, depending on the current state of the 

asset. 

1. Adjust the asset’s access properties by selecting and/or deselecting the 

various check box options. 

2. Click Save. 

Note: To make adjustments to access controls for workflow states, go to the 

/System/States folder, and use the process described above. 

 

BEST PRACTICES 

It’s a good idea to set the access properties on certain workflow states so 

that when a document is Pending Review or is Live, it cannot be edited by a 

user (except perhaps by a high level administrator). If modifications need to 

be made to an asset, ideally it should be branched and run through the 

workflow process again. Talk to your client about how they prefer to control 

access at certain workflow states. 

Note: There are three tiers of access: group level, asset level, and workflow 

state level. You should create test accounts so that you can log in and verify 

what each type user can see and do.  
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CONFIGURE CMS: ADJUSTING 

PUBLISHING INFORMATION 

Publishing information for an asset can be configured in many places. This 

section reviews some quick things to check when needing to adjust how an 

asset publishes. 

STEPS 

 For Changes Relating to the FTP Server 

1. Go to System > Configure > Export > FTP. 

 

 

 

 

 

 

 

 

 

 

The FTP Server screen appears: 

 

 

 

 

 

2. Make any desired changes to the hostname, username, password, FTP 

type (normal or SFTP), any umask settings, and the path from ftproot to 

webroot.  

3. Use the Test buttons to be sure your changes are working properly. 

4. Click Save when you are satisfied with the results of your adjustments. 

If you added a server: 

1. Go to System > Configure > Package: 
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The Publishing Packages screen appears: 

 

 

 

 

 

 

 

 

2. Add or modify a Publishing Package to use the new server. 

If you added a package: 

1. Go to System > Configure > Workflow: 
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The Workflow List screen appears: 

 

 

 

 

 

 

 

 

 

2. Select (highlight) the desired workflow and choose Edit > Edit Workflow . 

 

 

 

 

 

 

 

 

 

 

The Edit Workflow screen appears: 
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3. Edit the workflow to include the new package in the appropriate 

workflow states. 

Be sure to go to the Publishing Properties of the asset (or the folder from 

which the asset is inheriting its publishing properties) and add the package 

to the configuration if needed: 

4. Select (highlight) the asset or folder. 

5. Choose View > Properties > Publishing. 

The Publishing Properties screen appears: 
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6. Add the package to the configuration if needed. 

 For Changes to the Publishing Path or Filename 

1. Select the asset or folder (highlight it). 

2. Choose View > Properties >Publishing. 

The Publishing Properties screen appears. 

3. Make the necessary changes to the path or filename. 

4. Click Save. 

If a .asp template file is in use (this will be indicated on the Publishing 

Properties screen), you will need to edit that file to make adjustments. Go to 

Edit > Edit Template to launch the template editor. 

 More on Publishing Properties 

HTML rows in the Publishing Properties have to do with how HTML or other 

template-driven output content is published. This is always text-based 

content (HTML, PHP, ASP, XML, RSS, etc.). The “Media” rows affect how any 

binary assets (PDF’s, Word docs, Flash, Images, etc.) are published out for 

the current asset. A template’s filename.asp, url.asp, assetfilename.asp, and 
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asseturl.asp overrides any settings directly input to the Publishing 

Properties. 

Note: The Publishing Properties interface allows you to specify to where an 

asset will be published (its filename). HTML pages and media files can be 

sent to different servers. Keep in mind that a template can have template 

files that override this information. The Server refers to a publishing package 

and not just an FTP server. 

 

BEST PRACTICES 

 Where possible, let the CMS determine the publishing information—

especially file naming. Remember that your content will grow over time 

and publishing configurations that are easy to manage at first will 

become more unwieldy as content grows. 

 You should also set up publishing package information to be inherited 

by child assets. This will make it easier to make change down the road. 

 It is also smart to use includes to help centralize file-naming logic. 

 

COMMON ERRORS  

 Do not delete packages as a quick fix for turning off publishing. You will 

lose all the configurations for that package in the publishing properties 

for folders and assets. This is NOT recoverable. You can just assign a 

package to have no FTP or other output servers and get the same net 

effect, without destroying your configuration. 

 Also, when debugging, work procedurally: Check the FTP server 

configuration, then the package mapping, then the workflow, and then 

the asset. Publishing is configured in several places and these places 

can be easy to overlook if you aren’t paying close attention. 
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ASSEMBLE ASSETS: UPLOADING AND 

RESIZING IMAGES 

CMS end users can upload images into the system using Image Upload 

interface. The interface can be added to a template using the Code Wizard 

and selecting Image Upload.  

Note: This topic is covered in the Build Templates: Uploading and Resizing 

Images section of this guide. 
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ASSEMBLE ASSETS: UPLOADING A NEW 

ASSET 

The term asset in the CMS refers to any file or folder contained in the CMS. 

This includes documents, images, video and sound files, JavaScripts, and 

CSS files. The process for adding assets described here refers to assets that 

will be published—but not directly edited—in the CMS.  

Note: Content that has to be edited in the CMS must be inserted using an 

asset with an assigned template. 

STEPS 

To add a new asset to the CMS: 

1. Navigate to the place where you would like to add the content (in either 

CMS Preview or Folder View mode). 

2. Choose File > New. 

 

 

 

 

 

 

 

 

 

In that drop-down menu, you can see the available options for what type of 

content can be added. 

3. Choose Asset. 

The following screen appears: 
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4. Click Browse and navigate to the asset you want to add. 

5. Select the asset. 

The Browse window closes and the name of the selected asset appears 

in the Filename box.  

6. Click Save. 

The selected asset is uploaded into the CMS 

Note: The New option might not be available in every folder—and therefore 

you might not be able to create content. This could be due to the way the 

CMS instance is configured and/or how the access controls are set at the 

folder, asset, or group level. 
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ASSEMBLE ASSETS: CREATING AND 

USING LISTS 

Lists are used to enumerate and loop through content. They are best used in 

situation where the CMS end user needs to include a multiple of a specific 

field or content. For example, you would include a list in a template for a 

slideshow, where the user will upload any number of images or use it for a 

list of related links. 

Note: This topic is covered in the Build Assets: Creating and Using Lists 

section of this guide. 
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ASSEMBLE ASSETS: UNDELETING A FILE 

Occasionally, you may delete a file in the CMS and later need to recover it. 

The steps described below outline the process for undeleting files in the 

CMS. 

STEPS 

To undelete an asset in the CMS: 

1. Navigate to the folder where the deleted asset was located.  

2. To activate the folder filter (if it is not already active), click Toggle Filter 

on the Path bar: 

 

 

 

3. Select Deleted from the Other dropdown menu and then click Go: 

 

 

 

 

 

A list of all files or folders that have been deleted from this folder appears.  

4. Select (highlight) the item you want to undelete. 

5. Select Undelete from either the Edit menu on the Main Menu Bar or the 

right-click menu: 

 

 

 

 

 

 

The item no longer appears in your view since you are still viewing only 

deleted items.  

6. Click Toggle Filter again to return to the normal view.  
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The item that you restored now appears in the list. 

Note: Remember that deleted items in the CMS are only kept for about 2 

weeks and then are permanently removed. It may be impossible to recover a 

deleted item if this time limit has been exceeded. 
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WORKFLOW: ROUTING AN ASSET 

If you have to move an asset to another step in the workflow—but need to 

bypass the existing workflow process, you can use the Route command. For 

example, you may want to move an asset from Retired to Live if a client 

accidentally retired the asset. 

STEPS 

To move an asset:  

1. Select (highlight) the asset.  

2. Choose Edit > Route.  

The Route interface appears, showing a list of all the steps in the current 

workflow: 
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3. Select the option button next to the step in which you want to move the 

asset and click Save.  

Important: Be aware that you are circumventing the normal workflow 

process by routing an asset, and may be bypassing approval processes or 

other operations that should normally be followed for that asset. You could 

be modifying data. Be sure you know what you are doing before routing 

content. 

 

BEST PRACTICES 

You should limit access to the Route command as much as possible. Since it 

circumvents the workflow, it can be a very dangerous tool in the hands of 

untrained users. 

COMMON ERRORS 

Try to avoid the following: 

 Routing too many assets when using the Also Apply Properties To 

checkboxes.  

 Accidentally removing an asset by routing it off the live site. 
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WORKFLOW: REPUBLISHING CONTENT 

CMS end users and developers occasionally need to republish the entire 

contents of a site or folder. CrownPeak CMS offers this shortcut instead of 

queuing and publishing each individual asset. 

STEPS 

To republish an entire site, or a subset of content: 

 Navigate to the folder containing the content you want to republish. 

2. With nothing selected, choose Edit > Republish. 

The Republish menu displays the names of the available packages: 

 

 

 

 

3. Choose the name of the package to which you want to republish.  

A confirmation box appears: 

 

 

 

 

 

4. Click OK. 

A publishing pop-up opens to give you status on the publishing. 

Note: The publishing is recursive from the folder in which you start. The 

system only publishes content that is: 

 Configured for publishing to the package you specified. 

 In a workflow state that allows publishing to that package. 

 

BEST PRACTICES 

In most environments, only administrative users should have the ability to 

republish sites or sections. 
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WORKFLOW: PUBLISHING AN ASSET 

There are times when your users will need to make an edit and immediately 

publish the updated content. From the Edit menu, you can enable the 

publish command that will push the content to the site. 

 

Check the workflow configuration and user preferences to make sure this 

option is available. 

 

STEPS 

To publish an asset in the CMS: 

1. Select the asset.  

2. Go to the Edit menu.  

If the asset has no workflow, there should be options to publish and/or re-

publish. Selecting one of these options publishes the asset to any servers 

that are configured for that asset.  

If the asset has workflow: 

3. Go to the menu item for the asset’s current state (non-current states are 

grayed out), and then to its submenu.  

From there, you should see options like Publish to Live or Redeploy to 

Live. 

4. Select one of these options to activate publishing for the asset.  

Note: If the options do not seem to indicate that the asset will be published, 

the asset might be in a workflow state that does not allow publishing. The 

asset should be moved through the workflow to get to a state that permits 

publishing. 

 

BEST PRACTICES 

To avoid publishing errors like the example shown below, be sure to set the 

publishing properties of an asset on the root folder. 
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COMMON ERRORS 

When publishing, the following errors may occur: 

 Generic Error on view output: “No states selected”  

To address this, change your default browse states: 

1. Choose System > My Account > Preferences. 

The Startup Preferences screen appears. 

2. Check the appropriate Browse states: 

  

 

 

 

 

 

 

3. Click Save. 

 Document Publishing properties contains a warning that the asset 

workflow does not use the Live Site: 

  

 

If you see this message, check the workflow properties and determine if the 

publishing information has not been set. Click the computer icon at the 

bottom of the workflow and select the appropriate package: 
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PUBLISH: CONFIGURING PUBLISHING 

Publishing properties are the configuration settings that determine the 

location where an asset is to be published—for both staging and deployed 

live. Additionally, the settings determine how a file is named. 

 

STEPS 

To access Publishing Properties: 

1. Select (highlight) the asset. 

2. Choose View>Properties>Publishing. 

The Publishing Properties screen appears: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The areas that can be deployed to are broken down into Staging HTML, 

Staging Asset, Live HTML and Live Asset. The HTML destination is where the 

assembled page will go, and the Asset destination is where any included 

files like GIF files will be published.  
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BEST PRACTICES 

 Limit the number of locations where you place the publishing 

information. Usually it is placed in the main Web site folder (the 

homepage and assets folders are all that need to be set because of the 

publishing’s recursive nature). 

Limiting the places where publishing information is set simplifies the 

publish settings.  

 Before publishing a file, view the publishing properties (choose View > 

Properties > Publishing) to verify that the publishing file is it turned on 

and that it will publish to the expected folders.  

 The rule of thumb when publishing is to: 

1 Check the FTP server (System > Config > Export > FTP). 

2 Check the package (System > Config > Package). 

3 Check the workflow.  

4 Check publishing properties (View > Properties > Publishing). 

Again, publishing is recursive. When viewing the publishing properties, 

pay attention to the Publishing Destinations section.  

 In System > Configure > Package, make sure that the live site is listed 

first so that when you view output the asset shows live instead of stage 

output (which can confuse the viewer). 

 When you publish, a pop-up window appears. This window allows you to 

monitor the status of the publishing process. You can close this window 

at anytime—and even log off the system—without interrupting the 

publishing process. 

 

COMMON ERRORS 

 Can’t find a page or the home page is missing: 

Check individual publishing properties. Sometimes a file can have a 

/index deep in the folder structure if it was cloned from somewhere else. 

Note: An index file that has cloned publishing information can possibly 

overwrite other index files if it is publishing to the root folder. The easiest 

way to fix this problem is to go to the site’s root folder and clear all the 

publishing properties. Then select Also Apply Properties To the rest of 
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the site (pay attention to the model as it could also contain unwanted 

publishing information): 

 

 

 

 

 

 

 Document shows a publishing error in the Status column: 

Click on the label to display an explanation of the error.  

 Generic Error on view output: 

“No states selected provide publishing information needed to render the 

output view of delete.”  

If this error occurs, change your default browse states under System>My 

Account > Preferences to select valid states. Make sure your publishing 

properties are set on the /Site folder. 
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PUBLISH: CHECKING THE FILENAME 

To check the filename of an asset, the best place to look is in the Publishing 

Properties. Although the General Properties shows similar information, the 

Publishing Properties screen contains the best calculation of the filename—

and also shows the URL as well (which could be different, depending on your 

configuration). 

 

STEPS 

To check the filename of an asset: 

1. Select the asset (highlight it). 

2. Choose View > Properties > Publishing. 

The Publishing Properties screen appears: 
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BEST PRACTICES 

 You should use multiple windows when debugging filename issues. This 

allows you to modify templates or system configurations in one window 

and then refresh your filename/publishing properties view in the other. 

 Remember that the filename contains four components: 

1 Hostname: taken from the FTP export configuration 

2 Path to Webroot from FTProot: taken from the FTP export 

configuration 

3 Path: the directory path under Webroot that the file lives in 

4 Filename: the actual filename of the asset. 

 Use the System > Configure > Filename screen to make global changes 

to how filenames are handled: 

 

 

 

 

 

 

 

 

 

 

 

Chief among these attributes is the default extension setting, which makes it 

easy to change the default extension on all files. 

 

COMMON ERRORS 

 Remember that filenames and URLs are not always the same and can 

be configured separately in the CMS by using the filename.asp and 

url.asp template files.  
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 Assets (PDF’s, images, etc.) can also have custom configurations via the 

assetfilename.asp and asseturl.asp template files. Be sure to work in 

the correct templates. 

 It might not be correct to use the hostname configured for your FTP 

server as a URL. Web servers could make use of virtual hosts, for 

example, when serving a site (but this usually won’t be in place for an 

FTP connection). 
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PUBLISH: REPUBLISHING CONTENT 

CMS end users and developers occasionally need to republish the entire 

contents of a site or folder. CrownPeak CMS offers this shortcut instead of 

queuing and publishing each individual asset. 

Note: This topic is covered in Workflow: Republishing Content on Page 65 of 

this manual. 
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PUBLISH: THE OUTPUT TEMPLATE 

The output template is what determines the look and feel of your page. 

When you publish a page, the output.asp file compiles all of the CMS code 

and renders it as pure HTML, including any referenced images, CSS, related 

links, etc. 

 

BEST PRACTICES 

 Since the output template is a mixture of the front end code and CMS 

code calling content fields, printing lists, etc., it is a good idea to begin 

with well written and tested HTML code. Make sure the HTML templates 

pass minimum validation requirements before even beginning to port it 

into the CMS. Bad HTML can potentially cause problems with publishing.  

 Careful formatting and commenting of the code makes it easier to read 

and to separate CMS code from HTML.  

 View the output (View > Output) of the file in the CMS to see what kind 

of HTML it will render upon publishing to see if there are any issues that 

you can see at that point. 

 

COMMON ERRORS 

Again, badly written HTML can cause publishing issues: 

 Missing images can be the result of a linked image not getting 

published.  

 Missing includes or CSS can also be a problem if you forgot to publish 

out the individual include files or CSS files.  

 Badly written or invalid JavaScript code can also be problematic.  

To troubleshoot these types of problems, you can remove pieces of the code 

a little bit at a time to try to uncover where the issue lies. When referencing 

anything—an image, include, CSS, etc.—wrapping the link in asset.getLink will 

help to print out the correct paths to those supporting files. For example, the 

stylesheet should be referenced as follows: 

<%asset.SetParam "link_type", "include" %> 

<link 

href="<%=asset.getLink("/Assets/includes/styles.css

")%>" rel=”stylesheet” type=”text/css” /> 
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PUBLISH: PUBLISHING FOR QA? 

An important step in the development process is testing how pages will 

publish. In the process of performing quality assurance testing, issues often 

emerge once the assets leave the CMS preview environment. 

 

BEST PRACTICES 

When testing, begin in the staging environment. Start by publishing all non-

HTML assets first (images, CSS, JavaScript, etc.), followed by the HTML.  

Once everything is published, go through the entire site and methodically 

review each page. Be sure to test any dynamic aspects of the site such as 

forms, Ajax, etc. The first publishing test often reveals a number of errors.  

 

COMMON ERRORS  

 CSS issues 

Be aware that since the CMS preview environment has its own CSS and 

JavaScript, sometimes what renders fine in the CMS will look strange 

online (and vice versa). 

 Broken layouts 

Compare your page HTML output with the template HTML. Going line-by-

line, you can usually find the spot where a close tag is missing. 

 Publishing issues with alternative output.asp files (such as print versions 

of pages)  

Check that you have properly configured all the necessary page outputs 

in Publishing Properties. 

 FTP errors 

Sometimes there are unforeseen issues with the FTP connection (for 

example, the firewall has not opened). You can usually track these down 

before publishing by using the Test button in System > Configure > 

Export > FTP: 
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 Error in the HTML 

This type of error can occur when there is a problem in the HTML that is 

causing the CMS parser to fail. This is usually a missing quote or missing 

“>” in the HTML. These can be tricky to track down.  

The best troubleshooting method is to remove self-contained pieces of 

the HTML and then republish. This can help you narrow down which part 

of the HTML contains the error. Once you’ve done that, you can then go 

line-by-line until you find the error. 
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