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INTRODUCTION 

This guide provides instructions for using the CrownPeak Content 

Management System (CMS). CMS provides an extensive array of 

customizable features to help you create, manage, and publish your Web 

content. Using the Web-based CMS interface, you also have approval and 

scheduling options that can be configured to your organization’s 

specifications.  

Once your pages are ready to go live, the CMS can automatically publish 

them to your Web server according to a predefined schedule or under your 

manual control. 

The system has been designed to be easy to use for all levels of users. Your 

view of the system and workflow controls can be tailored to your specific 

level of permissions—so you only see as much of the system as necessary to 

get your job done.  

Note: You can always contact your CMS Administrator to set up additional 

levels of content control, or to help manage your specific permissions. 

We hope you find the system to be powerful and straightforward, and we are 

always happy to receive suggestions for further improvement. Since we 

continually refine and improve the system, you will receive the benefits of 

any new versions automatically. 
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GETTING HELP 

ONLINE REFERENCE 

The entire contents of this document can be found online via the CMS Help 

menu. Please refer to the online version for the latest version of the help 

system. In addition to this User Guide, there are several online links to other 

sources of information, and extensive reporting options. 

SUPPORT NUMBERS 

CrownPeak Technology can be reached at 

5880 W. Jefferson Boulevard, Unit G 

Los Angeles, CA 90016 

(310) 841-5920 

support@crownpeak.com 

For the best continuity of service, please work with your designated 

CrownPeak Technology contact for all questions.  

SUPPORT POLICY 

A certain number of service hours are included in each contract. These hours 

can be used for: 

 Updates to templates 

 Training of additional staff 

 Requests pertaining to issues not caused by the CMS system 

 Requests for advice on site construction, capabilities of the system, etc. 

 Issues arising from changes to published pages on the target system 

Before reporting an issue with the CMS, follow the steps in the 

Troubleshooting Guide under the Help menu in the CMS. 

If an issue is determined to be due to an error in the core CMS system (not 

the implementation). the service hours will not be charged for the work. 

New templates will require an extension of the current service agreement. 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 9 

Any time above the included service hours will be billed at an hourly rate. 

CrownPeak may change the interfaces as part of the upgrade process. New 

documentation will be provided with each interface update. While these 

changes may require a certain amount of relearning, they are often created 

as a result of making the interfaces more efficient, more secure etc. 
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GETTING STARTED 

The CMS design is based on some fundamental concepts. Understanding 

these key concepts will give you a foundation for working with the system 

and leveraging its power to your particular needs.  

Some of these concepts are more abstract in nature, and may be 

represented through a combination of functions and system behaviors. 

Other concepts are more concrete, showing themselves as distinct menu 

items that can be utilized through the Advantage interface. 

CONTEXT SENSITIVITY 

The CMS system has been built with “context sensitivity” as one of its 

underlying functions. Context sensitivity means that elements of the system 

adjust their behavior and/or appearance based on their current setting. This 

function is implicit to the system and is primarily represented through the 

menu bar and context menus.  

For example, when viewing a folder, the options available in the menu bar 

and context menus would be different if an item in the folder is selected 

than when no item is selected. Available options may also be different from 

one item to the next. The advantage of context sensitivity is that it ensures 

that you are presented with those options that are relevant to your current 

context—whether that is viewing a folder, previewing a file, or modifying a 

document.  

FRAMEWORK/IMPLEMENTATION 

To better understand how functions apply to aspects of the system, you can 

look at the CMS from a framework and implementation point of view. Simply 

put, the system provides a framework of functionality in which an 

implementation lives. Thus, the framework provides all the functions needed 

to manage assets (for example, status, permissions, and publishing), as well 

as the initial access into the creation and editing process.  

The implementation aspect of the CMS lives in the creation/editing 

interfaces. Functions within these interfaces for entering an article headline 

or author’s name are part of the implementation functionality. Another way 

to view the division is as follows: 

 Framework functionality is primarily shown in the menu bar and context 

menu. 
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 Implementation functionality is shown in the individual Input Forms 

(templates). 

NEW, OPEN, AND PREVIEW 

The first three options of the File menu provide essential CMS operations:  

 New  

This option presents a sub-menu of assets that can be created in the 

current area of the CMS. It is context-sensitive, which means the sub-

menu options will change as you navigate through the site, displaying 

what assets can be created in that particular area of the site. Also, it is 

possible that the New option may not display if you are in an area where 

you are not allowed to create content. 

 Open  

This is a navigation option. It is typically found in folders in the CMS that 

contain assets or other content to be managed. Using the Open menu 

allows you to navigate using the Folder View interface (a view of folders 

and assets in the system). 

 Preview 

This is also a navigation option. It displays a sub-menu with assets, but 

these assets are likely to be individual assets or specific templates that 

correlate to areas on the finished site (for example, your home page or 

section pages). Using this menu, you can navigate in Preview mode. This 

mode means that content is viewed as an HTML document, allowing you 

to use the actual navigation of the site implemented through the CMS to 

navigate through the system.  

 In the Folder view (Open option) and Preview (Preview option), the menu 

bar and context menus are active and adjust their options according to 

the document you are currently viewing. 

PREVIEW, STAGE, AND LIVE 

The site and content that is being administered can be conceptualized and 

viewed as a whole from three perspectives. These perspectives are referred 

to throughout the system, and thus it is helpful to have an understanding of 

the meaning behind the terms. 

 Preview Context 
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The Preview context is the site content as it currently exists in the CMS. You 

view this content within the CMS interface and can manipulate it while 

browsing it. Viewing content as the finished HTML within the CMS is typically 

called “browsing in Preview mode” or “looking at the Preview.” 

 Stage Context  

The Stage context is for content that has successfully completed any 

required workflow (such as an approval process) and is waiting to go live. 

Staged content has its own workflow state (“Staged”) and can be browsed 

on the Staging server (if applicable for the installation). You can reach the 

Stage site using an option under the File menu. Depending on the 

implementation, the actual hosting of the staged content may be on the 

CrownPeak Technology servers, or on your own servers. In either case, the 

location is transparent to you. 

 Live Context 

The Live context is for content that has been successfully published to the 

live Web server for this implementation. Live content has its own workflow 

state (“Live”) and can be browsed using the live Web site. For convenience, 

a link to the live site is provided under the File menu.  

SEND FOR APPROVAL, PUBLISH, AND DEPLOY 

Send for Approval, Publish, and Deploy are three key actions within the CMS. 

These concepts relate to the workflow of a document and make key changes 

to the status of an asset when invoked.  

 Send for Approval 

The Send for Approval action moves an asset out of the Draft status and into 

Pending or Approved status (depending on the configuration). “Sending” an 

asset means that the initial creation and edits are complete, and the asset is 

now ready to be considered for approval prior to publishing.  

Depending on the CMS implementation, the Pending status may have a 

large and complex workflow that an asset needs to pass through before 

being approved. The content of an asset is likely to be considered final (or 

close to it) if the document has been sent for approval. 

 Publish 

The Publish action moves an approved asset to the Stage site. This action 

also updates the status of the asset to “Staged.” A Staged asset may then 
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be viewed using a stage site to verify that the layout and format are correct 

(you can also verify that it is functioning properly within the Web site 

environment).  

 Deploy 

The Deploy action moves a staged asset to the Live site. The status is 

updated to “Live.”  

Also note that content can be “republished” and/or “redeployed” if edits are 

made that then need to be propagated to the Stage and/or Live sites. 

Redeploying an asset will also update the Stage server (in addition to Live) to 

ensure that the two systems are synchronized. 

SYSTEM INTERACTION: THREE KEY METHODS 

CMS utilizes an intuitive user interface to interact with the system. Because 

the interface features are similar to those of other common operating 

systems, Web browsers, and applications, the CMS features should seem 

familiar.  

Throughout CMS, there are only three main methods of interacting with the 

system. By understanding these methods, you can access any function 

within the system. Then, using CMS is simply a matter of knowing what the 

functions do and when to use them. 

 Method 1: Top Navigation Menu Bar 

 

The menu bar provides an integrated interface for navigating through the 

system and activating system functions and tools. Virtually all of the 

functionality in the system can be accessed from here. The menu bar is 

always available at the top of the screen. 

Using the menu bar is simple. Pause the cursor over any of the menu 

names, and a menu of options appears. Each option is fairly self-

explanatory, and some options may have a sub-menu of additional options. 

Regardless of the option, clicking on an option will activate that function or 

navigate to that area of the system. 

 Method 2: Context (Right-Click) Menu 

The context menu is available throughout CMS by right-clicking the mouse. A 

menu appears directly next to your pointer. This menu provides quick access 

to common system functions. The functions in the context menu are a 
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subset of those in the Top Navigation menu bar. Similar to the menu bar, 

pausing the cursor over the options in the context menu highlights the 

options. Clicking on a highlighted option activates that function.  

 Method 3: Select 

 

 

 

 

 

Available in the Folder View only, you can select (click to highlight) an item in 

a list (”Current Home page” in the example above) so that functions may be 

performed on that specific item. You can select an item by clicking on its 

label in the list.  

Selecting is a key method for using the CMS. By selecting an item, the 

options available in the menu bar and context menus change to be more 

appropriate for the selected item (this is an example of context sensitivity as 

explained before). 

Note: Click on the icon to show that document in Preview mode (same as 

double-clicking on the label). Click anywhere else (on the label, status etc.) 

to select the document. 

NAVIGATION MODES 

There are three primary modes of navigation with which you should become 

familiar. 

 Using Preview for Navigation 

Preview mode makes it very easy to get to the pages you want to edit or 

create by just following the page links. No knowledge of the underlying file 

structure is necessary.  

When using this mode in a large site, you can set your preferences to have 

any page in the system as your personal home page. For example, a person 

who is only responsible for creating press releases might want to set their 

home page to the press section of their corporate site in order to avoid 

extensive navigation to their work area (see the Working with Views section). 
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 Using Folder Structure for Navigation  

It might be more appealing to technical users to navigate using the folder 

structure. The Folder Structure mode allows you to navigate a tree structure 

to find the files you want to edit. Clicking on the icon opens folders.  

 

 

 

 

 

The clickable path menu provides “bread crumbs” for orientation and 

navigation, and the Goto menu offers quick jumping between folder 

branches (see the Working with Views section). 

Note: The file structure in the CMS does not necessarily have to mirror the 

structure of the destination site. While the destination Web site might be 

optimized for technology, the organization of the CMS folders might follow 

business logic or a geographical organization. 

 Using Summary, Reports, and Search for Navigation 

One of the advantages of having a context-sensitive menu system is that you 

can perform immediate actions on a document from any Report Page, 

Summary, or Search Result.  

A good example is the Summary page, which allows you to see all of the 

pages that are pending your approval as well as all the pages you have 

recently modified. The attribute-based approach works by selecting a 

document from any summary page, report, or search result and having all 

possible actions available from the context sensitive top menu bar. 

WORKING WITH VIEWS 

The View menu in the top menu bar allows you to switch to different views 

within the system. Views are different renderings of similar information 

designed to allow you to optimally perform certain tasks. 

You can choose from two distinct views to perform certain tasks on a page: 

 Folder - Gives access to Folder View and Archived Folder 

 Preview - Visual check of page created and visual navigation 
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 Folder View 

 

 

 

 

 

 

 

 

 

 

 

The Folder view gives you a clear snapshot of the status of any given page. 

 To work on a document, select the document and use the right-click 

menu or the top menu bar to perform any actions. 

 To preview a page, click on the icon representing the page. 

 To navigate to another folder, use the path or the shortcut menu in the 

blue bar. 

The following icons are encountered in this view: 

 Navigate one level up 

 Filter the current view 

 Refresh screen 

 Access shortcuts menu – Recently visited folders 

 User action required – document has changed (dirty document) 

 Document is locked by other user 

 Document is locked by current user 

 Document is scheduled 

 Content is publishing 
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 Preview 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the Preview mode, the top menu bar gives you access to actions you are 

allowed to perform on the viewed document within the CMS. You can, for 

example, use the Edit menu to manage the document’s workflow and move 

it along the approval process—or you can use the View menu to change to 

another view. 

In addition, the Preview mode allows you to navigate through the site as you 

would navigate through the live Web site. For example, follow a link from the 

home page to navigate to the particular page you want to edit. Use the View 

menu to select Edit and work on the page. 
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CONCEPTS 

One of the simplest ways to understand a content management system is to 

think of it like a word-processor mail merge where you create a database of 

content (for example, names and addresses). Also, like a mail merge, you 

also create one or more form letters, indicating where the data fields need to 

be (for example, Dear <<NAME>>). 

With CMS, you use one or more data entry input forms to create your 

database of content. For example, an input form for press releases would 

have fields for the title, date, and body. These are the forms you work with 

on a daily basis in the CMS. When it is time for the press release to show up 

on your Web site, those fields are inserted into your HTML Output Form to 

create the final page. 

Of course, CMS brings a lot of additional functionality. But, at its core, CMS 

and word processing mail merge are conceptually similar. 

INTERFACE PHILOSOPHY 

 Context-Sensitive Menus 

The CMS uses context-sensitive menus. At any point while using the system, 

the menus only reflect the options that are available for the currently 

selected asset. This allows the menu structure to be streamlined and more 

easily navigated. 

 If you are looking for a particular menu item and are not finding it, try 

browsing to the object on which you want to perform the action. The 

menu reference in this document may also help to identify when certain 

menu items will appear.  

 Menu items are also affected by the group permissions assigned to your 

user account. Be sure to check whether you have access to a certain 

function with your administrator. 

 The context-sensitive menu system extends to all file lists. Folder views, 

search results and reports all allow you to immediately act on the 

selected item. 

 Document Lifecycle Reinforcement 

The lifecycle for each asset in the system is an important concept. The 

system’s user interface reinforces this partly through the Edit menu. When 
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you select a file or document, or preview a document, the Edit menu 

indicates what state that asset is in—and the second-level menu items show 

which operations are allowed for the current state and user. 

ASSETS 

The CMS manages two basic asset types: 

 Templated asset 

A templated asset is a collection of data fields that you enter using an 

input form. When you fill out an input form, the data entered into the 

form fields is stored in the CMS database for use later when publishing 

content. That group of fields is also represented in folders as a single 

file.  

 File asset 

A file asset is any other file that has been uploaded into the CMS. 

CMS treats templated assets and file assets almost exactly the same; they 

show up as files in the folder view, can have workflows, permissions, 

versioning, and are deployed to your servers. 

One difference between the two types of assets is that file assets can 

actually reside on different servers if your installation uses a remote asset 

server. Even in this case, though, the remote server connection is 

transparent to users of the system. 

Note: Both types of assets are typically referred to as just “assets.” They are 

also sometimes called documents or files--but all of the terms refer to the 

same thing. 

INDEX PAGES 

Many Web sites have index pages that list titles of other pages. Examples 

include: 

 List of press releases with dates and titles 

 Home page, which shows the most recent three product 

announcements 

 Phone directory-listing page  

In all of these cases, the title (or other desired field) contains a link to the 

actual item (like a press release, a product page, or a phone book entry).  
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One of the powerful capabilities of CMS is that you only need to enter the 

actual item content, and these index pages are built automatically based on 

rules established during configuration. In this case, there are multiple output 

forms for a single set on input content. In CMS, Preview Mode allows you to 

view the index pages along with the content pages. 

NAVIGATION MODES 

 Preview Mode  

The Preview mode allows you to view your assets in any state. This allows 

you to view content additions in context prior to staging and live deployment. 

In Preview mode, you can select which documents to view, based on state. 

For example, you can preview only live documents or preview all approved 

documents etc.  

You can access the preview mode using the File > Preview menu. A state 

selector can also appear the lower right corner of the CMS page. 

 

 

 

 

 

 

 

 

For each repeated page of your site being managed by the CMS, there is an 

associated folder. The Folder view is simply a list of all the editions of that 

page. For example, a home page folder may contain the live page, a page 

scheduled to go live in two days, and the page that was live last week, but 

has been replaced. 

As you work with the CMS, pages go through a document lifecycle, and the 

folder view shows all of the versions, in a list, with their status clearly 

indicated. The Folder view gives you a clear snapshot of the status of any 

page or site section.  

For any given template, there are actually two Folder views. The Current 

folder shows documents that are new, pending approval, approved, 

scheduled, staged, live, and retired. The Archived folder is a repository of old 
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retired documents that you have packed away. These are kept separately as 

a convenience to avoid cluttering up your day-to-day Folder view.  

Note: You can retrieve assets from the Archived folder to be edited and 

reused. You can access this folder list using the View menu, or the File > 

Open menu. 

 Search Results and Report Mode 

When you perform a search in the system or use one of the several reports 

that return a list of files (for example, “Documents Recently Published”), you 

are presented with a list of relevant assets. This list is similar to the Folder 

view. Whenever you see a list of assets like this, the context-sensitive menus 

let you immediately operate on them. Simply click on the desired asset and 

use the menus just like you would in the folder mode. 

PREVIEW, STAGE, LIVE 

CMS supports three view modes:  

 In Preview mode, the pages are delivered entirely from the CMS. This 

mode allows the fastest viewing and is the view you see when you click 

on the Save and Preview button from an input form.  

 Page preview may not include all of your site’s navigational elements 

(depending on specific implementation), and may just show the relevant 

content for your asset to help focus attention on the content entered via 

the input forms.  

 Preview mode also has the capability of showing documents in different 

states in the system. The Preview State Selector button in the lower-right 

corner of the system allows you to change the desired state in which you 

want to view documents. This is visible for index pages on your site. 

 The Stage view mode shows you the site content on the staging server. 

The location of the staging server is implementation-dependent. For 

static sites, staging may be on the CMS machines. For sites with 

dedicated staging machines, or a dynamic content, the staging is usually 

on machines near the Web servers.  

 Previewing a site in Stage mode allows you to see the content that has 

been approved and is ready to go live. If the staging is on your servers 

(not CMS servers), you will also be able to see any dynamic content. 
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 The Live view mode allows you to see what is currently on your public 

Web site. This is offered as a convenience link to allow you to quickly 

see your live site. 

DOCUMENT LIFECYCLE 

As content is added to the system, it progresses through a natural lifecycle. 

Each step is initiated either by a user action or automatically by the system. 

The choice between manual and automatic is configurable and is 

customized for your specific implementation. 

This manual continually makes reference to pages, documents, forms, 

templates, etc. Thinking of the system in terms of “pages” is convenient, but 

it is important to remember that a given template may actually generate 

several pages on a Web site or even no pages at all. Some templates simply 

insert data into a database on another machine. In all cases, however, the 

content moves as group through the system until the final publishing step, 

where it may generate several pages or populate several databases. 

Here is a simple diagram of a lifecycle. You may decide not use all of these 

states in order to streamline your production process. 

TEMPLATES  

Templates define the page layout for each section of the site to be 

published. You can think of them as the form you fill out with your specific 

content. In the CMS, there may be many templates for each “page,” 

including the edit form, the preview, the spell checking raw view, and the 

output templates. All of these templates are different views of the same 

page, optimized for the appropriate display context. 

WORKFLOW 

The workflow pipeline describes a document’s life cycle. As a document 

proceeds through its life within the CMS, specific actions can be performed 

on the document at certain stages of the cycle. For example, a document 

that has not been approved cannot be deployed to the Web site, just as a 

document cannot be retired if it is not currently live (depending on your 

configuration).  

The workflow can be configured by your CMS Administrator on a per-

template and per-document basis, so many of the states will not be available 

to specific users. 
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APPROVALS 

Along with workflow, the approval process controls how a document moves 

between states. After a document is created in Draft mode, a number of 

approvals may be required to move the document into Approved mode. 

While the document is waiting for approvals, it is in Pending mode. If an 

approver rejects a document, it will have a status of rejected, and the author 

will need to make changes and resubmit the document for approval. 

SCHEDULING 

At some point in the workflow (depending on the particular implementation), 

you can schedule when a document will be published. Sometimes this is left 

to the author creating the document, who suggests both the content and 

deploy date. The other common approach is to have the approver choose the 

launch date.  

Scheduling allows a launch date and retire date to be specified with 

granularity, down to the hour. Of course, you can always manually deploy a 

document at any time. 

DOCUMENT ACCESS CONTROL 

Three levels of access control affect your ability to create, view, and modify 

documents: 

 User groups (roles) 

 Workflow permissions 

 Folder/file permissions 

In combination, these levels control what you can see and what actions are 

available for any given document. 

 User Groups (Roles) 

Your user group permissions control what your overall capabilities are within 

the system. For example, you can create new documents, you can edit them, 

you can approve them. Permissions also determine what kinds of editing 

operations you can perform when using the WYISWYG editor.  

Your local administrator is in charge of setting up accounts and choosing 

which groups you belong to. You can be a member of several groups, and 

groups are often based on combinations of content types and roles. For 
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example, for an installation with press releases and product sheets with 

authors and editors, the following groups might be set up: 

 Release Authors 

 Release Editors 

 Product Authors 

 Product Editors 

Let’s say there are three users of the system: Bob creates new press 

releases; Mary creates and approves new product sheets; and Jane is the 

manager/approver for both—and can also create/edit any documents. In this 

case, Bob would be in the release authors group; Mary would be in the 

product authors and product editors group; and Jane would be in all four 

groups. The two author roles would allow document creation, while the two 

editor roles allow approval. 

These combinations of group permissions correspond to the roles that each 

user plays when using the CMS. 

 Workflow Permissions 

As a document flows through the various lifecycle states, the workflow 

permissions control which actions are allowed at each state. For example, a 

user can delete a document in the approved state only if the workflow 

permissions allow that action.  

Another example is when scheduling occurs. Workflow permission control is 

done by the author in draft mode when the document is first created, or by 

the approver in the approved state. 

 Folder/File Permissions 

The folder/file permissions are similar to most operating systems. These 

allow for differential permissions based on user groups. The folder 

permissions allow you to control visibility so that different sets of users see 

entirely different content in the system, even within the same folder. 

DOCUMENT STATES 

Your individual implementation of CMS allows for total flexibility of document 

states. Some of the standard states include: 

 Approved documents 
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These documents have been approved by all approvers specified in the 

system configuration and are waiting to be published to the Stage site, 

or Deployed directly to the Live site (depending on the configuration). 

 Archived documents 

These documents have been archived and will no longer appear in the 

Folder view. Archived documents are stored in a separate folder. 

Documents that are archived can be un-archived and placed back into 

the publishing system or cloned back into the current Folder view. 

 Draft documents (New) 

These documents are still being edited by authors. Documents in this 

stage are in constant flux and are subject to change frequently as 

people work on them. 

Note: Any document may be cloned at any time. Cloning involves making 

an exact replica of a document, assigning a new label name to it, and 

registering it in the system. The cloned document then proceeds through 

as if it were a new document. The document that was cloned, however, 

remains in its current state unaltered. 

If an approver rejects a document, it is sent back to editing for changes. 

The document’s creator/author receives an e-mail notifying him/her that 

the document was rejected.  

 Live documents  

This document is deployed on the Web site in accordance with its 

scheduled dates, or manually (depending on your specific system 

configuration). Once this is performed the document is considered Live. 

 Pending  

This document has been sent for approval. If more than one approver 

has been specified, the status will reflect how many approvers have 

approved the document and how many total approvals are required. 

This will be displayed as a numeric ratio next to “Pending.”  

 For example, the approval ratio could be 0/3, 1/3, or 2/3. Once it 

becomes 3/3, the status is automatically changed from Pending to 

Approved. Once approved the page can be immediately or automatically 

published when the scheduled publish date arrives. 

 Retired documents  

A Retired document is no longer live on the site, but its name will still 

appear in the Folder view until it is archived. Documents are retired 
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when the retire date arrives, another document needs to become live, 

and only one live document is allowed (like a home page)—or when you 

override the schedule and choose to retire, delete, or archive the 

document. A retired document may be cloned or re-posted by a manager 

as long as it has not yet been archived. 

 Staged Documents 

Documents that have been published to the Stage site are ready to be 

deployed to the Live site either automatically by the system, or manually 

by one of the CMS users. 

 Suspended Documents 

This document has been put on hold and has a temporarily suspended 

live date. Managers will be able to put any document that is not live on 

hold, and then put that document back into circulation (awaiting its 

scheduled or manual post date) as needed. 
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USING THE CMS SYSTEM 

MENU OVERVIEW AND INTERFACE ELEMENTS 

The CMS uses sophisticated DHTML code to provide an application-like 

experience on a simple Web browser. The Web interface is easy to work with 

and provides access to all of the powerful features of the CMS.  

In addition to the menus described in other sections of this guide, there are 

several other user interface conventions and controls that will improve your 

use of the system. 

 Top Navigation Menu Bar 

 

Most of the CMS functionality is accessed via the menus at the top of the 

screen. The menus are context sensitive based on the asset, workflow, and 

group permissions, so you will only be see the commands that are relevant 

to your current mode or currently selected item. 

 File 

The File menu contains commands to allow you to open specific content 

folders and create new items for the current folder or preview. This 

menu also contains convenience links to search or preview the stage or 

live site. 

 Edit 

The Edit menu shows the current state of the selected document, and 

has sub-menus to allow state change actions to be performed (Send for 

approval, Approve, Schedule, Publish to Live, etc.). It also allows the 

document to be edited if you are allowed to do so. 

 View 

The View menu allows you to switch between Folder and Preview view. It 

also controls properties on the currently selected document. 

 System 

The System menu provides access to your account settings and other 

centralized functions such as reporting (usually restricted to 

administrators). 

 Help 
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The Help menu provides access to the help system, and contains 

support information. 

The Menu Item Reference section later in this document contains more 

detailed information on each menu command. 

 Global Elements 

Global elements of navigation present throughout the system include the 

following. 

 Backing Up 

The CMS supports the use of the back button on the browser. This 

option is also available on the Context (right-click) menu, which may be 

faster to use.  

When you back up, though, remember that you are backing up to the 

previous state. For example, if you edit a document, save it, then back 

up twice, the Folder view will not indicate the changes to the document.  

In general, you should try to move forward thorough the system. If you 

are in preview mode or looking at tasks, for example, use the View > 

Folder menu to go to the Folder view. 

 Context (right-click) menu 

Click the right mouse button to display a list of common functions for the 

current mode or currently selected item. This listing is an integrated 

subset of options from the menu bar. 

Note: If you want to use the browser’s native right-click menu, simply 

hold down the key while clicking the right mouse button. 

 Double-Clicking 

Many of the system functions are activated by clicking on a folder or 

document and then selecting an appropriate command from the Edit 

menu. In some cases, a double click may be useful. For example, 

double-clicking on the label of an asset has the same effect as clicking 

on its icon and selecting preview. 

 Folder View Elements 

 Path 

Displayed within the Folder view, the path provides three navigational 

methods for moving through the system.  
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First, the word “Path” itself is always a clickable link to the root level of 

the CMS. 

Second, each individual folder in the path (delimited by “/”) is a link to 

that folder. You can click on the folder names to rapidly move up the 

path as needed. 

Third, unless you are at the root level, a folder with an arrow icon is 

always displayed at the end of the path. Clicking on this icon will take 

you up one level in the current path.  

 Filter Menu 

The Filter menu (Folder view) allows you to change the way the list of 

items appears in the current view. The Folder view may be filtered on 

several criteria: Label, Status, Created By, Modified By, Date Type, and 

Other (custom fields as defined by the system and implementation). 

Running a filter returns a list of assets that match the filtering criteria. 

The filter can be toggled on and off using the Open/Close filter icon. For 

folders that have greater than 200 items, the filter is automatically 

toggled on. 

 Refresh 

To refresh the current Folder view, click on the round refresh icon. This 

may be needed when updating asset permissions, updating scheduling 

information, or if you want to see changes by other users of the system. 

The Refresh command can also be selected from the right-click menu. 

 Recently Viewed Menu 

When you pause the cursor over the icon representing an open folder, a 

menu of recently viewed folders appears. Select an option from this 

menu to go directly to the selected folder. 

 Preview and select in the Folder View 

To Preview an asset, click its icon in the Type column. 

To select an asset, click on its name in the Label column. When an asset 

is selected, the options in the menu bar and context menus are 

configured appropriately. 

 Sorting the Folder View 

Clicking on the header label of any of the Folder view columns (Type, 

Label, Status, Modified By, Size, Modified), to sort the list by that 

column. Click the same label a second time to reverse the order of the 
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sort for that column. The system remembers the sort order for a specific 

folder if you have changed it. 

 Scheduled Indicator 

If an asset in the Folder view is scheduled, the clock icon appears. 

Pause the cursor over the icon to bring up a tool tip showing the 

scheduled dates for the asset. Click on the icon to display the 

scheduling screen, or a list of the scheduled data. 

 Tasks Indicator 

If an asset has new task attached to it, the task icon will appear. Click 

on the icon to bring up the task interface for that asset. 

 Flags 

You can flag individual pages, assets, and folders via the Flag item in 

the Edit menu. Select an Item and click on Edit> [STATUS]> Flag. A Flag 

icon indicates that this item has been flagged.  

You can access a list of all your flagged items through System > My 

Account > Flagged Assets on the left side bar.  

 Left Hand Bar 

The left-hand bar is primarily an informative space, providing information 

about other users that are logged into the system, your username and your 

avatar. The left-hand bar also has a few links for convenience that are 

centered on your needs. 

 Avatar 

Click on your avatar to display the edit page for your user account. From 

this page, you may update your avatar, as well as other user 

information. 

 Summary 

My Summary shows a summary list of notable system data: tasks 

assigned to you, publishing errors, and the last five assets you worked 

on. 

 Preferences 

Preferences takes you to your preference page. 

 Tasks 

Tasks shows a list of tasks assigned to you and owned by you. It also 

shows unassigned tasks. 
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 Flagged 

Flagged shows you a list (report) of all your flagged items. 

 Logout 

Logout logs you out of the CMS. 

PROCEDURES 

LOGGING IN TO THE SYSTEM 

 

 

 

 

 

Before logging in the system you must have received from your 

organization’s CMS Administrator a URL you can use to access the system 

(for example, http://advantage.crownpeak.com/yourorganization), along 

with a username and password. Passwords must contain at least 8 

characters. 

To log in, enter the provided URL in your browser. At the logon screen, enter 

your username and password, and click Submit.  

Note: You may choose to have your logon information cached in your 

browser. This, however, is less secure than typing it in each time, especially 

if you’re sharing your machine with anyone. 

In case you have misplaced or forgotten your password, you can click the 

link called Forgot your password ... click here! The link will bring you to a 

page that prompts you for your e-mail address. After entering your address, 

you should receive your username and password in your mailbox within a 

couple of minutes. For increased security you should change your password 

after receiving this e-mail. 

Security is very important and therefore user actions are monitored within 

the login process, such as typical system use, IP addresses, and other 

factors that help to profile your individual use of the system. If certain items 

change suddenly, your account may be temporarily disabled to protect your 

content. In addition, repeated failed login attempts will also result in a 
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disabled account. If your account becomes disabled, please contact your 

organization’s CMS administrator to re-enable the account. 

 Asset Management 

Asset management solves the problem of efficiently managing, organizing, 

and leveraging your digital assets such as files, images, sounds, etc. Any file 

or media type that can be uploaded within the Asset Management System 

(AMS) can have specific permissions, scheduled launch dates, approval 

chains, check in, check out, rollback, and versioning. 

The AMS can be configured in two ways. Usually a directory called “Assets” 

with a common directory structure is created. The CMS Administrator can 

also set up where assets are uploaded in the corresponding directories by 

either himself or groups depending on their access permissions. A template 

can also be assigned to the asset upload process to give the asset more 

information such as categories, boilerplate content, keywords and 

summaries.  

The AMS is represented like a file system and allows you to select, add, 

delete, and view files and folders as needed. You are assigned access 

through the User Maintenance System.  

Note: Once you select an asset from the AMS in a page, the asset is copied 

into the CMS to prevent further complications such as when an asset is 

deleted from the asset directory. 

Assets can be deleted, renamed, cut, copied, cloned and flagged depending 

on your permissions. 

 Uploading a File 

To upload a file: 

1. Choose File > New> Upload.  

Click Browse and select the image or other file from your hard drive.  

2. If desired, fill in the metadata textboxes.  

This is important when you need to search for an asset, or list the 

various categories to which it belongs. 

3. Click Save. 
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 Downloading a File 

To download a file: 

1. Select the asset by clicking its label once. 

2. Click on the Edit menu (or right-click the file) and select Download.  

 

 

 

 Checking Out a File 

To check out a file: 

1. Select the asset by clicking its label once. 

2. Click on the Edit menu (or right-click the file) and select Checkout. 

3. Click OK to download the file to your computer. 

When the file is downloaded, a key will appear next to the file indicating 

that it has been checked out. 

 

 Checking In a File 

To check in a file: 

1. Select the asset by clicking its label once. 

2. Click on Edit (or right-click the file) and select Checkin. 

3. Click Browse and navigate to your changed file. 

4. Click Save.  

Once the file has been uploaded, the key should disappear indicating that 

the asset is checked in. 

 

 Asset Properties -Meta Data 

Metadata can be defined literally as "data about data," but the term is 

normally understood to mean: 

 Structured data about digital resources that can be used to help support 

a wide range of operations.  
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These might include resource description, categorization, title, and 

keywords. Once the data is input, the asset can be sorted, cataloged, 

and organized in a number of ways. More important, when you are doing 

a search, an asset is much easier to locate. 

CMS allows a custom set of meta-data to be applied to all assets, both 

templated and file. To set or view the asset properties for an asset: 

1. Select the asset by clicking its label once. 

2. Choose View > Properties> (or right-click the file) and select Meta-Data. 

3. Enter (or view) the desired information. 

4. Click Save. 

 Alerts 

Alerts allow anyone with the correct permissions to be e-mailed when the 

status of the file is copied, moved, deleted, updated, or checked in or out. 

This can be useful, for example, when someone needs to edit a file—but the 

file is checked out by someone else. The user waiting on the file can receive 

an e-mail notice when the file becomes available for editing. Another 

example would be an approver who wants to be notified when documents 

are ready for review. 

To set alerts for an asset: 

1. Select the asset by clicking its label once. 

2. Choose View > Properties > Alerts menu. 

3. Select the desired notifications and click Save. 
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PAGE PUBLISHING 

Most of the asset management procedures apply to page publishing. The 

following procedures are also available: 

 Create a New Page from Preview Mode 

1 Navigate to the preview for the type of document you want to 

create.  

You can choose File > Preview and choose the desired Preview. 

Previewing an index page (such as a home page) with multiple 

types of content will allow you to create any of the types used 

on that page, provided you have permissions to create them. 

2 Choose File > New and then choose the desired template type. 

A form appears.  

3 Fill out the fields and click Save or Save and Preview. 

 Create a New page from Folder Mode 

1 Navigate to the folder for the type of document you want to 

create.  

You can choose File > Open and select the desired Folder. You 

may need to navigate through the folders to get the right one. 

Some folders allow content of more than one type to be 

created. In this case, the File >New menu shows your choices. 

2 Choose File > New and then select the desired template type. 

A form appears. 

3 Fill out the fields and click Save or Save and Preview. 

 Clone a page 

1 Enter Folder view for the folder containing the asset. 

2 Select an asset by clicking on its label. 

3 Select Clone from the Edit menu. 

The asset will be copied to a new asset named “Clone of xxx”, 

where xxx is the original label. The new asset will have a state of 

Draft. 

 Spell Checking 

To check spelling: 
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1. From a folder view, select the asset by clicking its label once. 

2. Choose the Edit >(STATUS)> Spelling. 

The Spell Check page appears: 

 

 

 

 

 

 

 

 

 

 

The Misspelled Words list allows you to click on each word. As you 

choose a word, the context for that word will show in the Context box. 

3. Use the action buttons to address each word. 

 Searching 

The File menu contains a link to the search system. When you select Search, 

a sub-menu appears with two options: Quick and Advanced. 

When you select Quick, a dialog box appears where you can enter a search 

phrase. Just type in your desired search terms and click OK. The search 

results are displayed in the main window in a layout similar to the Folder 

View. Each asset will show the hits as bold font keywords in context. The 

search results are returned in a relevance ranked order. In the search 

results view, all of the Edit menu functions are available. 

When you select Advanced, you are directed to an Advanced Search screen. 

The screen allows you define search criteria by search field, comparison, 

value, and Boolean join. It allows as few or as many search criteria as 

necessary.  

 User Management 

The task of adding and modifying user accounts is typically assigned to the 

CMS Administrator. If you are the CMS Administrator, you can manage user 

accounts using the System > Configure > Users menu.  
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When you choose this menu item, you see a list of all users in the system. If 

you click on a login name, you can edit the account information for that user. 

While you are editing a user account, the Edit menu allows you to delete or 

clone a user account.  

The Edit menu also allows you to add a new user. When editing a user 

account, make sure all of the appropriate groups are selected. You can 

select multiple users from this drop-down menu by using the key along with 

the mouse. 

TASKS 

As one of its many community features, CMS contains a full task 

management system. You can assign tasks to other CMS users, as well as 

review tasks and search for them. 

 Creating a New Task 

1. Choose System > Site Tasks. 

The current list of tasks in the Task folder is displayed. 

Note: The filter options on top of the list of tasks allow you to filter the 

items in the current view based on various criteria: Subject, Status, 

Assigned To, Category, Owner and ID (custom fields as defined by the 

system and implementation). The Filter can be toggled on and off using 

the Toggle Filter icon. For Folders that have greater than 200 items, the 

Filter is automatically on. 

2. Choose File > New > Task. 

The New Task page appears: 
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3. 3. Define the new screen by populating the following fields: 

a. Owner - the Owner field is automatically populated with 

your username. 

b. Alert me… - Selecting either of these check boxes generates 

an e-mail alert when the corresponding task is completed. 

You can set your own global task notification preferences 

using the System > My Account>Preferences menu. 

c. Category - Select the task category from the drop-down list. 

Values are configured per CMS instance. 

d. Priority - Select the task priority from the drop-down list. 

Values include High, Medium, or Low. 

e. Assigned to - Use this drop-down list to assign the task to 

another CMS user. 

f. Status - Select the task status from the drop-down list. 

Values include Not Started, In Progress, Delayed, Deferred 

and Completed. 

g. Access - Select the task access control from the drop-down 

list. Values include Private (only the task creator and 

assignee can view it) or Public (everyone can view the task). 

h. Due Date - Select the due date for the task. A DHTML pop-

up calendar allows you to click on the date the task is due. 

i. Subject - Enter a subject for the task. 

j. Description - Enter a description of the task. 

k. Associated Files/Folders - Enter the path to the asset to 

which this task pertains. 

 Priority 

The priority of a task is identified by the following icons: 

 Red Arrow Up: High Priority 

 No Icon: Normal Priority 

 Blue Arrow Down: Low Priority 

 Status 

The Status of a task can be one of the following and is indicated in the 

Status column as well as in a color-coding. 

  Not Started 

  In Progress 
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  Delayed 

  Deferred 

  Completed 

 Viewing Tasks 

To view a list of current tasks: 

1. Choose System > Site Tasks. 

The Tasks page appears: 

 

 

 

 

 

 

 

 

 

 

2. Click on the Toggle Filter icon. 

The filter fields appear. 

Note: Tasks are identified throughout the CMS with the Task icon  . As 

soon as a task is completed the icon changes to the selected Task  

VERSIONS AND REVERT 

CMS keeps complete version information for every asset (both templated 

assets and file assets). The versions are stored as differences in the 

database for templated assets or patch files for file assets. Versions are 

stored when an asset is saved or checked in. Any asset can be reverted to a 

previous version.  

To access the versions history for an asset: 

 Select the asset and choose View > Versions. 

A chronological list of each version of that asset appears: 
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To preview an earlier version: 

 Click on the icon in the left hand column.  

To select a version to revert to: 

 Click on the desired asset version label.  

Once you have selected a version, use the Management > Revert To 

menu to roll back that asset to the previous version.  

REPORTS 

You can find reports using the System > Reports menu, and then choose the 

desired Report. Custom reports are Advanced Searches that have been 

Saved as a Report, while Standard Reports are built into the CMS. Built-in 

reports include: 

 Last Published 

This report shows documents published, along with the type, label, 

status, owner, size, modification date, scheduling info and tasks within 

that last 10 days, ordered from most to least recent. Documents include 

images and other assets in addition to HTML pages. 

 Last Logins 

This report shows logins from the last ten days, along with the name, 

date of login and IP address of where the user logged in. This 

information could be useful in assessing where an unauthorized login 

might have come from. 

 Most Active Users 

This report shows the ten most active users, along with how many 

actions were performed by each. 

 Least Active Users 

This report shows the ten least active users, along with how many 

actions were performed by each. 

 Login Alerts 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 41 

This report shows consistencies or inconsistencies in time zone, browser 

used, IP addresses, etc., that come from login profiling by the system, 

along with the date, name, and the reason for the listing. It shows 

interesting behavior that could be put to many uses (primarily for 

security purposes). 

 Locked Assets 

This report shows all assets that are currently locked, along with type, 

label, status, owner, size, and when it was last modified. 

 Assets Near Publish 

This report shows assets that are within five days of deployment, along 

with type, label, status, owner, size, when it was last modified, as well as 

scheduling info and notes. 

 Oldest Pages 

This report shows the pages that have been modified least recently, 

along with type, label, status, owner, size, and when it was last modified. 

 Last Modified 

This report shows pages modified, along with the type, label, status, 

owner, size, modification date, scheduling info and tasks within the last 

10 days, ordered from most to least recent. 

 Modified Unpublished 

This report shows documents queued for publishing, along with the type, 

label, status, owner, size, modification date, scheduling info and, 

beginning from top of the queue. Documents include images and other 

assets in addition to HTML pages. 

 Queued Assets 

This report shows documents modified but not published, along with the 

type, label, status, owner, size, modification date, scheduling info and, 

ordered from most to least recent. Documents include images and other 

assets in addition to HTML pages. 

 Never Logged In 

This report shows users who have never logged into the CMS. 

 Newest Assets 

This report shows the 50 newest assets created in the CMS, along with 

the type, label, status, owner, size, modification date, scheduling info 
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and, ordered from most to least recent. Documents include images and 

other assets in addition to HTML pages. 

 Recent Tasks 

This report shows the 50 newest tasks created in the CMS, along with 

the type, label, status, owner, size, modification date, scheduling info 

and, ordered from most to least recent.  

 Workflow 

This report shows the workflows configured in the CMS, along with total 

number of assets assigned to each workflow, the number of assets in 

each step of each workflow, as well as average time assets spend in 

each step and total number of assets that have ever been in any step.  

 Errors 

This report shows assets in the CMS that contain errors, along with the 

type, label, status, owner, size, modification date, scheduling info and, 

ordered from most to least recent. 

 Templates 

This report shows all the templates used in the CMS, along … 

 Publish Queue 

This report shows a graph of queued assets over time. 

 Asset Speed 

This report shows the 50 slowest assets to publish, in order of slowest to 

fastest. 

 System Summary 

This report shows total users, assets, pages, folders, and templates, 

along with the number of each. 
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The CMS has a Visual Page Annotation system for use in the Preview mode. 

Instead of just making comments on a separate list, you can add comments 

directly to the asset. This allows your comments to have a direct visual 

connection to the corresponding item. Other users can then preview assets 

within the system, see the annotations that have been made, and edit the 

asset accordingly.  

Note: You can hide annotations by choosing View > Display > Hide 

Annotations. 

 Comments 

Annotations added to an asset also show up as tasks in the task interface. 

Additionally, assets with annotations have a Task Indicator (icon) displayed 

in their folder view. 

 Creating Annotations 

To create an annotation: 

1. Select (highlight) some text on the screen or double-click on a graphic 

(one without a hyperlink). 

The Task Annotation page appears. 
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2. Complete the annotation fields and click Save. 

When you save your annotation, the text you selected is highlighted and 

a graphical indicator displayed.  

Note: Pause the cursor over the icon to bring up a tool tip that gives the 

username and text of the annotation.  

 Editing Annotations 

To edit an annotation:  

1. Click the annotation indicator to bring up the Annotation window: 
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2. Make the needed edits. 

3. Click OK to save any changes made to the annotation. 

4. Or, 

5. Click Cancel to end the editing session; any changes will be lost.  

EDIT MY ACCOUNT SCREEN 

The Edit User page allows you to set your password and contact information. 

To access this page and edit your account configuration, choose System > 

My Account > Edit: 
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 Non-Administrator Account 

If you have a non-administrator account, your login name is displayed, but is 

not editable. See your CMS Administrator to change your username.  

 Password: Change your password by typing it in the Password and 

Password Again fields.  

 Avatar Image: Change your avatar image by clicking on the current 

image and selecting one of the built-in images, or by using the Browse 

button to upload an image from your local machine. Images are 32x32 

GIF files. The system will scale the image for you if yours is larger or 

smaller, but the resulting image might not look as good as graphics that 

are sized accordingly before being uploaded.  

 First Name/Last Name: Change your first or last name in the appropriate 

fields.  

 Email: Enter your e-mail address in this field so system alerts go to the 

correct address.  

 Office Phone, Fax, Cell, and Pager: Use these fields to provide contact 

information to other users of the system.  

 Description: Enter a brief user description.  

 Administrator Account 

If you have an administrator account, you can edit these fields: 

 Status: Specify whether the account is enabled or disabled.  

 Expires on: Enter or select a date on which the account will expire, 

automatically denying the user access after this date.  

 Username: Change a name.  

 Groups: These check boxes allow you to assign the user to one or more 

groups. Use <Ctrl> + click to select more than one item.  

All the other fields are the same as those for the non-administrator. 

EDIT MY ACCOUNT PREFERENCES 

The Startup Preferences page allows you to set your startup view, default 

task alerts, default folder preferences, and visual page annotation icons. 

Access this page by choosing System > My Account > Preferences: 
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 The My home file/folder field provides a means to select which folder is 

home for you. 

 Select from either “After show summary view” (shows the summary page 

which includes last documents worked on, tasks assigned, etc.); “After 

login show Home preview” (A preview of the live Web site); or “After login 

show Home folder” (The home folder is selected in the item above). 

 The My Default Browse State(s) check boxes allow you to choose the 

default document state for the Preview Mode. 
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 Summary Page View 

  

 

 

 

 

 

 

These options allow you to customize your Summary Page view.  

 Folder Preferences 

 

 

The first option allows you to select the default field by which folders should 

be sorted. When you change specific folder settings, the system remembers 

them for you. 

The second option allows you to select how much information (measured in 

lines) should be displayed on a folder page. 

 Other 

 

 

The first option allows you to hide the left side status bar of the CMS. This 

may be an advantage in situations when there is not much free space on the 

screen. 

The second option allows you to hide the pop-up window when a file is 

published to stage or live. 

THE WYSIWYG EDITOR 

 Getting Started 

The “What You See Is What You Get” (WYSIWYG) editor is a quick and simple 

way of creating and editing documents with little or no knowledge of HTML. It 

is very easy to incorporate images into your pages or to create links to other 

documents. 
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With an asset selected, choose Edit from the Edit menu (or from the right-

click menu) to access the edit mode. If the page has been set up for 

WYSIWYG editing, you will see a window similar to the one below:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Some pages within the CMS do not use a WYSIWYG field and instead 

use more formal text fields, image upload controls, etc.  

 The WYSIWYG editor gives you a high degree of design freedom in 

creating pages. However, it is not a replacement for a full-blown HTML 

editor such as FrontPage, Dreamweaver, or HomeSite—though it does 

provide a lot of functionality via a simple Web interface. If you want to 

use a more powerful HTML editor, you can paste the formatted results in 

to the WYSIWYG editor window. 

 Not all the buttons have to be present for the editor to work. Your CMS 

Administrator will sometimes restrict access to certain functionality to 

maintain a consistent look and feel for the pages, and to make working 

with the WYSIWYG editor as easy as possible. 

 All buttons in the editor are context-sensitive and grayed out if the 

functionality is currently not available. 

 To get content into the editor, simply type or copy and paste from other 

documents like Microsoft Word or Excel or from Web pages. 
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 The formatting of documents when pasted from the sources mentioned 

above will be retained, though images may not work properly. Be sure to 

save them separately and insert them individually to ensure that the 

CMS is managing them.  

 Finding and Replacing Text 

  This feature allows you to find and replace text in the current page. 

 Using Styles 

  

Style sheets give you more control over the appearance and presentation of 

your pages. Using cascading style sheets, you can extend the ability to 

precisely specify the location and appearance of elements on a page and 

create special effects. You can also make your site more accessible for 

visitors with specialized browsers or output devices. 

A cascading style sheet (CSS) defines the styles that you can apply to pages 

or page elements. Each style definition (or style rule) consists of a selector 

followed by the properties and values for that selector.  

Note: The Font Style box lists standard HTML tags, such as Heading, 

Preformatted, and Address. Depending on your CMS implementation and 

your level of access, you might have limited or no access to the styles 

menus. Please contact your CMS Administrator for details. 

 Using a Style Sheet 

To apply a style to a page element: 

1. Select the page element. 

2. Select a style from the Styles drop-down menu. 

 Selecting Colors 

You can set the color for many page elements, including text, background 

color for text, and table borders. 
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 Select a color from a palette. 

 Specify a color by entering a hexadecimal value. 

 Enter a value combination for red-green-blue.  

 Formatting Text 

You can set the font for selected text by choosing the type face, font style, 

size, and color. You can also apply different effects to the text, such as 

strikethrough and small caps.  

Select the text you want to format, and choose an option from the Font Style, 

Font, or Size drop-down menus.  

Make text bold. 

Add italics to the text. 

Underline the text. 

 Inserting a Special Character 

You can insert a special character or symbol such as the trademark symbol 

(™). 

1. Place the insertion point where you want to insert a character. 

2. Click the Insert button. 

 

3. Select the character you want to insert. 

 Cutting or Deleting Text  

You can easily cut or delete text to remove it from the page. When you cut 

text, it is copied to the Clipboard and you can then paste the text to another 

location. When you delete text, it is not copied to the Clipboard.  

 To cut text and copy it to the clipboard, select the text and click Cut: 

 

 To delete the text, press Delete on the keyboard. 

 Croping Text 

The crop text function deletes everything on the page except the selected 

area. When you crop, the deleted text is not copied to the Clipboard.  

 To crop text, select text you want to keep and click the Crop button:  
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 Adding Shading to Text 

To add shading to any text you would like to highlight:  

1. Select the desired and click the Background Color button.  

 

2. Select a color from the palette and click the Select button. 

 Setting a Text Color 

To select a color for the text: 

1. Select the text you want to add color.  

 

2. Click on the Foreground Color button, and choose a color for the 

selected text. 

 Setting the Text Alignment 

You can align text to the left, right, or center of the page. The alignment 

setting affects all of the text in the paragraph.  

1. Select the text you want to align. 

 

2. Click the Align Left, Center, or Align Right button. 

 Setting Line and Paragraph Indentation 

You can specify the way you want to indent a paragraph. For example, you 

can indent the right or left side of a paragraph, or just indent the first line. To 

add an indent:  

 Select one or more paragraphs.  

 To indent the left side of the paragraph, click the Increase Indent 

button. 

 

 To remove the indent of the paragraph, click the Decrease Indent 

button.  

 

Note: Increasing or decreasing an indent always affects the entire 

paragraph.  
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 Applying a Style to a Paragraph 

A style is a combination of font and paragraph settings. Use styles to format 

your text quickly and consistently. For example, apply the style Heading 1 to 

each of your headings so that each one looks the same.  

Using styles also saves you time, because rather than changing the font and 

paragraph settings for each individual heading, you can simply specify a 

style to use.  

In addition to styles for headings, you can also use the Bulleted List style, 

which indents text and adds bullets, and the Numbered List style, which 

indents text and numbers the paragraphs.  

When you apply a style to text, the style is applied to all text in the 

paragraph. 

Note: You need to have styles defined in order to use them.  

To apply a style:  

1. Select the text to which you want to apply a style.  

2. Open the Styles pop-up menu and select a style.  

Or, 

Open the Font Style pop-up menu and select a Headline Style: 

 To quickly apply the Bulleted List style, click Bullet List. 

 To quickly apply the Numbered List style, click Numbered List.  

 Removing HTML  

This button removes all HTML from the selection, leaving only the raw text. 

This feature is very useful when copying text from HTML sources into the 

WYSIWYG editor. It allows you to quickly remove HTML and apply new layout 

to the content. 

 Showing Details 

This button allows you to show line breaks and paragraphs. You can use the 

button to toggle between showing details and not. Showing the details of 

page design can be useful in working with complex page layouts. 

 Searching Text  

You can search for text on the current page. 

 Creating Hyperlinks 
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A hyperlink is a connection from one Web location to another—either from 

one page to another or another location on the same page. The link 

destination is typically another Web page, but it can also be a picture, an e-

mail address, a file, or a program. 

When a site visitor clicks a hyperlink, the destination page is displayed in the 

Web browser, or a file is opened or run, depending on the type of link. For 

example, a hyperlink to an AVI file opens the file in a media player, and a 

hyperlink to a page displays the page in the Web browser. 

Two types of links are available in CMS:  

 External links are for documents not managed by the CMS (typically for 

documents on other sites). 

 Internal Links are to other Assets in the system. The CMS maintains 

their relative paths through Preview, Stage, or Live status, and fixes the 

URL accordingly as the document is Previewed, Published, and 

Deployed. 

 What Is a URL? 

When you create a hyperlink, its destination is encoded as a URL (Uniform 

Resource Locator), such as: 

 http://example.microsoft.com/news.htm  

Or,  

 file://ComputerName/SharedFolder/FileName.htm.  

A URL contains a Web server or network location, path, and file name. A URL 

also identifies the protocol that will handle the file, such as HTTP, FTP, or 

FILE: 

A hyperlink can be absolute or relative. An absolute URL contains the full 

address.  

A relative URL has one or more missing parts. The missing information is 

taken from the page that contains the URL. For example, if the protocol and 

domain are missing, the Web browser uses the protocol and domain of the 

current page.  

It is common for pages in a Web to use relative URLs containing only a 

partial path and file name. If the files are moved to another server, any 

hyperlinks will continue to work as long as the relative positions of the pages 

remains unchanged. For example, a hyperlink on Products.htm points to a 

page in the same folder. If both pages are moved to the same folder on a 

different server, the URL in the hyperlink will still be correct. 
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 Creating an Anchor 

An anchor is a destination in a page to which you can hyperlink. To create an 

anchor: 

1. Place the cursor at the position you want the anchor. 

2. Click the Create Anchor button. 

 

The Create Anchor pop-up window appears. 

3. Type a unique name for the anchor and click OK.  

The Anchor icon in the WYSIWYG represents the position of the anchor. 

 Creating an Anchor Link 

To create a link to the anchor: 

1. Highlight the word or phrase you want to link to the anchor 

2. Click the Create Anchor Link button:  

 

The Create Anchor Link pop-up window appears: 

3. Select the anchor from the drop-down menu and click OK. 

 

 Creating a Hyperlink 

You can create a hyperlink to an external destination such as a page or file 

in another Web site, or to a page or file within the CMS Web site.  

To create a hyperlink: 

1. Select the text or image you want to use as a hyperlink. 

2. Click the Create Hyperlink button: (the tool tip says Link Properties) 

 

The Link Properties pane appears. 

3. Select the link type from the URL drop-down menu: 

4. Enter the URL or internal path of the destination page and click OK. 

Note: External Hyperlinks are not tracked and checked by the CMS. You 

need to monitor the URL to see if it stays valid. 

 

 Removing Links 

To remove an internal link or an external hyperlink: 
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1. Select the text or image used as a hyperlink. 

2. Click the Remove Link button.  

  

 Working with Images 

The formats that are generally used for Web pages are GIF, JPEG, and PNG. 

Pictures in GIF format can contain up to 256 colors. One useful aspect of GIF 

pictures is that you can select one color to be transparent.  

The JPEG format is commonly used for photo-realistic pictures containing 

thousands or millions of colors. JPEG pictures are useful because you can 

control the file compression by changing the picture quality. The lower you 

set the quality, the higher the file compression will be, and, as a result, the 

file size is decreased.  

The PNG format is an alternative to GIF that supports transparency for 

pictures containing thousands or millions of colors. However, some Web 

browsers cannot display PNG pictures without a special plug-in. 

 Editing Image Properties 

You can specify how pictures are formatted on the page by setting their 

alignment as well as their horizontal and vertical spacing. For example, you 

can select an alignment option that positions the graphic on the right side of 

the page, with text flowing on the left. Or, set the horizontal spacing to 10, 

which puts a margin of 10 pixels on the left and right sides of the graphic. 

To set the image properties: 

1. Select the image you want to edit. 

2. Click the Edit Image button: 

 

The Image Properties pane appears: 
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3. Add or edit the image properties: 

a. You can specify the Alternative Text that is displayed in 

place of a graphic if the graphic cannot be displayed in a 

Web browser. Some Web browsers also display ALT text 

while the graphic is downloading, or when a site visitor 

moves her mouse pointer over the graphic. 

b. In the Alignment box, click an option to specify how you 

want the graphic to be aligned on the page. For example, to 

align the picture to the left side of the page and have text 

flow to the right, click Left. You can experiment with each 

option to see its effect. 

c. In the Horizontal spacing box, enter how much space in 

pixels you want displayed on the left and right sides of the 

graphic. 

d. In the Vertical spacing box, enter how much space in pixels 

you want displayed on the top and bottom sides of the 

graphic. 

e. Border Thickness allows you to specify how many pixels of 

border you want around an image. 

f. You can resize graphics such as pictures and animated 

GIFs. You can resize a graphic by changing its height and 

width properties, or you can resize it directly on the page. 

Resizing a graphic changes the HTML tags that tell a Web 

browser how to display the graphic; the actual graphic file is 

not changed.  

g. Specify whether you want to change the size in pixels or 

percentage, and then enter values in the Width and Height 

boxes. 

h. If you want to preserve the height-to-width proportions, 

select the Keep aspect ratio check box. If you select this 

check box and then enter a pixel value in either the Width 

or Height box, the CMS automatically changes the value in 

the other box to preserve the graphic's proportions. 

4. Click Save. 

 Inserting an Image into a Page 

You can add a picture from your local file system or select an image already 

within the CMS. 

To upload a new image from your local file system:  
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1. Place the cursor where you want to insert the image. 

2. Click the Insert/Replace Image button. 

 

The Image Properties screen appears: 

 

 

 

 

 

 

 

3. Type the path and file name, or use the Browse button to navigate to the 

picture you want from your local file system. 

4. Click the Upload button. 

The selected image appears in the WYSIWYG editor. 

To select an image already in the CMS:  

1. Place the cursor where you want to insert the image. 

2. Click the Insert/Replace Image button. 

The Image Properties screen appears.  

3. Click the Browse button (…) and select (highlight) an image located in 

the CMS file structure: 

 

 

 

 

 

 

 

 

4. Click the Select button. 

The selected image appears in the WYSIWYG editor. 

Note: As stated earlier, images can have the following file formats: GIF 
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(standard and animated), JPEG (standard and progressive), or PNG. 

 Creating Lists 

You can create different types of lists:  

 Bulleted list - for presenting a list of unordered items. A bulleted list can 

use the standard bullets (round, square, or circle), custom bullets that 

you create, or bullets from a theme (if the page uses one). 

 Numbered list - for presenting a list of sequential items. You can choose 

from numbers, Roman numerals (uppercase or lowercase), or letters 

(uppercase or lowercase). 

 Creating Complex Lists 

You can create lists that have multiple nested levels and paragraphs, and 

specify different list styles for each level. In addition, you can create 

collapsible lists, which allow the site visitor to show or hide different levels by 

clicking headings. 

 Bulleted Lists 

To display a non-sequential list of items, you create a bulleted list: 

1. Position the cursor where you want to create a list. 

2. Click the Bulleted List button. 

 

3. For each item you want to add to the list, type the item and then press 

Enter. 

4. When you have typed the last item, press Enter twice to end the list. 

 Numbered Lists 

To display a sequential list of items, you create a numbered list: 

1. Position the cursor where you want to create a list. 

2. Click the Bulleted List button: 

 

3. For each item you want to add to the list, type the item and then press 

Enter. 

4. When you have typed the last item, press Enter twice to end the list. 
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 Creating Tables 

A table is made up of rows and columns of cells in which you can insert text 

and graphics. You can use tables to: 

 Present information in a tabular format. 

 Present information such as time tables, product information, rates, 

etc., in a grid-like format.  

You can customize your tables to make them more attractive and easy 

to read by defining: 

 How the text appears in each cell by setting the alignment and font. 

 How each column and row is spaced in the table. 

 The colors for borders and shading. 

You can also use tables to lay out text and graphics on a page. Tables 

are supported by virtually all Web browsers and provide an easy way to 

lay out your pages.  

 Simple Tables 

You can quickly create a simple table just by specifying the number of 

columns and rows. Later, you can modify the table’s properties as needed. 

To create a simple table: 

1. Position the insertion point where you want to create a list. 

2. Click Insert Table. 

 

The Insert Table pane appears: 

 

 

 

 

 

 

 

 

3. Specify the number of columns and rows. 

4. Click the Insert button. 
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 Custom Tables 

1. Position the cursor where you want to create a list. 

2. Click Insert Table. 

 

The Insert Table pane appears: 

  

 

 

 

 

 

 

 

3. Add any of the following attributes: 

a. Style Class 

b. Alignment 

c. Rows 

d. Columns 

e. Border 

f. Cell Padding 

g. Cell Spacing 

h. Background Color 

i. Border Color 

j. Width in % or absolute pixels 

k. Height in 5 or absolute pixels 

l. Caption 

m. Table Attributes 

n. Cell Attributes 

4. Click the Save button. 

 Customizing Tables 

You can control how your table appears on the page by setting the table 

alignment. Tables can be aligned to the left, right, or center of the page.  
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You can also control the height and width of the table. For example, you can 

set the width of the table to 80 percent of the overall page width (or frame 

width, if the table is in a frame). If a site visitor resizes the browser window, 

the page size and table change accordingly. On pages that include a table 

and text, you can also specify whether you want text to flow around the sides 

of the table. 

Additionally, you can define the way text appears inside each cell. For 

example, you can specify how much space there is between the border and 

text of a cell, and you can set the horizontal and vertical alignment of text. 

Table text can be formatted like any other text, including font style, size, 

color, and other attributes. 

To set table properties: 

1. Position the insertion point in the table you want to customize. 

2. Click the Edit Table button. 

 

The Edit Table pane appears: 

 

 

 

 

 

3. Edit one or all of the following table attributes: 

a. Style Class 

b. Alignment 

c. Border 

d. Cell Padding 

e. Cell Spacing 

f. Background Color 

g. Border Color 

h. Width in % or absolute pixels 

i. Height in % or absolute pixels 

4. Click the Save button. 

 Editing Table Rows and Columns 

You can customize your table after you have created it by: 
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 Inserting more rows and columns as needed  

 Creating more cells in your table by splitting one cell into two or more 

cells  

 Merging adjacent cells into one cell 

Use the following buttons to: 

  Insert new columns into the table  

  Delete selected column from table 

  Insert new row into table  

  Insert new bottom row into table 

  Delete selected row from table 

  Insert new cell into table 

  Delete selected cell from table 

  Split selected cell in table 

  Merge selected cells 

  Show/Hide Borders 

 Borders 

You can customize the way borders look in your tables by setting the border 

color for the whole table, or setting a different border color for individual 

cells. Additionally, you can choose one color for the border. Or, if you prefer, 

you can choose a three-dimensional look using a light color and a dark color. 

Finally, you can also change the thickness of the outer border. 

Note: You can make working with tables that have no border easier by using 

the Visible Border button to show borders: 

 

 Background 

You can choose background colors and pictures for your tables. Background 

colors can be used to shade specific columns or rows to add emphasis. 

Background pictures add visual appeal to your tables.  
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Background colors and pictures can be set for certain cells or for the whole 

table. However, the settings for a cell always take priority. For example, if you 

set the background color for a table to be green, and set a cell color to be 

blue, the table will have a green background but one cell will be blue. 

 Advanced Text Editing Features  

An advanced text editor is built into your CMS. The administrator of your CMS 

implementation grants access to the text editor for specific groups of users. 

This means that not all users will necessarily have access to the text editor. 

If you have access, your WYSIWYG screen will look like this: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A tabbed interface provides access to three distinct views: 

 Design 
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This is the default view. It is identical to the standard WYSIWYG view 

without the advanced text editing features. This view gives you full 

access to the functionality of the WYSIWYG buttons. Every function of a 

button if applied is expressed in a WYSIWYG mode (for example, bolded 

text will be displayed bold). 

 Edit 

 

This tab displays the powerful text editor with many advanced features 

displaying the HTML source code. 

The Edit view allows you full access to the functionality of the WYSIWYG 

buttons. Every function of a button, if applied, is expressed in an HTML mode 

(e.g., the bolded word ”Text” will be displayed as <b>Text</B>). Additional 

functionality is provided through the buttons and drop-down menus 

described below: 

Goto Line Number - Click on the button and type the line number you want to 

jump to, then click OK.  

Format HTML - Click on the button to format the selected HTML. Use the 

drop-down window to select which part of the text you want to have 

highlighted. This feature allows you to rapidly find the text you want to work 

with. 

Import HTML - Click on this button to import HTML from a source outside the 

CMS. In the pop-up window, type the URL of the page you want to import. 

You can also input username and password for protected pages. When you 

click the OK button, the page is imported into the WYSIWYG. 

Word Wrap - Click on the button to enable word wrap.  
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INPUT FORMS 

The CMS Input Form is an HTML form that allows you to edit and update 

specific content in the CMS. The input form will vary among document types, 

depending on the content and the placement of text and images on the 

actual page. Certain items, however, will remain constant on each page. 

 Fields 

The following fields are commonly used in Input Forms. The specific choice 

of fields is tailored to each content type. 

 Text Field 

  

The text field is used for fields with one word or sentence such as a title or 

heading. 

 Text Area 

 

 

The text area is used for fields with plain text where little to no HTML 

formatting is required, and the text is usually longer than one sentence. It is 

possible for the advanced user to enter HTML tags within the text area, 

though your specific configuration will control how much HTML is allowed. 

 Image Upload Button 

 

The Image upload allows you to upload an image from either an asset 

directory or from your computer. 
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To upload an image from your computer: 

1. On the Image Select pane, click Browse to search for an image on your 

local machine and select a file. 

2. When the filename is populated in the textbox, click the Upload button 

to upload the image within the requested box. 

To select a file from an asset folder in the CMS:  

1. Use the asset list and path navigation to select an image file.  

2. After you find the image, click the Select button at the bottom of the 

form.  

The image upload section will remember the last place you requested a file, 

so the next time you upload an image you are returned to the place of the 

last upload. 

 

 

 

 

 

 

 

 

 

 

 

 

 File Upload Button 

  

The Upload button by itself usually means that a file can be uploaded to the 

CMS. The Upload File panel allows you to select a file from your local 

machine. 
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 File Select Button 

 

The Select button is used to locate files within the CMS such as those in the 

Asset folder. You cannot upload any files from your computer with this panel. 

Note: Once you browse to a directory where there are a large number of files 

the filter gets turned on automatically, allowing you to search for specific 

assets. 

 

 

 

 

 

 

 

 File Clear Button 

  

The Clear button is used in conjunction with the Select button, and allows 

you to clear the selection from the file select field. 

 Drop-down 

  

A drop-down menu is used in cases where specific lists of values apply, such 

as particular categories of names that you need to sort or organize in a 

particular way. The drop-down may contain custom lists, or lists of folders, 

assets, etc. 

 Radio Buttons 

  

Buttons can be used for Yes or No type questions. 

 Panel Input Form 

A Panel Input Form allows for repeating a set of fields that need to be 

manually ordered, such as on an FAQ page where there can be a number of 

questions and answers on a page. 
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The Panel Input Form may contain any combination of text boxes and text 

areas along with image and file upload buttons. The Insert button delineates 

the sub-panels. The Panel Input form may also be accompanied by individual 

fields to make up a single input form. There can also be multiple unrelated 

panels in one large input form. 

 Insert Field Button 

  

The Insert button is used to insert a new row of fields. 

 Move Panel Button 

   

The move buttons are used within the panel. These allow you to move the 

panel up or down, depending on the order you want the sub-panel content to 

appear. 

 Delete Panel Button 

  

The Delete button allows you to delete the current panel from the page.  

Note: The default minimum numbers of panels are two per section. If you 

have two empty panels and you delete one, another takes its place. You are 

not limited to a maximum number of panels. 

 Link Sort Panel 
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The Link Sort Panel allows you to organize a list of links in any desired order. 

New links (typically for new assets) will appear on the bottom of the list. The 

Link Sort Panel appears on all the Asset Input forms for a related collection 

of assets, but the values are shared between all of the assets so that the list 

order is the same on each Asset Input form. 

 Top Buttons 

  

Running parallel to the name field are usually the following buttons: 

 Publish/Deploy: Deploy is a special button which depends on the user’s 

permissions. Typically, only editors and CMS administrators will have 

access to this button, which allows for the immediate deployment of the 

page along with its dependencies to the live site. 

 Save: Clicking on this button saves the content and returns you back to 

the current folder allowing you to select another task such as editing 

another asset or creating a new page. 

 Save & Preview: Save and Preview performs a save as above, then 

immediately jumps to the preview mode. If you see some changes that 

are required, you can backup to the Input Form. 

 Cancel: Removes all changes and returns you back to the current folder. 
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MENU ITEM REFERENCE 

The main Menu Bar is located at the top of every screen in the CMS. It 

provides access to all features available to you in the CMS. 

  

FILE MENU 

FUNCTION 

The File menu allows you to create and locate your content. This menu is 

one of the primary staring points for any work on the system. 

VISIBILITY 

The File menu is a top-level menu and is always visible. The sub-level menus 

appear based on your user permissions. Contact your CMS Administrator for 

access to other potions of your site being managed by the CMS. 

 New 

The New menu shows a list of document types that you can create in the 

current folder or from the current preview. If you are trying to create a 

document of a different type, make sure to use the File > Open menu to 

move to the appropriate folder first.  

When you select a new document type, the input form for that document 

appears. For asset file uploads, a file upload interface appears. 

In addition to a list of document types defined by system templates, you may 

see the following items: 

 New Folder - creates a new folder within the current folder. 

 New Upload - prompts you to upload a new file into the current folder 

(most often seen in file asset folders). 

 Open 

The Open menu allows you to go to the various folders that you have access 

to. When you select a folder from the sub-menu, you will be placed in the 

chosen folder. The folders may be for templated assets or file assets.  

If you select a folder from the File menu, you see a Folder view of the 

documents being managed by that template. The Folder view is a list of all 

the editions of the page for that template. Some templates only allow one 

live document in the Folder view (for example, the Home Page template), 
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and some allow for multiple live documents (for example, press releases). If 

the template has several categories, there may be some containers or 

folders instead of the final pages. If your template is designed in this way, 

you can browse down to the appropriate category Folder view by double-

clicking on the folders until you arrive at the desired view. 

Assets can be stored in many places on the network including the 

CrownPeak Technology servers, your Web servers, your internal servers, 

Internet storage solutions like Xdrive, and other sites. For all of these, the 

location is mostly transparent. The CMS still keeps track of workflow, 

approvals, and meta information.  

If you select an asset repository from the File menu, you will see a list of files 

and/or folders for the repository. You can select files by clicking on them. 

You can browse the folder hierarchy by double-clicking on the folders or 

using the path information at the top of the folder. 

 Search 

When you click on the Search menu item, two sub-menu options—Quick and 

Advanced—appear. When you select the Quick option, a dialog box appears 

for you to type in a search phrase.  

Type your desired search terms and click OK. The search results will be 

displayed in the main window in a fashion similar to the Folder view. Each 

asset will show the hits as bold-font keywords in context. The search results 

are returned in a relevance ranked order. In the search results view, all of 

the Edit menu functions are available. Simply select the asset, and the Edit 

menu shows all available actions defined by your group permissions and the 

document workflow permissions. 

When you select the Advanced option, you are directed to an advanced 

search window. The window allows you define search criteria by search field, 

comparison, value, and Boolean join. It permits as few or as many search 

criteria as necessary. The results are displayed on the same page, and you 

are also able to select the result criteria and sort order.  

The search criteria and results are maintained and updated for your CMS 

session, so when you return to the search pane, the most recent search is 

displayed. If you have access, you may also be able to print the results of the 

Advanced search.  

 Goto 

The Goto option provides access to the Recently Viewed Menu that (also 

accessible by pausing over the folder icon in the Folder view). 
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 Stage Site 

This option provides a bookmark to the staging server, if one is being used. 

The Stage site is shown in a new browser window. 

 Live Site 

This option provides a bookmark to your live server, if one is being used. The 

Live site is shown in a new browser window. 

EDIT MENU 

FUNCTION 

The Edit menu contains most of the commands that take action on the 

selected folder or documents. This menu is context-sensitive, based on the 

status of the selected items, and reinforces the workflow.  

In many cases, a command (like Delete, for example) may appear in multiple 

stages of a document lifecycle—but the Edit menu only enables the menu for 

the selected document’s status. This approach was chosen since the 

lifecycle is a very important concept, and must always be considered in order 

to avoid confusion about which content is live or not on the site.  

If you look at a folder with no selected documents, the menus correspond to 

the current folder. If an asset is selected, the menus correspond to that 

asset. 

VISIBILITY 

The Edit menu is a top-level menu and is always visible. The states listed are 

only for the valid states of the currently selected item. The sub-menus only 

show the actions that your user permissions and workflow allow. 

 Top Level Items 

The top-level items for the Edit Menu show all of the possible document 

states for the currently selected item. Only one item is active, and 

corresponds to the state of the currently selected item. All other states are 

inactive.  

All of the functions available for the currently selected item are shown when 

you click on the appropriate state. 

 

 

 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 74 

 Sub-Level Items 

All of these menu commands apply to the template assets. Some of these 

commands also apply to file assets. 

 Approve to Stage 

This workflow command moves the selected item to the staging server. It 

automatically goes live on the scheduled date. Workflow commands may 

vary depending on your CMS implementation, and this option may be worded 

differently or not be available. 

 Archive 

This workflow command places the selected item in the Archived Folder 

view. This view is provided as a convenience to store older assets. Workflow 

commands may vary depending on your CMS implementation, and this 

option may be worded differently or not be available. 

 Checkin 

This command is used to check an item back into the CMS. An item can be 

checked in by uploading it from the local hard disk or from an asset 

repository. You must first select an item before checking it in. New assets 

can be uploaded into the current folder (if the folder and user permissions 

allow). 

 Checkout 

This command downloads the currently selected item to your local machine. 

The item is marked as being checked out in the system. In the checked-out 

state, no other users can edit the asset. 

 Clone 

This command copies the currently selected item, but sets the state of the 

copy to Draft. 

 Copy 

This command copies the selected asset to the clipboard. 

 Cut 

This command removes the selected asset from the current folder and 

places it in the clipboard. 
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 Delete 

This command deletes the currently selected item from the system. 

Publish to Live/Deploy 

This workflow command moves the selected item from the staging server to 

the live server, making it visible to the public. Workflow commands may vary 

depending on your CMS implementation, and this option may be worded 

differently or not be available. 

 Download 

This command downloads the selected asset without being checked out. 

 Edit 

This command opens the input form for the currently selected or previewed 

asset. 

 Flag  

This command allows the user to flag an item for follow-up. 

 Hide 

This command hides the selected items in the Archive folder. Items in any 

stage can be hidden.  

 Paste 

This command pastes any assets in the clipboard into the current folder. 

 Re-Deploy 

This workflow command manually refreshes the selected item to the live 

server. The staging server is also updated. Workflow commands may vary 

depending on your CMS implementation, and this option may be worded 

differently or not be available. 

 Re-Publish to Live 

This workflow command manually pushes the selected item to the live 

server. Workflow commands may vary depending on your CMS 

implementation, and this option may be worded differently or not be 

available. 
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 Reject 

An approver can use this command to reject a submitted article. Tasks or 

visual page annotations should be added to the asset if it is rejected to help 

the document author make the required changes. 

 Rename 

This command allows the currently selected item to be renamed. 

 Retire 

When you retire an item, it is unlinked or removed from the live site 

(implementation-dependent). The document remains in the Folder View until 

it is manually moved to the Archived Folder View. 

 Revert To 

When viewing the versions of an item, this command will allow the item to be 

overwritten by the selected version. 

 Send for Approval 

This workflow command approves the selected item for publishing. If the 

item needs multiple approvals, they are still required before the asset 

changes to the Approved state. Workflow commands may vary depending on 

your CMS implementation, and this option may be worded differently or not 

be available. 

 Set Schedule 

This command brings up the scheduling details for the selected item. 

 Spell Check 

Opens up the Spelling form for the currently selected asset. The form allows 

you to correct the spelling for the currently selected or previewed asset. 

 Unlock 

This command allows the locked status for an asset to be manually 

overridden. This is usually available only for higher-level users of the CMS. 

Contact your CMS Administrator if you need to have a lock manually 

removed from an asset. 

 Branch 
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This command allows you to create a separate version of the current 

document that is set to the initial workflow state. By creating a branch, you 

can take this separate version of the document through the workflow while 

leaving the existing version live. When the branched version goes live, it 

replaces the previous live version. 

 Route 

The routing interface allows a document to be moved to any step of the 

workflow, regardless of its current state. 

VIEW MENU 

FUNCTION 

The View menu is used to view the various aspects of assets and folders. 

VISIBILITY 

The View menu is a top-level menu and is always visible. The sub-menu 

items are visible based on your group permissions. 

 Preview 

The Preview menu allows you to preview the documents from the CMS 

servers. The sub-menu shows you a list of documents that you have access 

to. 

 Folder/Current Folder 

This command brings up the main Folder view for the current asset or 

Archived Folder view. 

 Tasks 

This command opens up the Task view for the currently selected or 

previewed asset. The Task view allows you see the task history for an asset, 

and add new tasks using File > New > Task. 

 Versions 

This command opens up the Versions list for the currently selected or 

previewed asset. The Versions list allows you to preview (by clicking on the 

icon) or roll back an Asset (using the Edit menu) to a previous form. 
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 Properties 

The Properties menu allows you to view the various system properties for an 

asset. Many of the sub-items are only available to administrative level users. 

 General 

This shows system internal field information for the current asset or 

folder. 

 Meta-Data 

This shows meta-data for the current Asset or Folder. If you have edit 

access to meta-data, you can edit these properties. Meta Data fields are 

configured for each installation and are shared among all assets. 

 Access 

Access Properties allow your CMS Administrator (and possibly editor-

level users) to control user access to the current Asset or Folder. 

 Content 

This shows the unformatted content data fields for the current asset. 

 Alerts 

This brings up the Alerts Panel, which allows you to select what kind of 

e-mail notifications you want for the current asset or folder. 

 Template 

Template Properties allow your CMS Administrator to assign a template 

to the current asset. 

 Workflow 

Workflow Properties allow your CMS Administrator to control workflow 

for the current asset or folder 

 Publishing 

Publishing Properties allow your CMS Administrator to control publishing 

for the current asset or folder 

 Audit 

This shows an audit report for the current asset. The report lists all actions 

taken with regard to the asset. 

 Archived Folder 
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This shows all archived assets corresponding to the current folder. The 

Archived Assets can be moved or copied to the current folder by selecting 

them (clicking on the labels) and using the Edit menu to move or copy them 

to the current folder. 

 Hidden Folder 

This shows all hidden assets corresponding to the current folder. The hidden 

assets can be moved or copied to the current folder by selecting them 

(clicking on the labels) and using the edit menu to un-hide them to the 

current folder. 

 Output 

This shows HTML output of final published assets. 

SYSTEM MENU 

FUNCTION 

The System menu provides access to many internal configuration items, 

system-wide communication features, and reporting. Many of the items in 

this menu are only available to system administrators. 

VISIBILITY 

The System menu is a top-level menu and is always visible. The sub-menu 

items are visible based on your group permissions. 

 Audit 

 System 

The System Audit shows every action recently taken in the system. It 

shows log in and log out events, as well as any document change 

events. This report provides a detailed system-wide log of all system 

usage, and allows filtering for custom reports. This menu is typically 

reserved for the manager-level users of the system. 

 Publish 

The Publish Audit shows every publish action recently taken in the 

system. This menu is typically reserved for the manager-level users of 

the system. 
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 Configure 

The Configure menu is the main entry point for all system configuration 

options. Most of these items are only available to system administrators and 

are documented in the Developer Guide. 

 My Account 

The Account section allows you to update your profile, preferences, and 

establish e-mail task notifications. E-mail asset notifications are set up via 

the View > Properties > Alerts menu. 

 Edit 

Brings up the account profile screen, allowing you to enter contact 

information, etc. 

 My Flagged Assets 

Shows a report of your flagged assets. 

 My Queued Assets 

Shows a report of all your current assets that are in the publishing 

queue. 

 My Modified Assets 

Shows a list of assets you have modified. 

 Home 

Clicking on Home links you to your Home as specified in the Preferences 

below. 

 Preferences 

Allows you to set up your startup screen, default e-mail task 

notifications, and default folder properties. 

 My Summary 

The summary report is a combined list of current items for the current 

user. It includes pending tasks, recently modified pages, and any 

pending approvals requiring attention. 

 Logout 

Selecting this command logs out the current user. User status is 

maintained on the server, but keyed to a temporary cookie. After 20 

minutes of not using the system, a user is automatically logged out. 

 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 81 

 Reports 

The Reports menu provides access to the many built-in system reports, as 

well as custom reports. Every action on the CMS is logged, and the reports 

provide access to that data in many forms. This menu is often reserved for 

the manager-level users of the system. Custom reports can be created by 

running an advanced search and creating a report. These reports are 

available to all users. 

 Site Tasks 

The functionality allows you to send reminders and assign tasks to other 

users as necessary. 

 Tools 

The Tools menu allows you to monitor content and resubmit assets. These 

items are only available to system administrators and are documented in the 

CMS Developer Guide. 

HELP MENU 

The Help menu contains all of the information in the CMS User Guide, as 

well as the following standard links: 

 Troubleshooting 

 User Guide 

 Admin Guide 

 Developer Reference Guide 

 Developer Training Guide 

 Common Actions 

 API Guide 

 IE7 Guide 

 CrownPeak Website 

 CrownPeak Web Site 

This is a convenience link to the CrownPeak Technology Web site, a location  

for latest press releases and upcoming product information. 
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INTERFACE ELEMENT REFERENCE 

ICONS 

 General Interface Icons 

  Avatar representing user – Change your avatar by clicking on the 

image 

  Navigate one level up 

  Filter the current view 

  Refresh screen 

 Access shortcuts menu – Recently visited folders 

 User action required – document has changed (dirty document) 

 Document is locked by other user 

 Document is locked by current user 

 Document is scheduled 

 Document has a note associated 

 Indicates a flagged item 

 Task 

 High and Low priority for tasks 

 Icons Representing File Extensions 

 ASP code (asp)   Movie File (mov) 

 CMS standard page  Adobe PDF file (pdf) 

 Microsoft Word (doc)   PICT graphic file (pict/pct) 

 Executable (exe)   PNG graphic file (png) 

 Flash   PowerPoint file (ppt) 

 Zip compressed file (zip)   TIFF graphic file (tiff/tif) 

 GIF graphic file (gif)   Text file (txt) 

 HTML file (html/htm)   Visio file (vss) 

 Java   Excel file (xls) 

 JEPG graphic file (jpg)   WAV audio file (wav) 
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 Yellow Cross Icons 

     

Little yellow crosses on icons represent indicate that a template is 

associated with that page. Editing such a file is done using an input form. All 

other files are edited by downloading (and checked out/checked in). 

WYSIWYG EDITOR BUTTONS 

 General 

  Copy 

  Paste 

  Undo 

  Redo 

 Text Formatting 

  Bold  

 Italic  

  Underline  

  Insert a special character 

 Cut or delete Text 

 Crop  

 Add shading to text 

 Set a text color 

 Align Left 

 Align center 

 Align Right 

 Increase Indent 
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 Decrease Indent 

 Find Text 

 Replace Text 

 Creating Links 

 Create Hyperlink (External) 

 Remove Link 

 Create Anchor 

 Create Anchor Link 

 Working with Images 

 Insert/Replace Image 

 Edit Image 

 Lists 

 Bullet List 

 Numbered List 

 Tables 

 Insert Table 

 Edit Table 

 Insert new columns into the table  

 Delete selected column from table 

 Insert new row into table  

 Insert new bottom row into table 

 Delete selected row from table 

 Insert new cell into table 
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 Delete selected cell from table 

 Split selected cell in table 

 Merge selected cells 

 Show/Hide Borders 

 Edit HTML 

 View HTML Source 

 Show details 

 Remove HTML 

 Page Break 

 Import HTML 
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