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INTRODUCTION 

This document is to be used by CMS Administrators and Developers, and 

covers all of the administrative level features of the CMS interface. Before 

working with the interfaces documented here, you should: 

 Be familiar with how to use the system to author and manage content 

 Read the CMS User Guide 

 

PURPOSE OF THIS DOCUMENT 

CrownPeak CMS offers an incredible range of options to tune and customize 

each implementation, and the entire system configuration is available 

through the same Web interface used by content authors and editors.  

A system of hierarchical permissions controls what users can access and do. 

Most clients appoint a local CMS Administrator to their team who manages 

all of the various aspects of their CMS implementation. 

Typically, CMS Administrators are given only the minimal access they need to 

handle their regular work. For unusual or complex configurations, the 

monthly service hours should cover most needs; you can ask your 

representative to configure the system for you. CrownPeak takes this 

approach since the configuration has a very big impact on the operation of 

the system; giving end users less control over the system helps ensure the 

integrity of each CMS. 

Since each user account has different levels of permissions, many of the 

functions described in this document may not be available to you. If you 

need more control over one of the areas, contact your local CMS 

Administrator. If you are the CMS Administrator, contact your CrownPeak 

representative to modify your permission levels. 

 

NOTE TO DEVELOPERS 

For developers, there are some sections of this document that outline the 

CMS development process. These sections are, of course, documented in 

more detail in the CMS Developer Guide. This Administrator Guide, however, 

is central to implementing an instance of CrownPeak CMS because the 

template programming process is only part of each successful 

implementation.  
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THE DEVELOPMENT PROCESS 

A large portion of the effort in implementing CrownPeak CMS involves 

working with the Web interface (with Administrator level permissions) to 

configure the system. All of the folders, users and groups, workflows and 

approvals, models, etc. are managed using the same interface to which all 

users of the CMS have access. However, most users do not have access to 

administrative level functions and will never see them in the menus (since 

only options available to you appear).  

Depending on your specific level of permissions, you may or may not see all 

of the capabilities documented here. The permissions are hierarchical, so 

you can only assign and view permissions and groups of which you are a 

member. 

 

“BUILDING VS. TWEAKING” 

The section below outlines the development process, and covers the typical 

sequence of actions required to build an implementation of the CMS from 

the ground up. Most of the time, however, this document will be used to help 

a CMS Administrator make small changes to the system. If you are in the 

latter of these two situations, you can skip this chapter and proceed to the 

specific reference sections relevant to the task at hand. 
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STEP-BY-STEP DEVELOPMENT PROCESS 

The process of developing in CrownPeak CMS follows several basic steps. In 

general, you move though these in order, and repeat several steps for each 

section or template of the CMS.  

The development process always involves a certain amount of successive 

refinement. For example, you will often set up a structure, group or workflow, 

move to a related piece, and then come back and fine-tune the 

configuration. 

The steps on template creation and content colder/initial file creation are 

interchangeable, depending on your preference. 

 

CMS DESIGN 

The first step in any implementation is to plan out how you want to set up 

the CMS. Although it is easy to make changes in the system, having an initial 

plan will make the development process go a lot faster. The CrownPeak 

Technology staff is happy to help with this process, offering many years of 

CMS and Web site development experience. 

 

CREATE A CMS INSTANCE 

Creating a new instance of the CMS is a step reserved for CrownPeak 

Technology staff. Since this process creates a new file structure on the 

servers and a new database, you need to contact CrownPeak Technology to 

start any new project.  

Note: Depending on your contract, there may be costs involved in creating 

new instances. 

 

CREATE INITIAL TEMPLATES 

A new CMS instance has a System folder in place, which contains a folder for 

the templates. From the Templates folder, you can create a new template. 

In essence, a template is a collection of input, output, and content 

processing template files. The input template file contains the data entry 

fields and layout, and the output template file contains the final HTML with 

field markers and VBScript code inserted.  
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One approach to developing your templates is to start by pasting some site 

HTML into an output template file, then replace selected content with fields, 

followed by creating an input template file to support those fields. To assist 

with this approach, the Template Editor has an import feature to get the 

HTML from an existing Web page, along with registering the images. This can 

be a big time saver. (The reverse approach is to create an input template file 

with the desired fields, and then build the output template file to use the 

fields.) 

Once the template files are ready for testing, you can associate them with an 

asset using the View > Properties > Template interface. Editing the asset will 

show the input template file, and viewing the asset will show the output 

template file. 

The Templates section of this document covers the interface to assign a 

template to any given asset (or model asset). To create an entirely new 

asset, you can upload a blank file. After that, you can clone it or make it a 

model to allow the File>New menu to be used (this is described later in this 

document). 

Note: Templates are documented in more detail in the CMS Developer Guide 

 

CREATE CONTENT FOLDERS/INITIAL FILES 

After the CMS is initialized, you will need to login and start creating the folder 

structures to contain the content and models. Remember that the folder 

structure in the CMS does not have to correspond to the Web site 

directories. If there is some correspondence, however, you may be able to 

use folder names or other CMS information directly in file naming and 

placement as a convenience. Hybrid approaches are fine too, where only 

some of the Folders have meaning related to the Web server.  

Because there are multiple methods for configuring publishing information—

from the Asset and Folder Publish properties to the filename.asp template 

file—you can have complete control over the naming and placement of each 

file (the CMS Developer Guide has more information on this). It is important 

to note that, with all of these customization points, you can structure the 

folders in the CMS in the most logical way for your particular users. 

New Folders are created via the File > New > Folder menu option. 
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CONTENT FOLDERS 

Content Folders represent a hierarchy in the system that makes sense to 

your specific implementation and users. If you are managing only a few 

content types, you may make a series of folders at the root level. If there are 

structures like departments, you may want to establish a multi-level 

hierarchy.  

In most ways, this process is very much like setting up directories in any OS. 

 

CREATE INITIAL MODELS 

In the System folder, there is a folder named Models in which you place 

content models. Models are used to provide a seed asset with a base 

configuration, including permissions, workflow, and other settings.  

The File > New menu option is primarily built from the models in the system. 

One way to think about models is that they are similar to clones of an 

existing asset—they provide boilerplate content and settings.  

The power of models comes in when: 

 You use several prototypes (which the author can choose from). 

 You have a collection of assets and folders, which can have recursive 

Model definitions.  

This approach allows CrownPeak CMS to create entire structures with a 

simple File > New menu option. 

From the /System/Models folder, use the File > New > Folder menu to make 

a new folder, and the File > New > Upload menu to make a new blank model 

asset (or clone an existing asset).  

 

REFINE DIRECTORIES AND TEMPLATES 

At this point in the CMS construction process, there is usually a recursive 

refinement period where you update models and templates until the system 

seems to be creating content correctly. Repeat the above steps for folder, 

file, and model setup, along with additional template coding. 
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SET UP GROUPS 

Next, you need to establish the groups or user roles in the system. This 

document contains the information for setting these up in the User and 

Groups section.  

Setting up the group names (roles) is more important than the specific 

permissions at first, so you can start with a basic set of all the group 

permissions and refine them later. 

 

SET UP WORKFLOW AND WORKFLOW FILTERS 

The workflow and workflow filters (similar to Approval Processes) are 

configured separately, but since they are conceptually similar, you will 

usually set them up together.  

In the Workflow admin interfaces (detailed below), you specify which actions 

(approve, schedule, etc.) can be performed at each step of the document 

lifecycle, and which states are active and mapped to each step. In addition, 

you can create workflow filters that function as an approval scheme for 

specific commands in each workflow.  

After the workflow is configured, you typically proceed to the Workflow 

Filters, where you can refine which groups and/or users participate in each 

step. 

 

SET UP USERS AND TEST/REFINE ROLES 

The final process is to create actual user accounts with the groups you have 

created. Log in as a user for each role, and make sure the system shows the 

appropriate controls and allows you to manage the appropriate content. 
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DEVELOPER DOCUMENTS 

Several documents are included in the complete set of CrownPeak CMS 

documentation: 

CMS USER GUIDE 

The CMS User Guide is designed for end users of the system and is the 

starting point for all the other documents. A thorough user-level knowledge is 

essential before modifying or developing your CMS since many of the user 

interface concepts are introduced in this document. 

 

ADMINISTRATOR GUIDE 

This CMS Administrator Guide extends the User Guide to cover all of the 

additional functionality in the CMS related to configuring the system. This 

document is intended for CMS administrators and developers. 

 

DEVELOPER GUIDE  

The Developer Guide documents template development. 

 

API REFERENCE 

The API Reference details the template file language. 
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FILE/FOLDER METAPHOR AND SYSTEM 

FOLDER 

CrownPeak CMS uses a file/folder metaphor to represent content rather 

than a database metaphor. While the underlying content is stored in a 

database, the file/folder representation leverages a concept with which 

most users are more familiar.  

The file/folder concept enables some very sophisticated capabilities, such 

as converting folder and file names into URLs or mapping certain templates 

to folders and pages through the use of “models.” 

 

CLIENT FOLDERS 

From the root folder, there is typically a System folder and a Client folder 

(typically named “Site”). While many clients just need a single folder for their 

project, some have various projects that are handled by the same CMS 

instance. The Client Folder helps to compartmentalize content, code, and 

access between separate projects. 

Within each Client Folder there are various Content Folders. The Content 

Folders are specific to each CMS, and may represent your site hierarchy, 

Web server directory structure, organization hierarchy, or any combination of 

these. The structure is tuned to your specific needs during CMS construction.  

HTML files can be published using any path, not just the ones used in the 

CMS. This flexibility allows a certain structure that might be better 

understood by your authors, while allowing any required Web server 

structure. If desired, the same structure can be used for the CMS and Web 

Server, or a combination of both.  

 

SYSTEM FOLDER 

The system folder is used to hold most of the internal CMS files such as 

templates, models, workflow states, etc. The folder itself has no special 

properties, so the name “System” is used by convention only. 
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TEMPLATES 

The Templates folder holds all of the template source code files. For each 

template, there is a sub-folder containing one or more template files. A 

Template folder roughly corresponds to a separate type of content. Within 

that folder the template files define the specific input forms, display, or code 

entry points (see the CMS Developer Guide for detailed descriptions of each 

template file).  

The most common template files include: 

INPUT.ASP 

Defines the content data entry form for the Template. 

OUTPUT.ASP 

Defines the output view for the Template. This is normally the HTML for the 

site (for that type of page or page part) with embedded CMS functions. If 

there is no preview.asp template file in the Template folder, this file is used 

for the CMS preview as well. 

Additional output template files can be created with any name (and are 

commonly referred to as “layout files”), and will be published after they have 

been set up in the Publish options. 

PREVIEW.ASP 

The preview.asp template file is very similar to the output.asp file, and can 

be used to provide a different preview in the CMS from the actual deployed 

content. This is often used to provide a streamlined preview within the CMS, 
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such as showing the page without the entire navigational context, a useful 

technique to help focus the content author on the specific content they are 

editing. 

POST_INPUT.ASP 

Post_input.asp is one of many process-oriented Template Files. It is called 

when the user clicks on any “Save” operation (“Save”, “Save and Preview”, 

“Save and New”) from the input form, and allows any required data 

manipulation or field checking before the content is stored in the database. 

HELP 

The Help folder allows instance-specific help to be added to the system. 

Adding a file here modifies the help menu (the File > New menu provides a 

generic asset with a WYSIWYG editor). The file name appears in the menu, 

and clicking on the new menu item brings up a new window with the help 

file. 

MODELS 

Models are “seed” folders (meaning empty, no content is stored in them yet) 

that get created when users use the File > New model menu option. Files 

created in this way are typically in DRAFT mode. In the Models folder you 

typically assemble all the Model folders and files to represent all new 

content (content available for selection in the File > New menu option).  

Note: More information on models appears later in this document. Models 

can reside anywhere in the system, but the conventional location is in 

“/System/Models/”. 

DICTIONARY.TXT 

The dictionary.txt file is the collection of extra words shared by users in your 

instance of the CMS. Generally, this file is extended when users “Add” a 

word to the dictionary (using the Spell Check tool). You can also edit this file 

directly in case you want to clean it out or add standard lists of words. 

LIVE SITE/STAGE SITE 

The Live Site and Stage Site links are created when you configure the FTP 

access to the destination STAGE and LIVE servers in System > Configure > 

Export > FTP. For each FTP server you define, an entry appears here (thus, 

you may have greater or fewer entries than Live Site and Stage Site, 

depending on your configuration).  

When you click on one of the links, you see an asset folder view for that 

remote FTP server. This is similar to using any FTP client to access the 

server, except that CMS provides auditing on any actions performed. 
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LOGIN.ASP 

If available, the login.asp file allows you to process the login of users to the 

CMS. This might be done to modify the groups to which a user belongs in 

order to suit a different interface mode (basic/advanced) or other types of 

operations.  

Consult your CrownPeak CMS Administrator if you have further questions on 

how this might apply to your installation. 
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USERS AND GROUPS 

Three levels of access control, in combination, control a user’s ability to 

create, view, and modify documents: 

 Groups (user roles) 

 Workflow States 

 Folder/File Permissions  

Your group permissions control what your overall capabilities are for the 

system. For example, can you create new documents? Can you edit them? 

Can you approve them? What kinds of editing operations can you perform 

when using the WYSIWYG editor?  

Your local administrator is in charge of setting up accounts and choosing to 

which groups you belong (your CrownPeak representative typically sets them 

up for you the first time during CMS construction). Users can be members of 

several groups, and groups are often based on combinations of content 

types and roles. For example, a CMS with Press Releases and Products with 

authors and editors might have the following groups: 

 Release Authors 

 Release Editors 

 Product Authors 

 Product Editors 

Let’s say there are three users of your CMS: Bob creates new press releases, 

Mary creates and approves new products, and Jane is the 

manager/approver for both (and can also create/edit any documents). In 

this case, Bob would be in the release authors group, Mary would be in the 

product authors group and product editors group, and Jane would be in all 

four groups. The two author roles allow document creation, while the two 

editor roles also allow approval. 

These combinations of group permissions correspond to the roles that each 

user plays when using the CMS. 

 

USER ADMINISTRATION 

The User Administration pages allow you to create, enable/disable, modify, 

clone, and delete users of the CMS.  

To access the User Configuration menu, choose System > Configure > Users: 
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This page provides an overview of the users in the system. Again, the groups 

to which you belong determine your level of access within the CMS—and you 

can only see users within the groups to which you belong.  

This feature allows, for example, department heads to configure new users 

for their own department without interfering with other departments. A 

system-wide administrator would belong to all groups in the CMS and would 

therefore be able to create/modify/clone/delete users throughout the 

system. 

Key user fields include the following: 

 

Login Name 

This is the username of the user, needed for logging into the CMS. The login 

name is assigned by the administrator initially and may be updated by the 

user. 

To access an individual user’s account information, double-click on the login 

name, or select the user (left click or right click) and use the Edit User 

command. 

 A green-colored login name (for example, vchang) indicates an active, 

enabled user account. 
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 A red login name (for example, wwolkenberg) indicates a user account 

that has been disabled.  

Note: See the Enable/Disable User Accounts section. 

 

 Real Name – Refers to the real name of the user as set in the First 

Name and Last Name fields in the user account. 

 E-mail Address – The e-mail address of the user—used by the system to 

send out e-mail alerts and task notifications. 

 Groups – Indicates the groups to which the user belongs. Clicking on the 

group name opens the group for editing.  

Note: Users typically cannot modify their own groups. 

 

NEW USER 

To create a new user, choose File > New User.  

For details on the User screen, see the Edit User section.  

EDIT USER 

Select a user and choose Edit > Edit User from the top menu (or by right-

clicking on a Login Name from the user list screen). For your own account, 

the Edit screen can also be accessed by clicking on your avatar on the left 

side bar, or by choosing System > My Account > Edit menu. 

 You can enable/disable user accounts with the Status drop-down menu. 

It allows user accounts to be quickly disabled/enabled. Disabling an 

account does not remove it from the system, but does prevent the user 

from logging into the CMS. 

 The Password field does some validation to ensure a sufficiently strong 

password is used. Passwords that do not contain letters, numbers, and 

extended characters will need to be modified accordingly. 

 Expires on allows you to set a date on which the account will expire, 

automatically denying the user access after this date. Select a date from 

the calendar popup, or leave it blank for no expiration. 

 Username provides a place to change the username (login name) for the 

chosen user. 

 The Groups selection allows you to assign the user to one or more 

groups. Note that Users will typically not see this menu, unless they have 

administrator level permissions. 
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All the other fields are for user contact information. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PREFERENCES TAB 

Use the Preferences tab to configure additional parameters relating to the 

user’s account in the CMS.  

 Startup Preferences – Define the user’s home file/folder (used by the 

Home link on the left side info panel of the CMS interface), what is 

displayed when they log in, and their default browse state(s) for 

previewing content in the CMS. 

 Summary Page View – Configures the My Summary page, linked to from 

the My Summary link on the left side info panel of the CMS interface. 

 E-mail Preferences – Defines which Task system e-mails are sent to the 

current user. 
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 Folder Preferences – Allow you to set the default folder sort order and 

number of items show during pagination. 

 Other Preferences – Allow you to hide the left side info panel and/or 

hide the Publishing pop-up window. 

DELETE USER 

To delete a user permanently from the CMS, choose Edit > Delete User.  

Note: For users who will no longer be using the CMS, it is generally 

recommended that you disable their account for a time rather than delete 

their account. By disabling their account, they are still unable to use the 

CMS, but their username will be preserved in the various reports in the CMS, 

which can be useful in viewing historical user activity. 

CLONE USER 

Sometimes it is faster to clone an existing user and make some changes 

rather than creating a new user. To do this, choose Edit > Clone User. 

ASSUME IDENTITY 

A quick way for troubleshooting user roles and access privileges is to 

assume the identity of the user in question. By choosing Edit > Assume 

Identity, you can login as the selected user and witness how they experience 

the CMS. 

Note: Be careful when using this tool, as it can be easy to forget you are 

logged in as someone else, or that you may have another browser open in 

which you are logged in as yourself. 
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GROUP ADMINISTRATION 

To access the Group Configuration menu, choose System > Configure > 

Groups.  

The Group Administration pages allow you to create, edit, clone, and delete 

groups within the CMS. These pages also provide an overview of the groups 

used within the system.  

 

 

 

 

 

 

 

 

 

 

 

 

 

To access the Edit Group page, select a Group, and choose Edit > Edit 

Group. The Groups, along with the State Access Control Lists (ACL’s) and 

Asset ACL’s make up the three-tiered matrix that defines the permissions for 

an asset in the CMS. 

GROUP NAME 

Group Name is a label for a particular group and is used throughout the 

system when referring to group level access or permissions, and when 

assigning users to groups. 

DESCRIPTION 

This section rovides a short description to help identify the group and its 

purpose. 

USERS 
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Indicates the Users assigned to this Group. Each User Name is hyperlinked 

to the user’s edit screen.  

NEW GROUP 

To create a new group, choose File > New Group.  

For more details on the Group page, see Edit Group below.  

EDIT GROUP 

This page is accessible by selecting a group and then choosing Edit > Edit 

Group. On the Edit Group interface, the capabilities check boxes will only 

appear if you have those permissions; thus, many of the items described 

here may not be available for you to assign. 

 

 

 

 

 

 

 

 

 

 

 

 

 Group Name - Identifies a particular group and is used throughout the 

system to assign users to a group. (* = Required Field) 

 Description - A short description helps to identify the group and its 

purpose. 

 The list of group members lets you know who is assigned to this group. 

Each name is hyperlinked to the Edit User screen for that user. 

Note: If you un-assign a certain access property from a group you belong to, 

and none of your other group memberships give you access to that property, 

you will not be able to restore that ability after saving the configuration. If 

this happens, please contact your CrownPeak Administrator for assistance. 
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USER PREFERENCES 

  Use this group of check boxes to grant users of the group the following 

capabilities.  

Users can: 

 Set their login view 

 Set task alert preferences 

 Set their default folder preferences 

 Set and view their flagged assets 

 Set their “other” preferences 

 Set their annotation preferences 

 Set their summary page preferences 

 Create page annotations 

 View/use the main navigation menu bar 

 View/use filters on file/folder/object listings 

 View/use the last accessed shortcut popup 

 View/use the right mouse click menu 

 Click on a username to view their info 

ASSET CAPABILITIES 

  Use the check boxes to grant users of the group the following 

capabilities.  

Users can: 

 View files and folders 

 View other user’s files 

 Create new uploads and folders 

 Edit files 

 Edit any file (besides their own) 

 Unlock files locked by other users 

 Audit files and folders 

 View a file’s version history 

 Revert a file to a previous version 

 Delete any file (besides their own) 

 Undelete files 
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 View and add to a file’s comments 

 Delete a file’s comments 

 Access hidden assets 

 Publish files/folders to Websites 

 Re-publish files/folders to Websites 

 Upload files 

 Create folders 

 Create files, folder, pages, folios based on Models 

 Delete folders (and their contents) 

 Delete files 

 Download files (in addition to viewing) 

 Check out files 

 Rename folders 

 Rename files 

 Move files 

 Move folders 

 Copy files 

 Copy folders 

 Clone (copy and pages) documents 

 Create branched documents (document that replace their original) 

 Un-branch documents (documents become detached from their original) 

 Set document as hidden 

 Route workflow documents to any workflow step 

 Paste documents anywhere (unrestricted) 

 Set file/folder workflows 

 Set page templates 

 Set file/folder options (icon, filter, etc.) 

 Set view file/folder metadata 

 Set file/folder metadata 

 Set schedule information 
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 Set up refresh schedule 

 Set file publish attributes 

 Set file/folder access 

 Set file/folder alerts 

 Import content using zip files 

 View file/folder content summary 

 View file/folder general properties 

 Set new file, folder, page, folio models 

 Import zip files to populate templates 

TASK CAPABILITIES 

  Use the check boxes to grant users of the group the following 

capabilities. 

Users can: 

 View their tasks or those assigned to them 

 Create new tasks 

 Edit tasks assigned to them 

 Add comments to their tasks or those assigned to them 

 Acquire unassigned tasks 

 Search all tasks 

 Edit any task 

 Add comments to any task 

 Delete tasks 

 Clone tasks 

REPORT CAPABILITIES 

  Use the check boxes to grant users of the group the following 

capabilities. 

Users can:  

 View reports 

 View user command report 

 View user summary report 

 View user visibility report 
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 View user activity report 

GUI EDITOR CAPABILITIES 

These options control which widgets will be available to users of the 

WYSIWYG editor field: 

  Use the check boxes to grant users of the group the following 

capabilities. 

 Design Tab – Allows access to the Design Tab (if configured) 

 Edit Tab – Allows access to the Edit Tab for viewing Raw HTML (if 

configured) 

 Styles – Allows access to the Style popup menu. 

 Font – Allows access to the Font popup menu. 

 FontSize – Allows access to the Font Size popup menu. 

   HTML Forms  

   Bold  

   Italic 

   Underline 

   Align – Allows access to all align buttons (left, right, center) 

   Lists – Allows access to both ordered & unordered list buttons 

   Indent – Allows access to indent and un-indent buttons 

   ForeGround Color – Allows access to the color selector 

   BackGround Color – Allows access to the color selector 

     Links – Allows access to internal and external link popup 

as well as the remove link button. 

   Anchor Links 

   Cut, Remove HTML, Crop  

   Copy 

   Paste 

   Table – Allows access to all table editing buttons. 

    Undo/Redo 

   Images – Allows access to the image upload and select popup 

as well as the image edit image button. 
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   Page Break – Allows a Page Break to be inserted that can be 

programmatically processed to allow for pagination of content. 

   Details – Displays icons in the content that provide a graphical 

representation of the HTML present. 

GROUP CLONING 

  Use the check boxes to grant users of the group the following 

capabilities. 

 Cloning this group also clones group asset ACL configuration (View > 

Properties > Access) 

SYSTEM CAPABILITIES 

  Use the check boxes to grant users of the group the following 

capabilities.  

Users can: 

 Refresh the entire sites 

 Resubmit all assets within current folder 

 Search and replace assets from their current folder 

 Directly edit any template fields (in content view) 

 Create new client CMS systems 

 See enabled Goto Asset in the Content menu 

 See enabled Debug output popup in the View menu 

 See enabled Display Table Borders in the Content menu 

 Configure system properties 

 Configure global menu properties 

 Configure global filename/URL properties 

 Configure global security properties 

 Change system variables (root content items) 

 Set up import configurations 

 Set up export configurations 

 Create/modify/delete asset workflows 

 Create/modify/delete workflow filters 

 Create/modify/delete user accounts 
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 Create/modify/delete groups 

 Assume another user’s identity 

 View the system audit 

 View the publish audit 

 Edit the title, department, and location dropdown in the edit user 

interface 

 Clear all document errors 

 Clear all queued documents 

 Set up/view the content monitor interface (tools menu) 

HELP GUIDES 

  Use the check boxes to grant users of the group the following 

capabilities.  

Users can: 

 View the Administrator help documents 

 View the Developer help documents 

 View the User help documents 

 View the API help documents 

 

THE USER/GROUP MATRIX 

The User/Group Matrix provides you with a simple visual way of correlating 

users with groups. To access the User/Group Matrix, choose System > 

Configure > User/Group Matrix. 

Use the check boxes to assign a user to a particular group. 

 

 

 

 

 

 

 



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 30 

STATES 

Within the CMS, assets may be placed into a workflow that defines its 

document life cycle. For each step in this workflow, the asset transitions into 

a “state.”  

The state identifies the current status of the asset using a descriptive label 

and an ACL specification. This ACL specification defines the operations a 

group member may perform on the asset when it is in that particular state. 

As such, the state represents the second of the three tiers of access control 

(group configuration, state ACL’s, asset ACL’s). 

The states are typically located in the System folder, under /System/States 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There is a file and folder associated with each. The state ACL’s are 

configured in the same way as any other file or folder: Select the file or folder 

and choose View > Properties > Access from the menu. 

The state file assets have their own template, and have limited configuration 

options when edited. 
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 State Color – Allows you to select a color that will be used to identify the 

state throughout the CMS. 

 Help – Allows for a brief description of the state. 

 To create a new state, simply clone an existing state, rename it 

accordingly, then modify the color and help text as needed. 
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WORKFLOW 

The workflow integrates the concepts of states and approvals into a 

sequence that describes a document’s lifecycle in the CMS (see the 

discussion of workflow filters in the next section). By blending these 

concepts together, a workflow is created that specifies what actions may be 

performed on a page, when those actions may be performed, and who may 

perform them. Depending on its configuration, the workflow can create a 

rule that says a page may not be published to the live Web site without first 

being approved.  

On a basic level, a workflow is composed of steps and commands. The steps 

represent a stage of the document life cycle, and the commands provide the 

means to transition from one step to the next. Because a workflow can vary 

greatly in complexity, the Workflow Administration interface supports a wide 

range of functionality, allowing for diverse and robust workflows to be built. 

Using the Workflow Administration interface, you may create, edit, clone, or 

delete workflows. A single workflow can apply to a single file or folder, or 

every file or folder in your CMS implementation.  

Note: Files and folders do need separate workflows since the ACL properties 

of the state need to be properly configured for the type of asset to which you 

are applying a workflow. 

 

WORKFLOW ADMINISTRATION 

To access the Workflow administration menu, choose System > Configure > 

Workflows: 
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USAGE 

The Usage column identifies the number of assets that are currently making 

use of the named workflow. You can find out which assets use that workflow 

by using the Advanced Search tool in the CMS. 

NAME 

The Name column indicates the name of the Workflow. This name is the one 

used throughout the CMS to identify the workflow. You can change the name 

in the Edit Workflow screen. 

DESCRIPTION 

The Description column provides a short explanation of the workflow. 

MODIFIED BY 

The Modified By column identifies the user who last modified the workflow. 

MODIFIED ON 

The Modified On column identifies the date the workflow was last modified. 

 

NEW WORKFLOW 

To create a new workflow, choose File > New Workflow.   

 

EDIT WORKFLOW 

To edit an existing workflow, select it from the list and choose Edit > Edit 

workflow.  
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This is the Edit Workflow page: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NAME 

The Name field identifies the workflow. This name is the primary displayed 

identifier for the workflow throughout the CMS. (Workflows also have an ID 

number which is useful in the template coding.) 
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DESCRIPTION 

The Description field contains a short explanation of the workflow. 

 

WORKFLOW STATE DIAGRAM 

The Workflow State Diagram provides a visual representation of the current 

workflow, including its steps and the commands that illustrate an asset’s 

transition from one step to the next. The diagram is interactive as well; all 

workflow configuration is accomplished by clicking on areas of the diagram 

that control specific workflow functions. 

STEPS AND GENERAL PROPERTIES 

The column headers at the top of the diagram represent the steps in the 

workflow:  

  

The steps correlate to the states configured in the CMS. In this way, the 

workflow serves as the link between the state ACL’s and the asset ACL’s, 

creating part of the three-tiered ACL structure.  

A step has a configuration interface as well, which is accessed by clicking on 

the step title.  

Note: Any configuration specified in a step is applied to the asset when it 

enters the workflow step. 

In the General Properties interface, the following options may be configured: 

 Title - The title of the current step, used elsewhere in the Workflow 

configuration. 

 Description - A brief text description of the purpose of the current step. 

 Status - A drop-down menu with a list of all the CMS states. This 

determines the column header and coloration of the current step. 

 Access - A CMS selector that allows you to choose the file or folder that 

will be the basis for access control in this workflow step. Usually, this will 

be the same as the status, but in the case of setting a folder (folio) 

workflow, the access will need to reference a folder—and not a state file. 

 Menu - Toggle to control the visibility of this step in the Edit menu. 

 Set Bookmarks - This is an advanced feature that allows you to set a 

bookmark for an asset when it enters this workflow step. The bookmark 

can then be used in other workflow steps to allow for an asset to return 
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to the bookmarked step. This means that documents can enter a 

workflow step randomly, and be assured of returning to their proper 

initial step. Consult with your CrownPeak Administrator if you think this 

feature might apply to your configuration. 

 Label - You can apply a text string to the beginning or end (or both) of an 

asset’s label when it enters the current workflow step. 

 Attributes - Check boxes allow you to determine if the asset should be 

set as deleted (and thus queued for deletion from the CMS), set as 

hidden (accessible via the hidden folders in the CMS only), or if a 

shortcut to the current asset should be created. In the case of a 

shortcut, a specific workflow step must be determined to place within 

the shortcut. 

 Variables - Enables you to define variables that are automatically set 

when the asset enters this step. In the example above, the asset will 

have the variable “spanish” set to “done.” 

 Workflow (“Change to”) - The drop-down menu lists the other available 

workflows from the workflow list, allowing you to transition an asset into 

a different workflow. This concept allows the use of “sub-workflows,” 

depending on your configuration. 

 Execute File - Provides a CMS selector to specify a file (ASP) to execute 

when an asset enters this step. Executing an ASP file would allow for 

custom operations on an asset that cannot be performed through other 

means.  

ROUTE SELECTION 

Besides configuring the workflow steps, defining the transitions between 

steps is the main task in configuring the workflow. To define a transition, use 

the Route Selection interface. It involves two steps. 

 

First you must select the type of transition. After making the selection, you 

will then need to configure the transition using the interface that displays. 
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ROUTE SELECTION: COMMAND - USER ROUTE PROPERTIES 

The Command transition is the most frequently used transition type. These 

transitions appear in the Edit menu, and are represented by options such as 

“Approve and Stage” and “Publish.” 

 When user selects - Using this text box, you specify the text of the 

command that will appear in the Edit menu. 

 Goto Step - The drop-down menu has a list of all the other Workflow 

Steps, allowing you to specify the target step for this command. 

 Use [drop-down] workflow filter - A drop-down menu with all the workflow 

filters is provided for purposes of defining an approval process that must 

be fulfilled in order for the command to execute. The option “None” is 

also provided in cases where no workflow filter is needed. 

 The check boxes allow for additional configuration of the command (and 

are self-explanatory). 

You can also access this interface by clicking on a command title in the 

diagram. 

 

 

ROUTE SELECTION: ACTION 

An action transition allows an asset to move to a new workflow step after a 

certain activity in the CMS has been performed on the asset. There are many 

actions to choose from, including “edited,” “published,” and “cloned.”  

A common use for this is to move a rejected asset back to the Draft step 

after it is edited. The asset may then move back through the standard 

approval process. 

 

The two drop-down menus allow you to specify the command that triggers 

the transition and the destination workflow step, respectively. 

Clicking on an action transition name in the diagram also brings up this 

interface for editing or deleting. 
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ROUTE SELECTION: SCHEDULE 

Schedule transitions allow for a transition to be executed when a specific 

schedule is met. This is commonly used for live dates or retire dates on 

content, but several other configurations are possible. 

 At [drop-down] - This drop-down menu (and the next one) sets the time 

interval. Available choices are “the same time as” and numbers 1 

through 20. The next drop-down menu allows an offset from the 

scheduled time. The units “months, weeks, days, hours” and 

“before/after” options are all available. When “the same time as” is 

selected, the second drop-down menu must be left blank. 

 The schedule name - Using the text box, you can specify the label for the 

time/calendar input that will appear in the Set Schedule interface in the 

CMS. 

 Goto step - Provides a drop-down menu to select the destination 

workflow step. 

Clicking on a schedule transition name in the diagram also brings up this 

interface for editing or deleting. 

 

 

ROUTE SELECTION: TIMEOUT 

Using a timeout transition, an asset can be moved from one workflow step to 

another—after the asset has spent a specified amount of time in the current 

workflow step.  

A common example would be a timeout transition after one week from the 

longer on the live site, but still visible in the CMS) to Archived (where the 

asset is now in a hidden folder), you can reduce overall clutter in your CMS 

folders. 

It is important to note that only a single timeout transition is allowed per 

Workflow step. 

 After [drop-down] [drop-down] - These two drop-down menus set the 

duration of the timeout. Options for the first drop-down menu are 1-20 

and “being.” Options for the second drop-down menu are blank, hours, 

days, weeks, and months. Using a configuration of “being” and “blank” 

would cause an immediate transition upon entering the workflow step. 

 Goto Step - This drop-down menu allows you to define the destination 

step for the transition. 
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Clicking on a timeout transition label in the diagram also brings up this 

interface for editing or deleting the transition. 

 

ROUTE SELECTION: CONFLICT 

The final transition type is a conflict transition. This specifies a transition to 

be executed if one of two possible outcomes occurs.  

First, if another asset in the same folder as the current asset—and using the 

same template as the current asset—enters the current workflow step, the 

transition will execute.  

The second is if another asset enters the current workflow step, and it is a 

branched asset, then the transition will execute.  

The first case is typically used for home pages represented by separate 

assets—when a new version of the home page is published, the old version is 

retired. The second case is part of the overall configuration of branched 

assets within your CMS implementation. 

The two drop-down menus specify the respective destination steps for each 

type of conflict. 

 

Clicking on a conflict transition label in the diagram also brings up this 

interface for editing or deleting the transition. 

PUBLISHING PROPERTIES 

Each workflow step may have publishing properties configured for it. This 

ties the publishing packages specified (using System > Configure > Package) 

to the workflow. If publishing is configured in a workflow step, the publishing 

will occur when an asset enters that step. 

A quick check of whether or not publishing is configured for a workflow step 

can be done by looking at the icons at the bottom of each workflow step 

column. 

 Indicates that publishing is not activated for the current step. 

 Indicates that publishing is active for the current step. 

Click on the icon to bring up the Publishing Properties interface. The image 

below shows an example of how publishing would be configured in a live 

workflow step: 

 Published On - Defines if the CMS Publishing Engine is active for the 

current workflow step. 
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 The other check boxes will vary depending on the number of publishing 

packages you have configured in your CMS. In the above example, 

content in the live workflow step will be published to the “Stage LISC 

Local Sites” package and the “Live LISC Local Sites” package, but not to 

the other two packages.  

 Here are a few scenarios to better describe the range of functionality 

possible using the Publishing Properties screen: 

1 Publishing ON, Stage ON, Live OFF: Publishing is active, content 

will be published to the stage package only. This is the typical 

configuration in the stage workflow step. 

2 Publishing ON, Stage ON, Live ON: Publishing is active, content 

will be published to the stage package and live package 

destinations. This is typical configuration in the live workflow 

step. 

3 Publishing ON, Stage OFF, Live OFF: This is the typical 

configuration for the retired workflow step. In the retired case, 

this would mean that publishing is active. However, the stage 

and live packages are set to off. Thus, the publishing engine will 

remove the content from the no-longer-selected packages 

because of the change in their selected status from the live 

step to the retired step. 

4 Publishing OFF, Stage OFF, Live OFF: Publishing is inactive, and 

the content in this state is not on any server. No publishing 

actions will be performed. This is the typical configuration for 

any workflow step prior to the publishing steps (e.g., Draft, 

Pending). 

5 Publishing OFF, Stage ON, Live ON: Publishing is inactive, but 

the content does exist on the selected package servers. This 

configuration is used in certain workflows where transitions are 

used to achieve other asset modifications, but no republishing 

actions should be taken. The “on” setting for the packages 

ensures that the proper publishing definition will be carried 

through. 

E-MAIL 

Your workflow steps can be configured to send e-mail to specified users 

when an asset enters that step. To view the e-mail configuration for a step, 

click on the   icon. 
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Through this interface, you may select users and/or groups who will receive 

e-mail notification that an asset has entered the current workflow step. The 

single arrows move the currently selected user or group in the desired 

direction, whereas the double arrows move the entire list. 

If your e-mail needs are complex, you may consider creating groups in the 

CMS that are “e-mail only groups.” This would constitute a group of users 

that has no real access permissions configured, but makes it easier for you 

to configure the e-mail recipient list. 

ADJUSTING WORKFLOW STEPS: INSERT, MOVE, DELETE 

At the bottom of each workflow step column, there are controls to adjust the 

ordering of workflow steps, as well as to expand or contract the workflow 

itself. 

Clicking on an icon will perform the desired action: 

 Moves the current step to the left in the diagram. 

 Moves the current step to the right in the diagram. 

  Deletes the current workflow step. 

 Inserts a new workflow step at this location. 
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WORKFLOW FILTERS 

Workflow filters are used within a workflow to provide additional control and 

structure to the flow of assets. By applying a workflow filter to a command in 

the workflow, you can control other aspects of how that command may be 

utilized and executed. 

The most common use of workflow filters is to define an approval process for 

content. Approval processes can be short or long, requiring single, multiple, 

or majority approvals prior to allowing an asset to move along in the 

workflow. 

 

CONFIGURING WORKFLOW FILTERS 

To view the list of Workflow Filters, go to System > Configure > Workflow 

Filters. 

 

 

 

 

 

 

 

 

The list shows the following information: 

 Usage - The number of assets currently controlled by the current 

workflow filter. 

 Name - The name of the workflow filter, used in the workflow 

configuration for identifying which filter to use. 

 Description - A short description of the workflow filter. 

 Modified By - The user who last modified the workflow filter. 

 Modified On - The date and time at which the workflow filter was last 

modified. 

From here, you create a new workflow filter, using the File > New Workflow 

Filter option, or select an existing workflow filter, and edit or clone it using 

the Edit menu. 
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The workflow filters use a “query builder” interface. This allows you to build 

up a multi-dimensional filter quickly using just a few fields. Because of this, 

workflow filters can vary greatly in complexity.  

Note: Feel free to experiment with your workflow filters to get the desired 

effects. 

  

 

 

 

 

 

 

 

 

 

 

 

NAME 

This field identifies the name of the workflow filter, used throughout the 

CMS. 

DESCRIPTION  

This field provides a brief explanation of the workflow filter. 

SEARCH FIELDS 

This drop-down menu gives a list of values and variables on which to base 

your filter. All system and template variables are included here, as well as 

settings for User clicks and Group clicks.  

By selecting a User or Group clicks, and structuring your criteria to where 

“Group clicks less than 1,” you would create an approval process where 

when a user in the specified group clicks on the workflow command that 

utilizes this Workflow Filter (for example, “Approve and Stage”), the filter 

would then evaluate to false, and execute the command. Users outside of 

the group specified would not see the command in their Edit menu. 

COMPARISON 
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The Comparison drop-down allows you to determine how the value of the 

variable will be evaluated. Several options are available, including greater 

than, less than, and null/not null. 

VALUE 

In the Value text box, you can enter the value you are comparing with the 

value of the variable. For the “clicks” variables, this should always be a 

number. For other variables, a text string is possible as well. 

BOOLEAN JOIN 

A Boolean Join allows you to create another level to the Workflow Filter. 

Selecting “AND” or “OR” adds a new row to the filter so that you may 

continue to build it until you are complete. To delete a line from the filter, 

clear out the Value, and return all drop-down menus to their initial entry. 
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FILE AND FOLDER PROPERTIES 

The File and Folder Properties collection of interfaces allow you to manage 

the individual characteristics of any folder or file asset in the system.  

Note: There is an incredible amount of power and flexibility in these settings, 

so be careful how you change things These settings are akin to administrator 

or root level permissions in other operating systems. 

The file and folder properties can be accessed by choosing View > 

Properties. The interfaces described below are context-sensitive, so you 

need to select an asset (file or folder) before you examine its properties.  

Keep in mind that if you are looking at a worklist/folder and have not 

selected an asset, the context is the current folder. This would be the same 

as if you were up one folder level in the hierarchy and had the current folder 

selected. 

These options are only available if you have the appropriate permissions in 

the File/Folder Access Properties for the selected Asset. 

ALSO APPLY PROPERTIES TO 

With the Also Apply To options you can apply certain configuration changes 

to related folders or assets. These options appear at the bottom of any 

relevant screen, and vary slightly between files and folders. 

File: 

 

 

 

 

 

Folder: 

 

 

 

 

 

 Siblings (File and Folder) - Changes are applied to all of the other assets 

in the same folder. 
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 Neighborhood (File only) - Changes are applied to all files at or below a 

specified path, which is configurable. When selected, the appearance of 

this option adds a text box:  

 

 

 Folder Children (Folder only) - All of the folders contained within this 

folder and their child Folders will have the same settings applied when 

changes are saved. 

 Templates (File only) - Changes are applied to all Files in the entire CMS 

that use the same template as the current File. 

 Models (not shown) - This sets the properties on all assets in the entire 

CMS that use the same model. 

 Labels (File and Folder) - This changes the properties on any asset in the 

entire CMS with the same name as the one you are currently working on. 

 Workflow (File and Folder) - Changes are applied to all assets using the 

same workflow as the current asset. 

If you select one of the above options, and click Save, a list of all the assets 

affected by the scope your selection is displayed: 

 

 

 

 

 

From this list, you can de-select any asset to which you do not want to have 

the changes applied. Click Save to then apply the changes you made to all 

the selected assets on the list. 

Caution: The Also Apply Properties To options make managing your asset 

properties very easy. However, use them with caution! It is very easy to make 

far-reaching changes to your entire CMS installation with just a few mouse 

clicks. Changes that you make cannot easily reversed (if at all), so be sure of 

what you are doing before you select any of these options. 

GENERAL PROPERTIES 

The General Properties allows you to examine a number of data fields 

internal to the CMS, including workflow, publishing, template, and uploaded 
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media information. In addition to choosing View > Properties > General, you 

can also right-click on an asset to access General Properties. 

Note: This is a “view only” interface. To modify any of the data, use the other 

properties interfaces (described in the next sections).  
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 Name - The name or label of the folder or file. 

 Type - File or folder. 

 Size - The size of the asset in kilobytes. 

 Checked Out By - This is the username of the individual who has the 

asset currently checked out. If it has not been checked out, the value 

will be “Nobody.” 

 Created By - The username of the person that created this asset. 

 Created On - The date and time when the asset was created. 

 Last Modified By - The username of the last person to have modified the 

asset. 

 Last Modified On - The date/time stamp set when the last operation was 

performed on the asset. 

WORKFLOW 

 Workflow Process - The name of the workflow currently assigned to this 

asset. 

 Status - The current Status (and therefore Workflow Step) that the asset 

is in. 

 Status Changed By - The username of the last individual to have 

changed the status on the asset. 

 Status Date - The date/time stamp of the last status change. 

 

UBLISHING 
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 Last Published By - The username of the last person that published this 

asset. 

 Last Publish Date - The date/time stamp of when the asset was last 

published. 

 Last Publish Size - The size of data published out, in bytes. 

 Published To - A list of files published out to the specified packages. A 

clickable URL (in blue) is also provided that will open a new window with 

the contents of the URL to help verify that the content is in place. 

 Current Filename(s) – The full path and filename for the current asset, 

along with the configured publishing packages. 

 Current URL(s) - The full URL of the current asset, along with the 

configured publishing packages. 

TEMPLATE 

 The full path of the current template. 

 Uploaded Media 

 Uploaded Assets - These are the assets that have been uploaded to the 

CMS and are used in conjunction with the asset whose properties are 

being viewed. For example, if you uploaded an image into the WYSIWYG 

field, it will be listed here. These assets are managed by the CMS along 

with the document, and do not appear in folders. 

ASSET IDS 

 Asset ID - The unique number assigned to the asset by the CMS. 

 ACL ID - A unique ID to refer to the ACL configuration (it is an ID in the 

CMS DB). 

 Base Model ID - The model that is used to let end users create this 

particular page type (using File > New).  Using GOTO and typing in the ID 

will show you the path to the model being used. 

 Branch ID - The ID of the original page from which the branch was made. 

When a page is a branch of an original, the branch ID will show in 

general properties.  

 Deploy ID - Database entry used mainly by CrownPeak backend 

engineers.  All the publishing information for an asset is stored in this ID 

in the database for debugging purposes. 

 Folder ID - The ID of the parent folder for this page. 

 Status ID - The ID of the workflow status/step the page is currently in.  
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 Template ID - The ID of the template folder this page uses. 

 Workflow ID - The ID of the workflow this page uses. 

ERRORS 

 Error messages will be displayed with respect to publishing this asset. 

ATTRIBUTES 

 Queued - Displays queued position in workflow. 

 Child Links - Assets to which this asset links. 

 Parent Links - Assets that link to this asset. 

 

META-DATA 

Meta properties allow you to assign values to assets to make them more 

easily catalogued and searched. This includes giving an asset a title (that 

may be different from its label), assigning it to a predefined category, writing 

a detailed description, and assigning keywords to the asset.  

The Meta Properties screen is accessed by selecting an asset and choosing 

View > Properties > Meta-Data.  

The Meta properties fields can be customized per installation, and apply to 

all Assets in the system. The following example is the default (minimal) set of 

Meta Properties fields: 

 

 

 

 

 

 

 

 Title - Enter the title you wish to give the asset here. 

 Category - Select the category you wish to assign to the asset. If an 

appropriate category doesn’t exist, you can either create one by 

selecting, new categories can be added by editing the metadata.asp 

template in the System folder. 

 Description - Enter a verbose description of the asset. 
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 Keywords - Enter a comma-delimited list of keywords. 

 

PUBLISHING 

Publishing properties are the configuration settings that determine where an 

asset will be published for staging and deployed live—as well as the filename 

that will be assigned to it.  

Access the Publishing Properties page by selecting an asset and then 

choosing View > Properties > Publishing.  

The deployment areas are broken down into Staging HTML, Staging Asset, 

Live HTML and Live Asset. The HTML destination is where the assembled 

page will go, and the asset destination is where any included files (like GIFs, 

JPGs, etc.) will be published.  

Note: Publishing properties can be controlled through either View > 

Properties > Publishing, or by the url.asp and filename.asp template files, or 

a combination of both.  The CMS will give a warning when it appears that 

code you put on the URL/filename template files conflicts with what you 

manually entered on this screen. 

 

 

 

 

 

 

 

 

 

 Package - This is a drop-down where you select one of the previously set 

up servers to publish to. 

 Path - This is the path/directory where you want the file saved relative to 

the root on the given server. 

 Filename - This is the filename you want the HTML/asset to have when 

saved. 

 Layout File - This specifies the file that contains information on how to 

display the HTML for formats besides HTML (like RSS, CSV, WAP, etc.).  
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The final file name and directory is determined by using these settings along 

with the system Publish/Deploy settings.  

Note: There is an optional Filename Template (documented in the CMS 

Developer Guide) that receives the final file location from theses settings, 

and can modify the path. If a Filename Template modifies the path, the 

settings you see here may not reflect the actual final URL. Use the General 

Properties interface described above to see the actual URL (file path) that 

will be used. 

 

ACCESS 

See the Asset and Folder Permissions section for details. 

 

TEMPLATE 

This page allows you to set the template for the selected asset. Access the 

Template Properties page by selecting an asset and choosing View > 

Properties > Template. 

 

 

 

 

 Name - This is the name of the asset that the template is being applied 

to. 

 Location - This is the path relative to the root of the asset that the 

template is being applied to. 

 Template Id - The unique number assigned to the template by the CMS. 

 Template Folder - This is the path relative to the root that contains the 

template that is being applied to this asset. 

The contents on the template folder are displayed to help identify what 

template files are available: 
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MODELS 

The Model Properties screen allows you to designate a folder for models 

within the current Folder. This provides a starting point for templates, 

permissions, etc., for documents in a new folder or new documents created 

within a folder. Navigate to the Model Properties page by selecting a folder 

and choosing View > Properties > Models. 

 

 

 

 Name - This is the name of the folder to which the model is being 

applied. 

 Location - This is the path of the parent folder of the folder to which the 

model is being applied. 

 Model Folder - This is the path to the folder that contains the model that 

is being applied to this folder. 

The contents of the Model folder are displayed to help identify which models 

are available in the specified folder: 

 

 

 

 

WORKFLOW 

The workflow properties allows you to assign a workflow to an asset. To 

assign a workflow, select an asset, then use the View > Properties > 

Workflow menu. Select a workflow from the list and Save the change. 

Workflow configuration is covered elsewhere in this document. 
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 Name - This is the name of the asset to which the workflow is being 

applied. 

 Location - This is the path relative to the root to which the workflow is 

being applied to. 

 Workflow - This is the name of the workflow that is being applied to this 

asset. 

 

CONTENT 

The Content Properties screen is a developer-level debugging tool that 

shows all of the content data for the selected asset. Data is shown as a list 

of name and value pairs. 

To access the Content Properties screen, select an HTML page, asset, or 

folder. Then choose View > Properties > Content: 

 

 

 

 

 

 

 

 

 

As an aid to developers, you can edit the fields directly by highlighting one 

and then clicking again. Changes take effect immediately and don’t need to 

be saved. 

 

OPTIONS 

The folder options allow customization of specific content folder, and allow a 

virtual folder (drawing content from other folders) to be established. This 

functionality may have performance issues since folder queries can now use 

content rather than system fields, and is reserved for use by CrownPeak 

technology staff. 
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ALERTS 

Alerts settings allow users to request e-mail notifications as documents 

move through their normal lifecycle. Please refer to the CMS User Guide for 

details. 

Note: Alerts are applied per user and per folder/file, so the changes you 

make to these settings only affect the current user. 
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ASSET AND FOLDER PERMISSIONS 

The asset and folder permissions are similar to most operating systems in 

that they allow differential access based on function and user groups. With 

CrownPeak CMS, this concept is significantly extended to allow a much finer 

granularity of permissions.  

Additionally, the CMS provides certain permission settings that permit you to 

manage the context-sensitive menus for Open, Preview, etc. For example, in 

the View > In Preview menu setting determines whether the selected item is 

available in the File > Preview menu. 

Asset and folder permissions can be accessed by choosing View > Properties 

> Access menu. The sub-menus and dialog boxes (described below) are 

context-sensitive, so you must select a file or folder in order to examine its 

properties. 

Note: If you are looking at a worklist or folder, and have not selected an 

asset, the context is the current folder. This is the same as if you were up 

one level in the folder hierarchy and had the current folder selected. 

 

ACCESS PROPERTIES 

The Access Properties screen allows you to set specific permissions for the 

selected item: 

 

 

 

 

 

 

 

 

 

GROUPS 

The Groups header applies to both the horizontal and vertical axes. Along 

the horizontal axis is a listing of access groups, with the vertical axis 

representing user groups. 
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Each access property is placed within one of five access groups. These 

groups (View, Edit, Launch, Properties, Other) represent the main types of 

functionality available within CrownPeak CMS.  

The user groups are a listing of every available user group in the system. 

Because assets and folders can be utilized by all users, the access 

properties for individual assets and folders are abstracted to the user group 

level. This balances the ability to be highly granular in the application of 

access controls with the need for scalability and efficient modification. The 

intersections of the access groups and user groups are where the individual 

permissions are set within the matrix. 

EVERYONE ROW 

The Everyone row refers to all the user groups as a single group. Toggling a 

property in the Everyone row sets or unsets that property for all user groups, 

allowing for a rapid configuration. 

It is important to note that there is a difference between using the Everyone 

check box to toggle permissions for all user groups on a specific permission 

and individually selecting those permissions for every user group. If the 

Everyone check box is active, then not only do all current user groups have 

that permission, but so do all newly created user groups. However, if you 

have selected the user groups individually, without using the selector, newly 

created user groups will not have that permission, and will have to be 

manually added. As you configure the access properties for your installation, 

you should consider which scenario will be best suited for your ongoing 

needs. 

TABS, ZOOM, AND SETTING PERMISSIONS 

In its default state, the Access Properties interface presents five columns of 

permissions. Because the range of access properties that can be set would 

be far too vast to display at once, each access group header functions as a 

“tab.”  

Clicking on the header’s title (the tab) expands (zooms in on) the column to 

display the detailed properties for that access group. Clicking on the tab 

again zooms out, returning you to the initial view. Additionally, clicking on a 

separate tab while another tab is open will zoom in on the new tab, while 

zooming out on the old tab. While you are zoomed in on a tab, the color of 

the other cells is muted and their check boxes removed so that only 

permissions in the current tab may be set. 

By using the zoom feature, access properties can be configured in a general 

or detailed manner. Selecting a check box when an access group is zoomed 
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out toggles all component permissions for that specific property for the 

specified user group. To control the detailed setting of properties, simply 

zoom in to reveal all the component permissions. The Everyone row 

functions the same in zoomed in or zoomed out modes. 

COLOR CODING 

The cells that make up the Access Properties Matrix are all color-coded, 

representing the following: 

  The user group is allowed to perform this action. 

 
  The user group members can only perform this action on their own 

assets. 

  The user group cannot perform this action. 

  There are mixed permissions in this Access Group for this user group. 

Expand (zoom in) this Access Group to view/change individual permissions. 

(Note that this color only displays when an Access Group is zoomed out. 

Additionally, no check box is displayed for cells with this color.) 

  The user group is not configured to perform this action. 

  

VIEW 

View Access Group controls the ability to see an asset or folder within the 

system, or external to the system (by allowing/disallowing the ability to 

download). For example, the View Access Group may be used to restrict the 

viewing of sensitive content to only specific groups of users. Another 

example is to use the View permissions to restrict separate groups of 

authors to their own content areas. 

VIEW 

This controls whether the specified user group(s) can see the current asset 

or folder.  

Note: Be careful not to turn this off for your group, otherwise you will not be 

able to see the asset or folder again. 

IN OPEN MENU 

This controls the presence of the current folder in the CrownPeak CMS File > 

Open menu (folders only). 

IN PREVIEW MENU 
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This controls the presence of the current asset or folder in the CrownPeak 

CMS File > Preview menu. 

DOWNLOAD 

This controls whether members of the user group may download the current 

asset to their system (assets only). 

 

NEW 

NEW FOLDER 

This controls whether a new folder may be created in the current folder 

(folders only). 

NEW UPLOAD 

This Controls whether a new file may be uploaded in the current folder 

(folders only). 

NEW MODEL 

This controls whether a new asset may be created based on the models 

assigned to the current folder (folders only). 

NEW DEPENDENCY 

This controls whether a new asset may be created based on a dependency 

established by the assets and their associated templates in the current 

folder (folders only). 

 

EDIT 

The Edit Access Group contains all permissions related to the modification of 

an asset or folder. 

EDIT 

For assets, it controls whether the current asset may be edited. For folders, it 

controls whether the contents of the folder may be edited. 

CHECKOUT 

This controls whether the content may be checked out of the system, locking 

it from further use by other users until checked in (assets only). 

SHORTCUT 
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This controls whether the asset may have a shortcut created for it. Shortcuts 

function similarly to Windows Shortcuts, allowing an asset to be referenced 

in multiple places within the CMS (assets only). The shortcuts may have 

different workflows, but share the same content. 

RENAME 

This controls the ability to rename the current asset or folder. 

DELETE 

This allows the current asset or folder to be deleted by the specified user 

group. 

MOVE 

This allows the current asset or folder to be moved from its current location. 

COPY 

This allows the current asset or folder to be copied. 

 

PUBLISH 

PUBLISH 

This allows the current asset or folder to be published to the specified stage 

or live server(s). 

RE-PUBLISH 

This allows the current asset or folder to be re-published to the specified 

stage or live server(s). 

SCHEDULE 

This allows publishing to be scheduled for the current asset or folder. 

 

PROPERTIES 

GENERAL 

This allows the specified user group to view the General Properties of the 

asset or folder. 

SET TEMPLATE 

This allows the specified user group to set the template for the current asset 

(assets only). 

SET WORKFLOW 
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This allows the specified user group to set the workflow (from the list of pre-

defined workflows) for the current asset or folder. 

VIEW META 

This allows the specified user group to see Meta information defined for the 

current asset or folder. 

SET META 

This allows the specified user group to define Meta information for the 

current asset or folder. 

SET PUBLISH 

This allows the specified user group to configure publishing and deploy 

settings for the current asset or folder. 

SET ACCESS 

This allows the specified user group to configure the access properties for 

the current asset or folder.  

Note: Be sure not to deactivate this setting for your user group, otherwise 

you will not be able to change the properties for this item again. 

SET MODELS 

This allows the specified user group to select a model folder for the current 

folder (folders only). 

SET ALERTS 

This allows the specified user group to set alerts (e-mail notification about 

asset or folder status changes) for the current asset or folder. 

VIEW DEPEND 

This allows the specified user group to view the dependencies for the current 

asset or folder. 

VIEW CONTENT 

This allows the specified user group to view the content properties (a listing 

of all content in the database) for the current asset or folder. 

SET ZIP IMPORT 

This allows the specified user group to set zip import for the current folder. I 

don’t think this is in the product any longer? 

 

OTHER 
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AUDIT 

This allows the specified user group to view the system and publish history 

(operations performed on) of the current asset or folder. 

VERSION 

This allows the specified user group to view the versions of current asset, 

allowing for a possible rollback if needed (file assets only). 

COMMENTS 

This allows the specified user group to view and make comments (including 

page annotations on file assets only) on the current asset or folder. 

SIMILAR  

This allows the specified user group to view assets similar to this one. 

 

ALSO APPLY PROPERTIES TO 

Asset Dialog Box: 

 

 

 

 

Folder Dialog Box: 

 

 

 

 

To allow for a broader configuration of access properties, the current 

settings may be instantly applied to an additional subset of assets and 

folders. In this manner, permissions can be quickly configured or edited for a 

large portion of CMS content (the subset selections vary slightly between 

assets and folders). 

It is important to note that all of the current access properties are replicated 

to the selected subset and not just updates made in the current editing 

session.  



 

ENSURING YOUR WEB CONTENT SUCCESS – PAGE 64 

Caution: You should exercise caution when selecting a subset. You can 

rapidly change the configuration of large sections of your system when using 

them and there is no “undo” feature. 

SIBLINGS 

 File assets - Apply the current access properties to file assets in the 

same folder as this asset. 

 Folders - Apply the current access properties to folders in the same 

folder as the current folder. 

NEIGHBORHOOD 

 Assets only - Apply the current access properties to all assets in the 

same folder as this asset, and all assets in the folders next to and below 

this asset. 

CHILDREN 

 Folders only - Apply the current access properties to all folders within the 

same folder as this folder, and all folders below this folder. 

TEMPLATES 

 Assets only - Apply the current access properties to all assets based on 

the same template as the current asset. 

MODELS 

 Folders only - Apply the current access properties to all folders based on 

the same model as the current folder. 

LABELS 

 Assets and folders - Apply the current access properties to an 

asset/folder with the same name as the current asset/folder. 
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SYSTEM, SERVERS, AND PACKAGES 

CrownPeak CMS allows the entire system and server configuration to be 

performed via the Web interface. This allows for rapid setup and 

configuration changes to your installation. Note that many of the server 

configuration options will not be relevant to your particular implementation, 

so they can be ignored. The most common configurations are for the HTTP 

and FTP servers. 

 

SYSTEM 

The system configuration dialog box allows you to modify some global 

settings for your CMS instance. It can be accessed by choosing System > 

Configure>General. These options are not normally available to CMS 

Administrators and are typically reserved for CrownPeak Technology staff 

and development partners. 

 

 

 

 

 

 

 

 

 

 

 

 

 Default E-mail Sender – Used to set the From: address for any e-mail the 

CMS sends to users (alerts etc.). You can set this so that replies go to 

the most appropriate person in your organization (usually the CMS 

Administrator).  

Note: Only one address can be specified. Contact CrownPeak 

Technology if you need more than one. 
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 Account Alert E-mail Address - Should be set to the CMS Administrator. If 

you do not have an appropriate person in your organization, you can set 

it to support@crownpeak.com, and CrownPeak Technology will respond 

to system messages. Again, only one address can be specified. 

 Mail Server - Allows a different system to be used as the mail host. The 

normal value for this field is mail.crownpeak.com. 

 Lock Expiration - Sets the number of hours that must pass before an 

inactive locked file is released. 

 Live Website URL - Used to set the URL for the live site. It is the URL that 

is displayed when Live site is selected from the File menu. 

 Stage Website URL – Used to set the URL for the stage site. It is the URL 

that is displayed when Stage site is selected from the File menu. 

 Default Scripting Language - Can be set to VBScript or JScript. 

 Error E-mail - Should be set to the appropriate person in the organization 

to receive error messages from the CMS.  

 Support E-mail - Should be set to the CMS Administrator. If you do not 

have an appropriate person in your organization, you can set it to 

support@crownpeak.com, and CrownPeak Technology will respond to 

system messages. Only one address can be specified (contact 

CrownPeak Technology if you need more than one). 

 Support Telephone - Should be set to the CMS Administrator. If you do 

not have an appropriate person in your organization, you can set it to 

310 577 5850, and CrownPeak Technology will respond to system 

messages.  

 Document State Selector – Check box allows you to toggle this feature 

on and off. If it is on, it will display the state selector in the lower right 

hand corner of the “Preview” mode. 

 Similarity Engine - Check box allows you to toggle this feature on and off. 

 On icon click or double click show - Allows you to select which of the 

following should occur with these actions: Preview, Edit, General 

Properties, Content Properties, and Comments. 

 

SERVERS 

The Server configuration dialog boxes allow you to configure the connection 

to servers used in publishing. In most cases, the server is also given a name 
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to be used elsewhere in this system. This approach allows you to make 

changes in the server back-end without re-configuring the templates etc. 

Note: All of the panels in this section allow multiple entries: Each time you 

save one line, a new one will be added. 

FTP 

The FTP configuration is very important since the CMS publishes all 

documents using FTP. Most implementations will use the FTP configuration 

and none of the others. You can set up several FTP server configurations for 

the same server, possibly with different root paths, to allow for different 

publishing locations or different file asset folders. You can access FTP 

configuration by choosing System > Configure > Export > FTP. 

 

 

 

 

 Name - Used to identify the server in other parts of the system, 

particularly for Packages in the next section. 

 Hostname - Contains a name or IP address for the FTP server. 

 Username and Password – These fields specify the FTP login 

information for the FTP server. Make sure that the given account has 

write access to the folders being published to. 

 Root Path - Allows you to set the CMS root path relative to the FTP root. 

This serves two purposes. The first use is that the root path is added to 

file names when being published, thus pushing all documents into the 

designated directory. The second purpose is that file asset folders that 

use the FTP system for asset management will restrict users to the Root 

Path folder. 

 Use Active Mode - Allows you to set active or passive connection for FTP 

connection. This may be necessary for servers with firewalls. 

 You can also set read, write, and execute access for Unix systems. 

HTTP 

The HTTP and SOAP configurations allow the CMS to publish data via Web 

services. On the receiving end, the Web services are essentially CGI scripts 

that take the HTTP submission and do some local processing.  
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The main difference between the HTTP and SOAP approach is that HTTP can 

use a custom (defined by your implementation) command and data protocol, 

while SOAP uses XML to identify the data fields and define commands. You 

can access the HTTP configuration screen by choosing System > Configure > 

Export > HTTP. 

Typically, your local technical staff will maintain the gateway to give you 

maximum control over your local database. To fully implement these 

approaches, please consult with CrownPeak Technology. 

 

 

 

 

 Name - Used to name the server in other parts of the system, 

particularly for packages in the next section. 

 URL - The full URL for the gateway CGI script (Web service URL). 

 Username - The basic authentication username if the URL is password 

protected. 

 Password - The basic authentication password if the URL is password 

protected. 

 Timeout - The maximum time to wait for a response from the URL. 

 Cookie - The cookie string to use when accessing the URL in the form on 

name-value pairs. 

 Method - The HTTP method determines whether the CGI calls will use 

the GET or POST method. 

 Results Encoding - The method to process the results returned from the 

HTTP transaction. 

SMTP 

The SMTP configuration configures CMS publishing to E-mail. You can 

access SMTP configuration by choosing System > Configure > Export > 

SMTP. 
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The exact use of this approach requires CrownPeak Technology involvement, 

so please contact CrownPeak Technology for details. 

 Site Name - Used to name the server in other parts of the system, 

particularly for Packages in the next section. 

 To Address - The e-mail address to send the message to. 

 From Address - The e-mail address specified as from in the e-mail 

message. 

 Subject - The subject of the e-mail. 

 Content Type - The e-mail message content type. 

ODBC 

CrownPeak CMS can also publish data via ODBC. It is recommended, 

however, that you use the HTTP or SOAP protocols since these protocols are 

more robust across the Internet (only require Port 80, and are transactional 

in nature). You can access ODBC configuration by choosing System > 

Configure > Export > ODBC. 

 

 

 

The exact use of this approach requires CrownPeak Technology involvement, 

so please contact CrownPeak Technology for details. 

 Site Name - The name field is used to name the server in other parts of 

the system, particularly for packages in the next section. 

 Type - The driver type for the ODBC connection. 

 Server - The database to which the server is connected. 

 Username - The ODBC username to use to connect. 

 Password - The ODBC password to use to connect. 

 Database - The name of the database to which you want to connect. 

 

PACKAGES 

The Publish/Deploy configuration allows you to create names for each 

server, and designate them for stage publishing or live deployment. The 

actual Publish/Deploy path and filename is configured in the asset (or 
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model) permissions. In addition to these settings, the Filename Template 

can also override or modify any of the Publish/Deploy settings in the system.  

Use the General Properties of an asset to determine the actual final 

filename and path. 

Note: The panel in this section allows multiple entries. Each time you save 

one line, a new line is added. 

 

 

 

 

 

 

 Name - The type can be either Stage or Live, depending on where the 

content will be published. 

 FTP, HTTP, SOAP, SMTP, and ODBC Servers - The server drop-down 

menus allow you to tie the name to one of the predefined servers by 

name. Only one can be chosen at a time, but more than one can be 

created for dual output publishing. 
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TOOLS 

The System > Tools menu provides some global commands, which are 

typically only available to Administrator-level users. These utilities are used 

for development purposes—and not in the day-to-day administration of the 

CMS. 

REFRESH STAGE 

Any document with a status of Staged will be republished to the stage 

server. 

Note: This will create a large publishing task since many assets need to be 

assembled and published. 

 

REFRESH LIVE 

Any document with a status of Live will be redeployed to the live server. 

Again, this will create a large publishing task since many assets need to be 

assembled and deployed. 

 

SET DRAFT TO STAGE 

This function changes the status from Draft to Staged for any asset in the 

draft state. Assets will not be published. You should use the Refresh Stage 

command to publish all the asset to the Stage state. 

 

SET STAGE TO LIVE 

This function changes the status from Staged to Live for any asset in the 

staged state. Assets will not be published or deployed. You should use the 

Refresh Stage or Refresh Live commands to publish or deploy all the assets 

to the Stage or Live state. 

 

RESUBMIT ASSETS 

The assets in the current folder are resubmitted as if you edited and saved 

each one. This is useful for pushing content back through the post_input.asp 

template file. 
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CONFIGURING MENUS 

When implementing CrownPeak CMS, the user experience can be 

customized to a great degree. One of the areas of customization is tuning 

many of the program menus. When the menus are carefully configured, the 

CMS becomes more productive to the end users. 

The following sections describe all of the areas where you can customize the 

system menus and the technique for setting up each one. 

 

HELP 

In addition to the system Help menu items, you can add your own local help 

to assist your CMS users. The Help menu is available to CMS administrators 

as a folder so that you are able to directly manage the help content. 

 

HEADER 

The top header of the CMS is an HTML file with associated graphics. 

Currently, the process of updating the header involves making an HTML file 

for the new header, and sending the files to CrownPeak Technology for 

installation. 

 

PREVIEW 

The Preview menu is a convenience to allow users to navigate around the 

managed content of the site in Preview mode. You can control which content 

types are in the Preview menu using the folder properties. Preview is 

available for both file and folder assets. 

 

 

 

 

 

 

OPEN 
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The Open menu allows users to jump directly to content folders in the 

system. Like the Preview mode, folder properties are used to set whether the 

given folder is included in the Open menu. The Open properties are only 

available for folders, not files. 

 

 

 

 

 

 

NEW 

The New menu is populated with models when specific folders have the New 

Model Access Property set. To set up a press release in the system, for 

example, you need a folder to hold the releases (say, /Press Releases/). You 

also need a model folder and model press release (say /Models/Press 

Releases/Press Release).  

In this example, the Models folder holds all of the system models (by 

convention); the Press Releases folder holds the models for new press 

releases; and there is a single file asset: Press Release. The /Press 

Releases/ folder, then, should have its model properties set to 

/Models/Press Releases/, and its New > New Model Access Properties 

turned on. The “/Models/Press Releases/Press Release” file is a blank 

upload with the template and permissions pre-configured. 

 

 

 

 

 

 

DEPENDENCIES 

Dependencies are not a separate menu item, but are related to the New 

menu. If you set the New Dependency flag for a folder, then any assets in 

that folder that link to other assets will cause the secondary assets to also 
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appear in the New Menu, provided the user has access to the secondary 

asset and the secondary asset folder has its New Model flag set.  

This is useful in Preview mode where you may have an index page (for 

example, Home Page) that refers to several content types. When you are in 

Preview mode, all the content types will appear in the New Menu, allowing 

you to create a new item in any of the types you see referenced in the index 

document. 

 

 

 

 

 

 

LIVE SITE 

The File > Live Site menu is a convenience link to pop up a new browser 

window pointing to the Live site being deployed to by the CMS. The Live site 

link is set in the System Properties configuration dialog box. 

 

STAGE SITE 

The File > Stage Site menu is a convenience link to pop up a new browser 

window pointing to the Stage site being published to by the CMS. The Stage 

site link is set in the System Properties configuration dialog box. 
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STRUCTURING THE CMS AND MODELS 

CrownPeak CMS offers many ways to structure your content and templates. 

Using input forms and folders, you establish how users view the content. The 

structure can reflect your Web server directories or not, depending on your 

particular needs. 

The following sections give an overview of configuring folder structures and 

models, and more information can be found in the Template Design Patterns 

document and the CMS Developer Guide. 

 

STRUCTURING FOLDERS 

Folder structure in the CMS is very flexible; you can chose to follow the Web 

server structure or choose a different scheme, depending on the how the 

content authors actually conceptualize your information. With CrownPeak 

CMS, the structure of the folders can be completely decoupled from the site 

structure if you want, with the CMS making sure content gets into the right 

place on your Web server. 

CATEGORIZING CONTENT: INPUT FORMS VS. FOLDERS 

If your content needs to be categorized, you can either provide input form 

fields, or use folders to allow for categorization. Using folders makes sense 

when the assets have only one parent for the given category, or if you want 

the categories to be part of the path on the Web server. In this case, the 

folder names can be used as part of the filename. Using input forms for 

category control makes sense when you have several categories, or when 

you have multiple selections from a single category list.  

WEB SERVER DIRECTORIES VS. CMS FOLDERS 

The folder names can also be used to match Web server directories if you 

want. If you choose this approach, the package configurations can be easily 

used to set up the final file path names. 

FOLDER PER PAGE VS. ASSET PER PAGE 

For a group of related pages such as press releases, it makes sense to have 

one folder hold all of the editions of that content type. In the folder, you will 

have all the releases—including those being worked on as well as live ones. 

This allows you to see the status of the section at a glance. 

For sections of the site that have a single page (such as the Home Page), 

you need to decide if you want to have a single asset that you keep editing 
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and deploying, or whether you want a folder to hold all the editions of the 

Home Page.  

In the latter case, each page of the site becomes a folder in the CMS. You 

can also mix and match these approaches, depending on how often certain 

pages change. For fairly static pages like an About Us page, or Privacy Policy, 

you may choose to have them all as single assets in one “miscellaneous” 

folder. For sections like the Home Page (assuming it changes weekly or 

monthly), you would set up a folder. 

 

MODELS 

Like a folder that holds file assets, the Models folder is a regular folder when 

it is created—but when used it becomes a very powerful tool within the CMS.  

Webster defines a model as “a usually miniature representation of 

something; also: a pattern of something to be made.” This is an accurate 

description of what a model directory contains in the CMS: It can hold a 

representation of a combination of empty or partially populated files and 

folders. 

The most common usage for the Models directory is for the creation of new 

files. If you create a new file without a model of that file, you will get a blank 

file with no input fields. For every content type that exists within the CMS 

that needs to be duplicated more than once within a directory, a model 

should be created.  

In the Models folder, you are not limited to just one file or even one folder; 

you can have several models to allow for different versions of the same 

content type. For example, you might want to have a short or long form of an 

article.  

The model also carries the access permissions as well as any boilerplate 

content within the model assets. For example, a field could have standard 

content such as an address field that seldom changes; however, when it 

does the content is simply edited by the content author. 

CREATING A MODEL 

 

 

 

Models are setup off the root CMS folder by convention. When the model 

directory has been set up, it is usually best to organize the individual files 
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and folders into their own section folders, which will help in their 

organization.  

Once the folder is created, you can then copy in sample files and folders 

(configured with templates and workflow) to serve as the model assets.  This 

is also a good time to check if the preliminary access rights are correct so 

that the correct groups can view, create, and edit new assets based on these 

models. 

When creating model structures, it sometimes helps to draw a diagram of 

the dependencies to help organize the folders. 

SETTING THE MODEL ON A DIRECTORY 

To set a directory for a model: 

1. Select the folder (files cannot have models). 

2. Choose View > Properties > Models. 

 

 

 

 

The Model Properties window appears.  

 

 

 

 

 

3. Type the name of the folder that contains the model file(s) in the Model 

folder input box and click Save.  

Note: The second part of this form only appears after you have saved the 

model.  

Once the model is saved and you return to the Model Properties screen, a 

second panel shows up which allows you to conveniently select the model 

assets and check the asset permissions. After you setup the models, test 

them out by using the File > New menu. 

DEPENDENCIES  
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Dependencies are interrelated with models. A dependency is the relationship 

between the various assets and their links to each other. If a model is set up 

in one folder and the file is linked internally from another folder, that folder 

acquires the model in the File > New menu, even if the View > Properties > 

Model is blank. 

There are times, however, when this feature is undesired, and in this case 

there are two ways to turn off dependencies. The first is by setting the 

permissions on the model asset so that certain user groups do not have 

access to that model. Under View > Properties > Access, you can see if 

“everyone” has View enabled. If, for example, you do not want the user group 

“Freelancers” to have access to that model, simply de-select the view. 

 

 

 

 

 

 

 

The second way to disable dependencies is to turn off dependencies directly 

on the folder itself. Use the View > Properties > Access menu after selecting 

the folder. This time, under the folder view, we are accessing the New group 

as opposed to the view group in the file. Again, de-select both New Model 

and the New Dependency on the various groups that you do not wish to have 

access to the model.  

This process will take some fine-tuning and you may want to have a second 

browser open with a sample user account logged into test the settings. Be 

sure to open a new instance of IE when working with two accounts since 

your cached information will carry along if you use a new window. 
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